Question about Kenmore 25512/ 25513 Progressive Canister Vacuum

Open Question

My vacuum is a Kenmore Special Edition with a Power-Mate 12.0 AMPS wand. I ran over the edge of fringed edge of my living room carpet and immediately turned off the vacuum. Although I have removed the fringe pieces from the wand head and I have pushed the overload protector reset button on the wand, the wand brush will not turn. Help- it's the Thanksgiving weekend and guests are coming soon! Thank you.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Kenmore Progressive Model # 116 25914507

I had the same problem with my vacuum. I called in for technical service and was told to push the "reset button". It turns out that there is a small red button right next to the dirt indicator light. I pushed the button, plugged the vacuum back in and started it up and it worked like a charm! :) Hope this helps!

Posted on Mar 26, 2008

Ad
  • 1 Answer

SOURCE: No power to head of Kenmore Progressive canister vac

The extension wands are defective and have trouble with their plug connectors on each end. The power head has a reset button on top right but no lights mean no power which means the wand isn't connecting the power to anything.

Sears has a new replacement -- too bad it isn't recalled so you could get it for free ($106.59 + tax + shipping). 2nd sweeper -- same problem.

1st sweeper: I just took needlenose pliers and pulled connectors out a little further (Too bad I can't seem to make the 2nd sweeper work with this easily. It might be one of the connectors or the wiring harness inbetween with a break.) Can't buy the wiring harness for this or connectors, just the wand.

If anyone has a working wand you want to sell me email me at hiwhatsnew@hotmail.com. Thanks!

Posted on Jun 12, 2008

Agent Don
  • 310 Answers

SOURCE: Hi, I have an electrolux Ambassador

http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=678083
Generic problem for all Vacuums
Hi, I have an Electrolux Ambassador
Posted by greenforest on Jun 17, 2008
Hi, I have an Electrolux Ambassador and the other day I was vacuuming a fringe carpet and the fringe made the Electrolux stop (has happened before) and when I pressed the reset button, the motor is on but the wheel does not spin. Any suggestions?

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. There are 2 possibilities that could be happening. Either the belt is broken of which you can replace the belt @ least one a year for proper maintenance or there may be a reset for the vacuum in case you get something caught in the brushroll section of the vacuum. Check both of those items and it should work unless you have a motor burn out – if you did there would be a burning smell. Feel free to contact your local vacuum cleaner dealer in your area.

So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://electrolux.com/ Customer Service 1-800-896-9756
Electrolux Home Care Products – North America
P.O. Box 3900 Peoria, IL 61612
Thanks, Don the Vac Man
Go Ahead. Use Us.

Posted on Jun 17, 2008

advacak
  • 125 Answers

SOURCE: kenmore 116 bagged canister vacuum

something is jamming the brush roller, or the bearings are seised

Posted on Dec 03, 2008

  • 134 Answers

SOURCE: Wish to remove bottom ofpowerhead-Kenmore Progressive 11629912990

I have a whispertone vacuum, different model #, but maybe instructions will be the same. Turns out I didn't need a new belt, just clean out the crud and reset overload protector. The instructions in the manual tell you to remove the light cover and bulb first. To do this, press in and lift both sides. Push in and turn bulb counterclockwise to remove. (you need to do this because the next step involves turning the unit over). This takes you to
Step 2. Unscrew the cover screws ( on either side of bulb).
Step 3. Turn unit over. To remove cover, insert screwdriver at cover tabs on both sides and twist to release tabs.
Step. 4 Turn unit right side up. Press handle release pedal and lower the swivel. Tilt cover forward from back until front snaps free.
Step 5. Carefully insert and twist screwdriver at each brush support to free brush from base.
Step 6. Remove worn belt.
Step 7. Slide brush supports off to check and clean brush support areas.

To replace belt: slide washers and brush supports onto brush assembly.
Install new belt over motor drive, then over brush sprocket.
Snap brush supports into place on base. Be sure brush supports are not upside down.
Line up front of cover and base. Rest cover on front edge of base. Tilt cover to back. Press cover firmly until side tabs snap into place. Replace cover screws, light bulb and light cover.

Posted on Mar 12, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

While using the power mate rug part I caught a small rug and the vacuum would no longer pick-up .


Check to see if there is a reset button on the head. This protects the machine for times like you described. When something jms up the reset button will turn ofdf th machine. Simply push the reset. Hope this helps, Chris

Feb 07, 2011 | Kenmore Vacuums

1 Answer

My power mate keeps losing power. As I am vacuuming, it surges off and on. The rest of the vacuum works perfectly fine. help!


Remove the wand from the telescoping pole, and look at the two holes in the wand where the electrical connection is made between the wand and the pole. You may see corrosion, which will cause the connection to be flaky and the power assist to surge on and off.

In any case, a good bet is that the wire harness in the wand needs replacing. It's about $15. (P/N KC37GBZTZV06) You'll have to take the wand apart - 3 screws and some judicious prying - to replace it.

Dec 28, 2010 | Kenmore 25614 / 25615 Progressive Bagged...

2 Answers

We have a Kenmore canister vacuum cleaner. the carpet cleaning attachment, I think is called the power mate has a beater that is intermittently working now


Your hose could be bad. The wires frequently go bad up by the handle switch. also could possibly be the wand, those go bad. You can check that by attaching your powermate directly to the nozzle without the wand and see if the same problem is there. Do you have the mini powermate also? the one that is usually mounted on the wand. If so plug that in directly to the hose and see if you have the same problem. If that tool works fine then the problem is in the powerhead.

Jan 03, 2010 | Kenmore 23812 Progressive PowerMate Bagged...

1 Answer

I have a Kenmore canister vacuum cleaner. The


check the reset button or the wire that goes into the powermate sometimes it frays and breaks

Dec 29, 2009 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

Vacuum not picking up dirt


The neck in your power head is likely clogged. Disconnect from the wand and look inside. Also check the wand.Since you have suction on the bare floor the hose is likely not blocked.

Sep 11, 2009 | Kenmore 22512 Bagged Canister Vacuum

1 Answer

Canister motor not on - power to power mate is on


if its a long plastic tube with snaps on it that is where the fuse is.open it up and you will find the fuse

Apr 28, 2009 | Kenmore 25512/ 25513 Progressive Canister...

5 Answers

Kenmore vacum wand power cord


http://www.vacsew.com/vacuum-cleaners/kenmore-vacuum-parts.html/

Try here

Jul 16, 2008 | Vacuums

2 Answers

Carpet attachment


Check the plug ends at the top of the wand and the plug going into the hose handle, also at the bottom of the wand. It sounds like they may be burnt, if so they will need to be replaced. One cause of these connections going bad is not turning the power head off when connecting or disconnecting. Therre are other causes, the switch in the handle is going bad, also some of these cannisters have a relay mounted by the vac motor, sometimes they go bad.

Mar 12, 2008 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Carpet function rollers don't turn


Most likely a broken belt. If the brush roll is turning freely, then check the belt.

Mar 02, 2008 | Kenmore 25812 / 25813 Progressive Bagged...

2 Answers

Losing power to stick/floor vacuum


if you have an extension wand, the replacement will cost about $100.00. there is a way to repair both the pwr-cord on the brush assemble and the wand, but it depends on how much damage there is. also you need to check the contacts where the wand connects with the handle,and the prongs on the handle.

let me know if you still need help

Jan 11, 2008 | Kenmore 25614 / 25615 Progressive Bagged...

Not finding what you are looking for?
Kenmore 25512/ 25513 Progressive Canister Vacuum Logo

Related Topics:

145 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76649 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...