Question about Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out, Center Discharge, 240V, w/Hair & Lint Pot

1 Answer

I turn my pump on, it starts pumping then about 10-15 sec it shuts off. Doesn't seem as loud or pulling pressure either.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Contributor
  • 44 Answers

Check the label and then the wiring on the motor to see if you are wired 120 or 240 first. If you are supposed to get 240 and are getting 120, the motor will run @ 1/2 speed for a little while and then shut off. If this continues, your motor will short out. If your motor is getting 240 volts while running, you have a bad motor.

Posted on Oct 09, 2010

  • Jerry Davis Dec 12, 2012

    Check the start switch. Do not need a new motor for that. May just be corroded.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Corolla NZE. It runs for a few secs when starting then shuts off. What's wrong?


Could be that your fuel pump is going bad? Have the fuel pump pressure checked, the average fuel pump pressure is around 40 to 45 PSI, anything less and the car will stall or stop.

Jun 07, 2015 | Toyota Cars & Trucks

1 Answer

My 95 gmc wont start when hot


check the fuel pressure regulator for leaks it may divert the fuel when warmed up,check all vacuum hoses for cracks if you think it's bad change it. turn key on and wait 30 sec.then crank and see what happens,fuel pump may be getting hot.if you can check fuel pressure at the rail for at least 35 psi.you can do this by removing the schrader valve and attach a hose with gauge.you should be able to hear the fuel pump for a few sec.when you turn the key on. try this when cold then hot see if you notice a differance.it seems to relate to a fuel problem.hope this helps,dave

Apr 13, 2014 | 1995 GMC Sierra

1 Answer

Unit starts with normal screen,. pump motor doesn.t start and specticle shaped figure flashes next to Systolic upper LH corner. of display. Flashes for approx 5 secs and turns off.. Changed batteries same...


Motor is burned out, wires to motor are not connected. The pump MUST start to begin the sequence of "events". Repair or replacement is necessary!

Dec 26, 2012 | Health & Beauty

1 Answer

Starting


Most likely the pump, but as I've said before, messing with gasoline is very dangerous and dhould be avoided except for those with good skills and uncommon common sense. A pressure test would be best. Unless you have access to a fuel pressure tool, you'd be guessing, and this is something not to be second guessed.The regulator can only be tested with a gauge.
Here may be a simple, easy way to check your pump:
Open the trunk and have an assistant turn the ignition key to the ON position without starting the car. Listen carefully and do this several times. If you immediately hear a light whirring sound eminating from under the trunk, then the electric fuel pump is working. If it does not come on immediatley when the jkey is turned, then there is a fault. If it is fairly LOUD, then it is laboring and may be cutting out or hesitating during the initial start.

Nov 10, 2011 | 1999 Chrysler 300M

1 Answer

Hyundai 2003 Santa Fe 2.7V6 - engine turns over fine, doesn't seem to be getting fuel immediately. Eventually it starts after 5 or 6 seconds of turning over. Suspect fuel filter or fuel pump?


Initially I would agree fuel pressure had dropped off after shut down. This fuel filter is a sock screen attached to the fuel inlet tube of the fuel pump and is located inside the fuel tank with the fuel pump. This screen is rarely the cause. You'll need a fuel pump pressure gauge to verify the low fuel pressure at start up. Caution, sometimes this low pressure isn't a faulty pump, sometimes it's a poor wiring connection to the pump motor. An analog amp meter can verify if there is fluctuation/ing current flow to the fuel pump. A fluctuating current flow could mean poor connections, or could mean the pump has/is gone/going bad.

Aug 31, 2011 | 2003 Hyundai Santa Fe

1 Answer

We pulled the fuel line at the engine and only a small amout of gas seem to come out when cranking the engine


Check voltage at fuel pump with key on will only have voltage at pump for about 3 sec. to check turn key off and back on 3 sec to check voltage, do as many time to you need to check, if you do have voltage, bad fuel pump, no pressure.

Jun 24, 2010 | Hyundai Motor 2004 Sonata

1 Answer

2003 Jetta, starts and shuts off after 5-10 sec.


i think you have to have the fuel pump checked. it seems that its not pumping enough gas to the engine so it shuts off after burning the remaining fuel in the line.

Sep 26, 2009 | 2001 Volkswagen Jetta TDI

1 Answer

Fuel pressure


could be, fuel filter,pump,relay, turn key on but dont start, do you here the pump? should run bout 2-3 sec then shut off. if its really losing pressure while running, its most likely ur pump..

Jul 29, 2009 | 1991 Saturn SL1

1 Answer

Power washer problem no pump action


sounds like nozzle is blocked.small bits of grit jam nozzle unscrew and make sure its clear turn water on and pull trigger to see if gun trigger works,then refit nozzle check again for spray.if clear start up and try out.if no go then pump probably needs cleaning and relubing seals.

Apr 20, 2009 | Comet Garden

2 Answers

No longer hearing the "whirr" of the electric fuel pump


if this is a no start then the next step is to pull the gas tank and replace the fuel pump module, the fact you heard the pump in many cases means the pumps shaft bearings were worn out, they are pretty silent for the most part.

Apr 09, 2009 | 1997 Chevrolet Blazer

Not finding what you are looking for?
Sta Rite 1 HP Sta-Rite Pump: 1.5" in/out, Center Discharge, 240V, w/Hair & Lint Pot Logo

152 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sta Rite Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1338 Answers

john h

Level 3 Expert

12104 Answers

steve morris
steve morris

Level 3 Expert

1675 Answers

Are you a Sta Rite Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...