Question about AudioSource SW-15 Subwoofer

1 Answer

My sub isnt receiving any power. the light on the back will not turn on no mater what i do. new power supply?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hey i have the same problem, were you ever able to fix it?

Posted on May 21, 2011

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

OmniS10 does not work


Mine has issue with the sub input that runs from the receiver sub output. So I don't have the LFE effect. I have to use the secondary hookup which is:
-run your front speaker wires from the receiver into the input. Then run wires out back to your front speakers.
Is your completely dead period? Or is the light coming on? If its dead, it may be a fuse or the power supply has failed....if the light comes on. Try the secondary hookup. Make sure both your reciever and the sub are unplugged. Plug them back in after you have hooked everything up..

Feb 08, 2013 | Mirage OMNI S10 Speaker

1 Answer

Have a sanyo 50" plasma


This tv problems are related to powering up the tv and sustancening the tv power source to the tv itself.Replaced the tv sub power supply board where the a/c power cord plug into it.Try website like Ebay.com to buy a whole new refurbish sub power supply board for the replacement.

Sep 06, 2011 | Sanyo DP50747 50 in. Plasma TV

1 Answer

My boss d1000.2 2 channel amp was working fine..i took it out the car n put it back n.now the power light comes on but it doesnt play


Make sure your power supply isnt crossed, you will still get a power light with reversed polarity. Then ensure the speaker is connected at both ends, on the amp and at the sub.

Aug 07, 2010 | Car Audio & Video

1 Answer

Pioneer receiver


powered sub should work no mater what your listing to unless its not set up

Apr 22, 2009 | Pioneer Audio Players & Recorders

2 Answers

Klipsch ksw subwoofer wont power on


The power supply switching transistors are likely fried. Dangerous high voltages involved. I would remove the plate and send it to Klipsch for repair.

Jan 16, 2009 | Gem Sound SUB-650M Speaker

3 Answers

Light on front isnt on at all..


Actually, there is a fuse. You need to take out all the screws and remove the two dials so you can take off the panel. Look to where the power cord connects to the board, and you will see the fuse. It is a 125V 4 amp fuse.

Jul 24, 2008 | Sony SA-WM500 Subwoofer

2 Answers

Subwoofer goes to sleep


The receiver automatic speaker set-up set the sub volume at -12 and since it was not getting any signals from the receiver it was doing what it is supposed to be doing (going to the standby mode). This was troubleshooted by Onkyo tech support on a Sunday. All the best about Onkyo customer support.

Apr 12, 2008 | Audio Players & Recorders

1 Answer

Subwoofer noise


You didn't say is your sub active or passive.If its active first check signal cables from theater system,power line of the sub, it has to be the same phase as the system.If its passive take a voltmeter disconnect the sub from the system and measure for DC voltage on the SUB output on the system when its OFF.If DC voltage is present your amp is damaged.It can also be that the preamp circuit for the sub doesn't mute the input when unit is on stand by and you hear frequency of your power supply (50-60Hz) on the sub

Mar 09, 2008 | Audio Players & Recorders

Not finding what you are looking for?
AudioSource SW-15 Subwoofer Logo

Related Topics:

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top AudioSource Audio Players & Recorders Experts

Josh Whitehead
Josh Whitehead

Level 3 Expert

1148 Answers

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

Andrew Taylor
Andrew Taylor

Level 3 Expert

14534 Answers

Are you an AudioSource Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...