Question about MTX X Thunder 1000XD Car Amp

1 Answer

My mtx 1000xd will turn on but makes a sound inside near the circle donut looking with(lots of wires soldered) and where my ground is to the trunk bolt and even in side speakers. It will not power my subwoofer and the bass knob wont turn on.

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Renaissance:

    An user who is expert in 3 categories / brands.

  • MTX Master
  • 2,226 Answers

Sounds like you may have a bad torroid (the donut looking thing). you may also have a bad ground connection. make sure you have completely bare metal where the ground connection is. you need a very clean connection.

Posted on Oct 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sobs 1997 900 turbo having trouble with running


Saabs can be prone to floating ground issues in some of the light fixtures. My older one had this happen in particular, when the ground plane in the tail light cluster rusted and isolated the ground on a bunch of lights. It turned into a bypass where brakes, blinkers, emergency, all would make all the lights flash kind of dimly.

You should be able to remove the rear light clusters from inside the trunk. Look and see if there is corrosion, or signs that the ground plane - should look like a large scale printed circuit board, is damaged. Clean it off with a wire brush. if the ground plane is broken, you'll want to either get a replacement base plane, or, if you re-connect the ground, use some heavy wire to solder it back into connection so that it can handle the current for the lights.

I hope this might help!

Oct 06, 2014 | 1997 Saab 900

1 Answer

Humming amplifier


One old trick is to use a new 14 gauge ground wire and connect your head unit to the amp.

Ground both ends to the metal on frame,

Jan 14, 2014 | MTX X Thunder 1000XD Car Amp

1 Answer

My MTX JH600 works intermittently. I don't hear the fans coming on at all and the amp doesn't seem to get hot. Even at low power the amp will turn off all of a sudden and then boom back on after...


One of my friends had a amp like that , i looked at it an the inside of speaker box wires was touching , if thats not it then check ur power an ground , power wire must be the same size ground an if ur ground is not grounded good then u will get the cuting out .

Jun 10, 2011 | MTX JackHammer JH600 Car Audio Amplifier

1 Answer

THE AMP TURNS ON BUT THE FUSE UNDER THE HOOD KEEPS BLOWING and the sub wont turn on but the amp turns on


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty . Please use volt meter to test correct voltage and ohm feas ng on speakers. .A thumbs up would be greatly appreciated if this answer is helpful to you. amp-turns-but-zb4bomd1rt4qms0dqd12kkt2-3-0.jpg

Jan 16, 2011 | MTX X Thunder 1000XD Car Amp

2 Answers

Amplfier mtx rfl404 goes into safe mode when playing at load volume after 10 mins


you might need to turn the amp down and get some better wires to carry the load. when at lot of juice is being tranfered you need good wires to hold it

Mar 14, 2010 | MTX Thunder 801D Car Audio Amplifier

1 Answer

Diagram x1000d


http://www.mtx.com/caraudio/products/manualsQuickInstall/amps/XT_1000XD_InstallSheet.pdf

THIS LINK WILL TAKE YOU TO THE SUPPORT PAGE FOR THE 1000XD. IF YOU WERE REFERRING TO THE SERVICE MANUAL OR SCHEMATIC OF THE CIRCUIT BOARD, THEN YOU WILL HAVE TO CONTACT MITEK AT 800-225-5689 AND ASK FOR MR. DABBAS. LET ME KNOW IF YOU REQUIRE FURTHER ASSISTANCE......V

Jan 13, 2010 | MTX X Thunder 1000XD Car Amp

1 Answer

Mtx 1000xd led light is flashing and the subs will not work


The light flashing usually means there is a short somewhere. Check your wires to make sure there are no slices and are touching. Also check to make sure you have your remote wire hooked up.

Sep 19, 2009 | MTX X Thunder 1000XD Car Amp

2 Answers

Fast blinking red light


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Good L .A thumbs up would be greatly appreciated if this answer is helpful to you. MTX Audio

Aug 13, 2009 | MTX X Thunder 1000XD Car Amp

1 Answer

Humming sound to speakers from amplifier


Hello,

It sounds like you may have a ground loop issue. I'd start by checking all the power and ground connections. Then disconnect the RCA wires from the amplifier. If the hum goes away then you should try grounding the stereo to a better grounding point, the factory grounds are usually not very good at all. Then try it again, if it is still there try replacing the RCA"s.

If the hum is still there after you've redone the connections and replaced the RCA's, you may need to install a ground loop isolator.
Both www.crutchfield.com and www.sonicelectronix.com sell good ones.

Hope this helps

Mar 28, 2009 | MTX X Thunder 1000XD Car Amp

2 Answers

Rear turn signals don't work, bulbs are good, front signals blink fast, at first only drivers side didn't work occasionally, now neither side works at all. What's wrong?


are you sure bulbs are good ?? double check bulbs also make sure there is a ground wire from your light fixture is grounded to the body near by this might be causing your problem .. usually if front ones blink fast rear bulbs are bad ... thanks Jerry holler if you need more.

Jan 29, 2009 | 2004 Pontiac Grand Prix

Not finding what you are looking for?
MTX X Thunder 1000XD Car Amp Logo

Related Topics:

143 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

76164 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...