Question about Car Audio & Video

1 Answer

ED7400 - Edge Car Audio 400w amplifier keeps cutting out the music and going into protective mode.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Master
  • 680 Answers

The most common problem is that the amplifier isn't getting enough power. Try installing a one farad capacitor between the head unit and the amplifier.

Posted on Oct 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Protection light came on what cut off


Amp in Protection - Troubleshooting - Basic Car Audio ...

www.bcae1.com/.../troubleshootingbasicsampinprotect.htm
Some simply shut down and the power light will not illuminate when in protect mode. If the power light blinks then goes off, the amp is either going into protect ...

How do I fix my amp it keeps going into protection mode ...

? 2:00
https://www.youtube.com/watch?v=DQ1bdsm6s2c
Apr 24, 2013 - Uploaded by Nathan West
My MTX 600xd amp light won't even come on. ... Red light comes on. ... one.. and some times it goes into protection... once I turn the car off...

Jan 11, 2016 | Car Audio & Video

1 Answer

When i turn the music up sub cut off blue light stay on red triangle cuts off


Hi, the amp is going into protect mode. You can either keep it turned down or possibly reconfigure the speaker connections for a higher impedance. If you tell be the model of your sub, I may be able to suggest a better arrangement.

There is a manual here if you don't have one: http://manual.kenwood.com/en_contents/attachDownload/6017/

May 08, 2011 | Kenwood KAC-7204 Car Audio Amplifier

1 Answer

The protection light keeps coming on


That means something isn't wired right. Make sure that all of the power inputs from the battery are correct. Most importantly make sure no bare wires are touching (IE the positive and negative bare wires going to the subwoofer terminal.) If it keeps persisting, check the voltage level in the car and make sure it is normal, because some fancy amps have protection where it will go into protect mode if the amplifier is not getting enough power to supply. Also, does this happen when you are really bumping (like high volume) or just the second its on it cuts? Because when you really play it loud and it cuts, sometimes you are putting too much a load on the amp. Make sure the fuse in the amplifier is the correct fuse for the amplifier.

Oct 13, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Pdx 4.150 amp suddenly cuts all sound from the amp when music is played loud/normal for me, unknown reason it just started doing it, I didnt change or add anything to cause this issue. All power and ground...


ALL THAT IS NOT YOUR PROBLEM CHECK ALL YOU POWER SOURCE AND IF ALL OK CHECK TO SEE IF ANY SPEAKER IS BAD OR GROUNDING OUT'' THE CAN COURSE THAT TO HAPPEN AND CHECK MAKE SURE RCA IS NOT PINCH ANY WHERE

Aug 05, 2009 | Alpine PDX-4.150 150W x 4 Car Amplifier...

1 Answer

Amp keeps cutting off


Do you have heavy enough gauge wire supplying B+ to amp.Big amps draw a lot of current and require very heavy gauge wire. The longer the run the heavier the gauge needed.

Apr 20, 2009 | AudioBahn A8000T Car Audio Amplifier

2 Answers

I have an american legacy series 2 1000watt apm


Check and see what size fuses it uses. Your watt power means nothing without good fuses. My suggestion would be to go buy 40a fuses and replace the ones you already have.

Feb 27, 2009 | Legacy Audio American Legacy II LA290 Car...

1 Answer

Problem


you need to get a bigger ground wire and the cut in and out will stop the cutting in and out is the protection mode starting if it cant hold the thump a capacitor 2farad will hold the bass
hope this helped

Feb 15, 2009 | Eclipse Premium 34230 Car Audio Amplifier

2 Answers

Amplifier not working


Do yourself a favor and take it to a repair shop. It will be alot easier on yourself and you will get your amp back in working condition alot faster.

May 04, 2007 | AudioBahn A8000V 400W x 1 Car Amplifier...

1 Answer

Power & protect


my amp says Lo on the digital circle on top of the amp i have a mtx 9500 bridged to the amp and it cuts out at high volumes and suddenly please help



Dec 21, 2006 | AudioBahn A8000V 400W x 1 Car Amplifier...

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

99 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4848 Answers

yadayada
yadayada

Level 3 Expert

75822 Answers

The Knight
The Knight

Level 3 Expert

74136 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...