Question about Pyramid GA610 600 Watts Dual Channel Guitar Amplifier

1 Answer

When I turn on the amp it turns on, but it doesn't amplify my guitar/ work at all.

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 42 Answers

Check the power transformer first to see if tou are getting power to the amplifier section. If you are getting power, your problem is probably the power transist is bad.

Posted on Oct 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have guitar pre amplifier b200s and there's no sound coming thru it. How would it fix this amp?


maybe try turning the wire from your guitar to the amp around you might have the inlet in the outlet socket?
if not its probably damaged internal wires for the speakers

Mar 23, 2013 | Music

1 Answer

My fender fm 65 dsp amplifier squeals and feeds back every time i turn it on


Is it plugged into a guitar at the time? If so, it sounds like you're using a speaker cable instead of an instrument cable. There is a big difference. Look on the cable to make sure. If guitar is not plugged in would be a completely different diagnosis.

Mar 05, 2013 | Fender Musical Instruments Corporation...

1 Answer

The amp does not work at all even though the lights on the amp come on but when i connect it to the guitar no sound whatsoevva i checked the sound nobs on the guitar and the amp n all r ok but no soun


Have you checked a different cable?. Also, when you plug in the unit, there should be a "pop" if everything is turned on. If there isn't, the connection is bad someplace.

Aug 06, 2012 | Marshall Amplification Marshall MG15FX...

1 Answer

The guitar is not amplifying


faulty lead? when the lead is plugged in turn the amp distortion on (may be called 'gain') and when you tap the end that goes into the guitar with your finger you should hear a buzz. try another lead if not, and if it still doesn't work make sure that volume is up on the amp and the guitar. there may also be a knob in the back of the amp, turn that up too (but not all the way or when you do get it working you'll blow the speakers out).

Apr 19, 2011 | Marshall Amplification Marshall MG Guitar...

1 Answer

When I turn on the amp, I get a loud hum. plugging into the jack doesn't change anything. turning the dials doesn't change anything. when I turn off the amp it makes a loud crack.


i) Disconnect one lead of loudspeaker & insert an open-ended guitar cable into headphone socket.

ii) Put a dc voltmeter across open end jack then turn Frontman ON for a few seconds.

iii) The reading should be about 0volts - if the voltage is high (27v), then it is likely that the PA chip TDA1514A has blown.

iv) If,however, the voltage is correct in iii) , then reconnect speaker & put guitar cable into the POWER AMP IN socket & connect other end to guitar...Turn on briefly, if there is still hum then fault is in the output stages & will require chassis removal to solve.

Feb 23, 2011 | Fender FrontmanTrade 25r Combo Guitar...

1 Answer

My amp, was working fine last night, it wont turn on, and i tried switching guitar, cables, even power supplys and still wont turn on, i heard a pop last time i used my amp, and then the signal was lost...


The unit will require repair and if you are not adept at electronics, you will need to take it to a shop. Likely there is failure in the power supply or amplifier that has blown the fuse. Replacing the fuse WITHOUT repairing the cause MAY do additional damage.

Dec 28, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

I have a Marshall MG100DFX. I turned my amp on a few days ago and I heard this loud sound (not the standard hum/buzz that you hear when you plug a guitar into an amp; it sounded more like a foghorn). Now,...


I would try hitting the side of the amp before turning it on. There may be a loose piece of solder or other conductive particle stuck somewhere. Bang the cabinet rather hard with your fist. If that doesn't help it might be a loose solder connection at a resistor or capacitor but a tech should check that out.

Dec 04, 2010 | Marshall Mg100dfx 100-Watt Combo Guitar...

1 Answer

I can turn it on and i hear the fan going...but it doesnt make any sound when i strum or anything...please help!


There are some basic things you can try before you suspect the amp. Does your guitar cord work in another amp? Is your guitar sending sound through your guitar cord? Without any thing plugged into your amp can you hear a slight hiss when you turn your controls up on your amp? Here is a link to some things you can do to troubleshoot the problem:http://www.geofex.com/ampdbug/ampdebug.htm Even though the info is for tube amps a lot of it also applies to solid state (transistor) amps like yours.If it turns out to be the amp and you don't feel comfortable working on it and have no one that you know personally to do it you are best served by taking it to a certified Marshall repairman who will have the tools, parts and schematics to help you.

Apr 18, 2010 | Marshall MG100HDFX 100-Watt Amplifier Head

1 Answer

My guitar volume won't turn off


the problem i analyse is 1) the wires of the volume control (it has three wires wired to the input of the amplifier) wire 2 and 3 have got shortened.
2) the field effect transistor of the preamplifier has got shortened . the fet is in built in certain guitars.3) if its wire wound volume control then it has lost grounding , that is wire no 3 has lost its grounding (usually this is associated with a hum from the amplifier

Sep 19, 2009 | ESP Ltd EX-50 Electric Guitar

2 Answers

Amp turns on but no sound even with diff guitars and cords


Hi Dan
I wish I could just say what to fix, but you can not do this at home. Line 6 is a great amp and worth the time taking it down to the music shop , to be looked at an give you a repair estimate. good luck keep on rocking in the free world. DFD

Apr 12, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

Not finding what you are looking for?
Pyramid GA610 600 Watts Dual Channel Guitar Amplifier Logo

Related Topics:

110 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pyramid Music Experts

Vito Vacirca Jr.

Level 2 Expert

140 Answers

yadayada
yadayada

Level 3 Expert

75797 Answers

kakima

Level 3 Expert

102366 Answers

Are you a Pyramid Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...