Question about ElectroVoice . Speaker

Open Question

I have the EV sh-1502 speakers ..i am getting crackling from one of the horns..what and how do i fix it thanx

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 19 Answers

SOURCE: no sound from EV SH-1502 ER 15" driver

Either the 15" speaker is dead, or the passive crossover inside the unit. The simplest way to identify your problem is to remover the speaker that isn't working from the enclosure, and exchange it with the speaker that is working. If there's no sound still, it's the speaker itself that is the problem. If it works in the other cabinet, then put the "working" speaker in the cabinet you took the "bad" speaker out of, and if it doesn't work, then there's a problem with the crossover in the first cabinet. I believe you can buy a replacement crossover from EV. If it's your speaker, do a google search for "speaker re-coning" in your area - it's cheaper to re-cone the speaker than buy a new one.

Posted on Jun 18, 2009

caroldon
  • 17129 Answers

SOURCE: I have an old set of EV 1502 PA Speakers. One of

The crossover network is a combination of a LCR circuit. since all these arre passive components you will not have a problem to find the actual fault. Since you have confirmed with the drivers, the line in to the network from the speaker wires must be traced for continutiy, use a good multimeter. now check carefully on the PCB-printed circuit board.- for any track damage on it, if so loop and connect. The main driver is usually in parallel to the main line but with a croos over of a cpacitor and a series inductor. This will be the culprit, either it has come off from the PCB or open out by burning off. replace or reconnect. I am sure it can be sorted out easily by your carefully analysis. Hope this helps. Good day

Posted on Jul 20, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a VISIO VX37L 2006 TV The audio goes on and off and crackles and sometimes makes a loud horn sound. Please Help!


Check the speaker/s. If found OK; check and replace the damaged component/s at its audio output section circuit board. If needy, replace this board as card basis. If you wish to get some details; check the site linked here. Surf the site with patience. Pull up older posts. Surf the site with patience.
http://electronicshelponline.blogspot.com/

Oct 19, 2015 | Televison & Video

1 Answer

I have just purchased a pair of EV speakers. Just a minor problem - the light on the front of the speaker (near the logo) works perfectly fine on one, but is not working on the other. Help would be...


If the speaker is working then the "power on" LED has a broken wire/bad connection or the LED has burned out. LED's don't burn out often so I would think it is a internal factory wiring issue. If they're still under warranty, have EV fix it.

Sep 26, 2013 | Electro-Voice Elx112p Ev Powered 12"...

1 Answer

Crackle or popping from EV Sx 100+ speaker


test this : Gd bless you
Line noise is feeding in from the AC line. Use an ac line filter to block the line noise. RF (radio frequency) interference is being picked up by the power line or wiring. Remove sources of RF interference, such as fluorescent lighting or wireless devices not designed to work with audio/video equipment. Wires between the components are on top of one of the components; the transformers are causing RF interference. Be sure that wiring goes behind the components rather than on top or between components. If there is an equalizer in use, there could be a ground loop. Ground loops can be resolved by installing GLI's (ground loop isolators) on the cables connecting to the equalizer.

Jul 10, 2013 | ElectroVoice Audio Players & Recorders

1 Answer

Crackling in rear speakers of panasonic wireless system sh-fx71 from home theater system sa- btt770


The wireless circuitry is malfunctioning due to a part failure, this is a job for a professional and I recommend a estimate.

Mar 18, 2012 | Panasonic Televison & Video

1 Answer

Where can i buy a horn for a ev sx 300? how much?


You don't "buy a horn" as the horn itself is molded into the case and if the case is smashed that is fatal.

If it is the sctive element for the tweeter/mid you are after, the correct terminology is "compression driver". That should aid your search.

It is best to go directely to EV to get an exact replacement for this. Or try to find one at this site:

http://www.loudspeakersplus.com/parent_category/HFCD/High-Frequency-Compression-Drivers/1.html

They vary from about $30 to $500.

Sep 06, 2010 | ElectroVoice Sx300e

1 Answer

I have an old set of EV 1502 PA Speakers. One of my Cabs the 15" driver stopped working... I can plug the Horn and the 15" Driver in Separately and they both work which I think means I have a problem with...


The crossover network is a combination of a LCR circuit. since all these arre passive components you will not have a problem to find the actual fault. Since you have confirmed with the drivers, the line in to the network from the speaker wires must be traced for continutiy, use a good multimeter. now check carefully on the PCB-printed circuit board.- for any track damage on it, if so loop and connect. The main driver is usually in parallel to the main line but with a croos over of a cpacitor and a series inductor. This will be the culprit, either it has come off from the PCB or open out by burning off. replace or reconnect. I am sure it can be sorted out easily by your carefully analysis. Hope this helps. Good day

Jul 19, 2010 | ElectroVoice . Speaker

1 Answer

Wiring diagram for horns in a speaker ev eliminator i dual 15's


hi can you please tell me on a ev elimenator horn which out of the wires is the live?

Nov 02, 2009 | Audio Players & Recorders

1 Answer

There is crackling coming from the horn as soon as the power is turned on, the level of the crackle does not alter with the volume control, the cabinet performs fine otherwise ?????


The horn speaker is wearing out. Inside speakers, there is a magnet, the speaker part is attached to a cone that slides over the magnet, They tend to make crackling noises. Try very gently to apply pressure to the horn and then release. If you hear a scratching sound, the horn will need to be replaced

Jun 27, 2009 | Mackie SRM-450 System

1 Answer

No sound from EV SH-1502 ER 15" driver


Either the 15" speaker is dead, or the passive crossover inside the unit. The simplest way to identify your problem is to remover the speaker that isn't working from the enclosure, and exchange it with the speaker that is working. If there's no sound still, it's the speaker itself that is the problem. If it works in the other cabinet, then put the "working" speaker in the cabinet you took the "bad" speaker out of, and if it doesn't work, then there's a problem with the crossover in the first cabinet. I believe you can buy a replacement crossover from EV. If it's your speaker, do a google search for "speaker re-coning" in your area - it's cheaper to re-cone the speaker than buy a new one.

Jun 18, 2009 | ElectroVoice . Speaker

1 Answer

How will i know if the horn has blown on my ev zx 5 speaker?(there is no top end at all) thanks.


first,try switching to a different output(if this is the left speaker,switch it to the right)if it does the same thing,then we need to pull the back off the speaker.to make sure the crossover is not bad your gonna want to unplug the horn & put a signal to it from your source(do this at a low volume with the bass turned down & trble turned up)if you have sound then there is a problem with the crossover(this is the pc board in the enclosure that connects to the speakers)if not your horn is gone.hope this helps,thanx for using fix.please rate all replys

Nov 17, 2008 | ElectroVoice Audio Players & Recorders

Not finding what you are looking for?
ElectroVoice . Speaker Logo

Related Topics:

414 people viewed this question

Ask a Question

Usually answered in minutes!

Top ElectroVoice Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

Vito Vacirca Jr.

Level 2 Expert

140 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you an ElectroVoice Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...