Question about Orion HCCA-D2400 Car Audio Amplifier

2 Answers

Trying to increase volume on car deck when doing so the amp just shuts off, then amp makes a burning popping sound and smells like something burnt up and 3 sec later amp kicks on and still works, none of the fuses are burnt or blown and amp is on 10:00 setting and still unable to increase the volume on the deck with out amp shutting off

Posted by on

Ad

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Orion Master
  • 637 Answers

Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. Hopefully you have warranty. Please check impedance on speakers as they coyld be fried as well. A thumbs up would be greatly appreciated if this answer is helpful to you

trying to increase volume on car deck when doing - trying-increase-volume-car-deck-when-otfyjrky3pc2prtgltcdyqtn-3-0.jpg

Posted on Feb 03, 2015

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Orion Master
  • 1,114 Answers

Check speakers and wiring to and from speakers for shorts with a meter. You have done damage to the protection circuitry more than likely. Check the impedance at the speaker for proper level and check speaker wire for shorts from amp to speaker. If you still have a problem, post a comment and I will help you firther.

Posted on Oct 03, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Tried hooking subs and amp to my factory deck in my 2006 chrysler town &country limited.. Everything was working but wife's friend started while I was wiring smelled like burning electrical.. Now no s


Only fuse you need is the power wire leading to your aftermarket amplifier for te subwoofer. Which most likely you have too small of a gauge of wire and burned straight through it, and if you haven't, add a 40 amp fuse near the battery where your power cable is hooked up to. Also use a multimeter to test your power wire on amp, check the

Jul 19, 2013 | Car Audio & Video

1 Answer

Fuse rx 570 pioneer stereo


Sounds like you have a much bigger problem than just a fuse. Popping sound and burning smell means something much more serious.

Jun 18, 2013 | Audio Players & Recorders

1 Answer

Just installed second hand Lanzar 430 amp new Enron deck tried to fire up and sounds like heartbeat through speakers, ran smaller main power feed this time, slight burn,t smell from amp, not sure wha


are you running your power cable next to the amp receiving line if so your catching interference,they should be ran on different sides of the car check.Also check for proper grounding make sure its bare metal your ground is going to

Mar 15, 2013 | Lanzar Car Audio & Video

1 Answer

I heard a pop and smelled something that smelled like it was burning then the protect light came on then it shut off


Where there is a smell something burned---my suggestion is have a shop look at the unit and get a repair estimate---you can try that yourself but taking apart correctly is not always easy and there is a chance you might cause more problems---even if you find burnt part/s you will not likely know what got them.

Nov 08, 2012 | Mitsubishi M-VR1000 Receiver

1 Answer

Washer had just started and i started to smell something, and all of a sudden a noise came from the washer and then smoke came from machine really bad, the noise sounded like air escaping


Looks like something is short circuited & due to which there is burning smell coming out of the machine. Disconnect the machine immediately & inspect the insides of the machine. Locate the burnt motor or burnt wires. You heard the noise coming out of the motor. It could be dislocated brushes due to which the motor could not rotate & in turn it burnt your motor.

Sep 18, 2011 | Admiral Washing Machines

1 Answer

Mixer is still going but making a popping noise. Also has a burning smell - maybe a wiring problem?


HI.When the stand mixer produces a popping sound during mixing this problem has something to do with the motor.Motor has bossing on it.This might not be lubricated well and eventually lossen up.That's why it produces a popping sound.And with regard to the burnt smell might be on the coil of the motor's rotor or armature.Is the unit still functioning eventhough you smeeell burnt wire?Thank you for choosing FIXYA..

Jul 22, 2011 | Kenwood KM305 Stand Mixer

1 Answer

My son was playing a video game and the t.v. made a popping sound and the went black we could smell something burnt.


Ur power board is dead,smelling burn capacitors,puff up or pop open replaced capacitors,or replaced the whole board.

Dec 23, 2009 | Sony BRAVIA KDL-46S2000 46 in. LCD HDTV

2 Answers

Amp is on, but sub wont produce any bass


Make sure the subwoofer is set to low frequency, make sure subwoofer and bass are enabled on the headdeck. Make sure the gain is turned up on the amp, make sure the rcas haven't come out of the back of the head deck.

Aug 04, 2009 | JBL GTO14001 Car Amp

3 Answers

Rainbow Vacuum smells like something is burning.


Your belt is worn and that is why there is a burnt rubber smell. You need to change your belt. You can find a replacement belt and instructions here:

Rainbow Replacement Belts

Apr 02, 2009 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Tv popped and shut off


Burnt small 2KV capacitor near flyback xformer....original is
221K....I use 271K / 2KV ...Possible burnt 1K 1/2 watt resistor
and shorted zener diode ....ECG 519..................T.

Dec 08, 2007 | Zenith B27A11Z 27" TV

Not finding what you are looking for?
Orion HCCA-D2400 Car Audio Amplifier Logo

115 people viewed this question

Ask a Question

Usually answered in minutes!

Top Orion Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

yadayada
yadayada

Level 3 Expert

76691 Answers

Are you an Orion Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...