Question about Technics SL-1210 Turntable

1 Answer

Intermitant channel down

Keep losing r hand channel, sometimes works, then doesnt.
Have metered the phono cables to connection board, all ok.
Used various stylus and cartridges sometimes works, then doesnt.
Have cleaned tone arm contacts with cotton bud and switch clean as looked dirty, still works intermitantly?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Hey, I'm having the same problem. I found this with a little help from a small site I found called Google:

http://www.divdev.fsnet.co.uk/repair3.htm

Here's what he suggests. I have no clue what it means but I'm sure that it cane be decoded with some manuals:


Technics SL1210 , 1979 ?
Intermittent loss of one channel.
The headshell was slightly loose on the tonearm
and moving inwards would cause loss of one channel.
To remove this arm undo the slotted lock ring at the very top
of the arm pivot and undo the central pin. The arm
with jiggling can then be removed assuming enough slack in
the signal wires. Undoing the 2 watchmakers screws near
the headshell allows removal of the 4 pin connector.
Presumably the wires inside the tone arm at this connector
could touch the inside of the tonearm and lead to
break in sprung connection. Placed a bit of brass shim
in the slack area and pushed back in to wedge tight.
Also removed the soft washer on the plug shaft of the headshell.

Posted on May 31, 2008

  • Rive May 31, 2008

    Check other solution: 1210 GOES MONO.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

TV intermittently loses and regains audio/video from only a couple TV channels


Fault at its main digital board. Short circuited component/s at it. Contact any service technician; or the authorized service center. If you wish to get some details; check the site linked here. Pull up older posts. http://electronicshelponline.blogspot.com/ In most cases, the main board might have to be replaced. If so, a software [firmware] update too might be necessary.

Mar 28, 2017 | Sharp LC 46SV50U 46" LCD TV

1 Answer

Not receiving STEREO output when toggle switch for mixer is in the STEREO position


Here are a couple of steps you can do first before opening up the mixer & I'll word this so that it covers every potential item, (Turntables, CDJ's, Rack Mount CD Players, External Player, PC, Laptop, etc.) Obviously there are a multitude of items that could be the cause of you only receiving your RIGHT MASTER OUT since you didnt specify what item this occurs with if not all. So here's a quick legend for you to follow my references regarding the NUMARK 5000FX Mixer so here we go:
*******************************************************************************
MIC/Line Phono/CD Phono/CD Phono/CD LA/LB Zone/Booth/Rec/MSTR
LO LO LO LO LO LO LO LO LO LO LOLOLO LO
RO RO RO RO RO RO RO RO RO RO RORORORO
********************************************************************************
1. Turntables - A) If being used make sure the little black switch on the back is set to Phono instead of CD. Plug just one table in, play the record & see if there's only one side of your MASTER output jumping and make note of it. Then repeat the exact same steps for all Phono inputs (total 3) & again make note of your MASTER output signal Left or Right or Both sides jumping. This will help you identify if its just a specific channell that only works on R or L.
B) Now do the exact steps above for the other turntable & this will confirm whether or not the Phono cables went bad on the turntable or if a specific channell is has gone bad while in Phono mode.
2. CDJ's/Rack Mount CD Player - A) Now just use your CDJ's/Rack Mount CD PLayer for the next test & be sure to now change the little black switch on the back from Phono to CD. Just as the steps with the turntable perform the same for this item in all possible RCA's (total 6) & note your MASTER channell output signals L & R.
B) Now do the same for the other CDJ/Rack Mount CD Player & this will confirm whether or not the RCA cables went bad on the CDJ's/Rack Mount Player or if a specific channell has gone bad while in CD mode.
3. Audio Cables OUT - A) There are a host of ways to have your audio come OUT & multiple configurations depending on how you record &/or bounce your audio OUT. Now since you say your MASTER OUT digital meter is only jumping on the R side depending on if you're going with RCA MASTER OUT or XLR BALANCED MASTER OUT either or is what'll show the digital reader bouncing with audio so check both. It could very well have been a cable going bad on you simple as that & you can check that by pluging your cable that works on the R side into the L side. If it starts showing a reading on the digital meter than you've solved the problem being a bad cable. Also don't forget to check your ZONE, BOOTH & RECORD OUTS as well however these will not show on your digital meter so open up your audio recording software to confirm that L & R sides are working for these.
B) Last but not least double check that your BALANCE knob is set directly at 12 o'clock, this could sometimes be the culpret.

Well I hope this helps & good luck.

WesTCo@sT
">

Sep 21, 2012 | Numark Industries Numark 5000FX 5 Channel...

1 Answer

Hello i need help please..... I have a Technics SU-Z550 and SH-8055 Graphic Equalizer My amp has lost power... lots.! its working one channel louder than the other but the one which is louder still has...


If the same channel is dead on the EQ as is dead on the amp there may be a correlation.

Let's break this into its two parts.

1) SU-Z550: You don't say WHAT source(s) you tried to use on the CD/AUX, TUner and PHONO inputs. The external device itself could be the source of the low volume. Try swapping the Left and Right cables to see if it follows the source channel or stays with the amplifier channel.

Check the controls on the amp to make sure you understand each one's effect on the sound.

"PHONO" is literal and exclusively FOR A TURNTABLE - NOTHING ELSE - EVER.

2) SH-8055: Equalizers don't 'boost' sound, they modify its levels at various frequencies. To do that they should be connected into a Tape loop on your amp. OUTs go to IN's. Then you select the Tape Loop on the amp and that inserts the EQ into the signal path of whatever source you're listening to. It's actions are BEFORE any other amplifier controls such as volume, tone and balance. The EQ itself also has a Tape Loop to replace the one it occupies. Make sure it is not enabled unless you have a Tape Deck on it to use. Choose "SOURCE". The blue LED display is to show you frequencies are present in the program material.

Set all of its lighted band controls at midpoint prior to declaring it defective. EQ is like any spice - a little is good, a lot ruins the recipe.

Mar 21, 2011 | Technics Audio Players & Recorders

1 Answer

I am trying to hook up my cable box so i can watch tv.


At the cable box input, connect the cable (probably labeled "Cable In" or "Signal In").

Depending on the cable box model and available inputs on your TV, connect one of the following (listed in descending order of video quality). Colored phono plugs must match the colors of the plugs on each end.:

  • HDMI (a single rectangular connector at each end - sometimes you need to connect the Audio separately with a two - line cable with red and white phono plugs).
  • YPbBr, AKA Component (Cable with Red, Blue and Green phono plugs, plus a separate Red and White cable set for Audio).
  • S-video (a single round connector and separate Red and White audio cables).
  • Composite (Yellow video cable plus Red and White audio cables, usually sold as a single set).
  • RF out on the cable box connects to ANT or Cable In on the TV with a coax cable.
The various options are always grouped in some manner on both the Cable box and the TV. On the TV, note which input set you use, for example, "Component 1". This is the input you will select to watch whatever channel you select on the cable box.

An unused output on the cable box can go to a video recorder. Some cable boxes may permit setting up two different channels for this purpose; others will only put out the signal from one channel at a time on all outputs.

You may, if you prefer, connect the audio cable from the cable box to a stereo receiver instead of the TV. Usually people connect the audio to the TV, then connect another audio cable from "Audio Out" or "Monitor Out" on the TV to the stereo receiver. That way the sound is from whatever video source is currently selected, and the TV remote control can be used to set the volume. TV sets with this option usually have a setting to turn off the internal speakers so you hear only the external stereo speakers.

Feb 05, 2011 | Televison & Video

1 Answer

My Pioneer PL-990 Turntable only outputs sound through the white wire. Only a quiet buzz comes through the red wire.


The red wire is the right channel, so going back to your amp, get a single phono plug with with the wire exposed, so you can touch the wire. Then remove the turntable connections. With the amp on plug the the lose wire plug into each channel and check if the sound on the right is still low. If it is then there's a problem with the magnetic cartridge pre-amp inside the amp. They are often located near the phono socket on a seperate PC board, but if not just follow the red wire to the main board. Chances are it will be an IC that's failed.
If it has a strong buzz at the back of the amp. Then I should replace the wire between the turntable and the amp. Or the right phono plug that connects to the amp.

Nov 13, 2010 | Pioneer PL-990 Turntable

1 Answer

Is there a wiring diagram for the nikkai EAPA450 Amp


Hi, if you still need a photocopy of instructions email me mail@srands.co.uk

If you want instructions in brief this involves POWER CONNECTIONS, PHONO LEAD & SPEAKER CONNECTIONS:

POWER (At the same time when routing these wires, I would connect the PHONO LEADS from the car cd player to the amp, if your car cd player only has 1 preout (1red & 1 white) then you will need two phono splitters, a female to 2 males. Phono leads carry the unamplified sound from cd player to the amp):
~ Permanent 12V+ (Thick lead that is fused direct from battery all the way to the amp, wire must be 20a to 30a +, hence 1cm diameter wire, known as AWG8, Maplin sell cheaper kits then most)
~ Amp REMOTE (A thin insulated cable (5a is OK) from car cd player amp remote wire, this turns the amp on when the cd player is on, if your car doesn't have an amp remote wire, suggest nearest ignition supply or seperate switch that you turn on when you want to turn on the amp)
~ GrouND 12V- (Insulated lead (20a to 30a) to nearest part of unpainted car chassis such as interior panel screw hole, instead of an insulated cable all the way from the batery, this is common practise.

SPEAKER:
Each speaker has a - negative & + positive, these must connected correctly. The amp has 4 channel, 2 channel labeled as front, 2 channels labeled as rear. Using speaker wire, connect cable from amp to speakers. Note: Ensure the speakers being connected only receive sound from the amp (Not cd player as well, as would damage players or at the very least impair sound)
The amp has a feature called bridgeable this means a sub 8" or 10" sub can be powered by 'bridging' two channels. For example there are 2 ways to bridge power a Sub on the NIKKAI EAPA450:
i) Sub speaker wire positive + to channel RL and Sub speaker wire negative - to channel RR.
OR
ii) Sub speaker wire positive + to channel FL and Sub speaker wire negative - to channel FR.

Switches:
~ Bass boost, meant to be on for a channel if using sub, otherwise off.
~ X-over mode adjust hi/lo frequencies, only work if both x-over switches are on! Then adjust switch frequency knob, until it sounds right.
~ Gain (Volume knob) adjust volume knob up or down, until it sounds right!

NOTE:
You will need patience! many hand tools and parts such as: Wiring kit, fuse holder 20a/30a, Phono leads, speaker cable, Fork/ring connectors, wire strippers, wire cutters, set of screw drivers, also ueful to have zip ties to tdy excess cable and 'P' cable clips to tidy speaker wire to shelf, etc.

OK

Any more questions just email me mail@srands.co.uk

Dec 01, 2009 | Car Audio & Video

1 Answer

Menu keeps flashing remote control wont work, cant change channel or volume.when i hold down channel up andmess with remote sometimes it changes channel. channel down button is only one that doesnt change...


U have 2 situations:
1st U have a tv Key stucked or internal control board defective.
2nd U have a broken tv remote control.

Note: Check for stuck pressed keys on TV, if not send to repair shop, for checkup.

Nov 29, 2009 | Insignia IS-LCDTV32 32 in. Television

2 Answers

Cambridge A5 Amp, only one speaker works when phono selected


If both speakers work okay on other inputs .Then cable from pre-amp to amp and main amp are okay. If phone RCA jacks go directly to electronics board .Then its possible solder on phono jacks need to be resoldered or other connections in that section.If unit needs repair you can also purchase a phono preamp from radioshack hook up your and use it on other good inputs such as CD etc..Please note PHONO inputs are only for turntables .If a non turntable input such as CD,TAPE,TV Etc is used on PHONE .Then you will overdrive this input .

Jul 21, 2009 | Audio Players & Recorders

1 Answer

IT DOESNT SEND ANY SIGNAL.... NEW NEDDLE BUT STILL NO SOUND WATH'S RONG WITH IT


HELLO!
OK! This sounds like a faulty cartridge or wiring. Borrow another cartridge if possible and if the problem still persists it could be the wiring inside the unit which goes from the arm into the deck and connects to the phono cables - a multi meter is a great tool to have around! Check the continuity from the headshell wiring to the phono plugs also check headshell wires for continuity.
NOTE: Cartridges DO go faulty - strange as it may seem!
ALL THE BEST!

Jun 22, 2009 | Technics SL-1200MK5 Turntable

6 Answers

I installed netgear adapter WG111v3 and I keep losing internet connection


I had the same problem and when checking the properties of the adapter under device Manager.

I found the under the Power Management Tab the option to

"Allow the computer to turn off this device to save power" was turned on.

Remove the check mark from this option and click OK.

Oct 29, 2007 | NetGear : WG111 54 Mbps Wireless USB 2.0...

Not finding what you are looking for?
Technics SL-1210 Turntable Logo

159 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4852 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...