Question about Hoover SteamVac F5914-900 SpinScrub Upright Vacuum

1 Answer

Brushes not spinning or barely spinning while operating machine

While cleaning a carpet I noticed the brushes were suddenly not spinning as fast and the machine wasn't sucking the carpet cleaning solution up. I had just finished successfully cleaning another carpet without any problems.....please help..

Posted by on

  • 3 more comments 
  • ziggyzik Jun 21, 2008

    the brushes do not spin at all on my steamvac. what could be the problem? thank you.

  • Anonymous Jul 06, 2008

    upholery brushes not spinning

  • Anonymous Jul 07, 2008

    brushes wont spin at all. they are free if you move them. how do i get it to work?

  • Anonymous Mar 30, 2014

    cleaning bare floor and brushes won't spin. How do I fix this?

  • Anonymous Mar 30, 2014

    My brushes aren't spining. I am cleaning a bare floor

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

There are filters, one on the lid, the other from the bottom, has a red frame, pull it out and clean it. There maybe a foam filter on the lid covering the yellow ball, it needs to have at least a 1/4 in. gap from the top. Also make sure that the lid is on correctly and tight.

Posted on May 26, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Brushes don't rotate on proheat2X,


How to Replace the Belt & Brushroll on Bissell ProHeat 2X ...

? 2:11
https://www.youtube.com/watch?v=Jj_43IHz9U4
Dec 28, 2012 - Uploaded by eVacuumBags
How to Replace the Belt & Brushroll on Bissell ProHeat 2X Series Carpet ... How to Replace Bissell Deep Cleaner Pump Belt orBrush Belt - Duration: 1:44. ... Won't SPRAY solution Rollers spin Fixing Bissell ProHeat Carpet ...

Brushes Will Not Rotate Deep Clean Essential - YouTube

? 0:53
https://www.youtube.com/watch?v=gbEXY5jkWSc
Apr 9, 2015 - Uploaded by BISSELL
If your machine is turned on and in the upright position yourbrushes will not turn. ... How to Replace the Belt & Brushroll on Bissell ProHeat 2X Series Carpet ... Won't SPRAY solution Rollers spin Fixing Bissell ProHeat Carpet ...

bissell pro heat 2x brushes wont spin Questions & Answers ...

www.fixya.com > Forum > Tags
... bissell pro heat pet 2x and my brushes won't turn or operate... check the belt belts ok brushes won't turn/rotate turn dial on bottom front on the water tank to ...

Feb 03, 2016 | Vacuums

1 Answer

Brushes not rotating


here is manual > http://hoover.com/file/593/
The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaningicon1.png has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plasticlb_icon1.png has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this femaleicon1.png receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to request a repair clarification and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the modelicon1.png number off the back of the machine and provide, and provide me with the full model number. I would be happy to provide any technical support you need, just request a clarification on the repair...

Apr 25, 2013 | Tti Hoover F7412-900 Max Extract Dual V...

2 Answers

On hoover steam carpet cleaner, the brushes do not rotate on low or high settings.


Follow these steps if the Brushes Fail to Spin
•If the brushes on your Hoover carpet cleaner fail to spin, there may be a problem---some sort of blockage---with the suction or with the belt that turns the brushes.
Turn the Hoover carpet cleaner over, and inspect the brush area. Debris, strings, or pet hair may be tangled in the rollers, keeping them from turning. Use a pair of scissors to cut away any obstructions in this area. Flip the Hoover carpet cleaner back over, and turn it on to see if cleaning the rollers has solved the problem.
To check the belt, turn the Hoover carpet cleaner over, and remove the bottom plate screw with a Phillips head screwdriver. Investigate the belt area to see if it is broken or has somehow slipped off. If it is broken, you can order a part from Hoover.com or from many of the other online parts stores.
When the belt arrives, simply slide it on in place of the broken belt, reattach the bottom plate and turn the Hoover carpet cleaner right-side up. Turn it on to test your solution.

Sep 03, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Brushes won't rotate on hoover steam vac. I have removed them and cleaned.


The brushes turn by the airflow from the vacuum suction turning a turbine motor to spin the brushes. First try to spin the brushes by hand. If they won't turn it usually means the brushes are clogged with hair and debris or need replaced or the turbine could be seized up. If the brushes won't spin reach under the brushes and push the little tabs and remove the brush block asssembly from the machine. If the brushes spin freely after you remove them from the machine then that means that most likely the turbine is seized and will need to be repaced. If the turbine is not seized you may simply just have a clogged filter screen. Most steam vacs have a red screen filter either on top or underneath the machine. On the top it is under a little clear plastic cover that you have to pry off before you can pull the screen out to clean it. If it's underneath you can pull it out and clean it.

Jul 18, 2010 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

5 BRUSHES DO NOT ROTATE WHEN IN CONTACT WITH CARPET


HI There,

When the brushes on a Hoover SteamVac stop spinning, it can be caused by several things. The most frequent problem is that there is debris in the brushes such as pet hair, or lint, that prevents the brushes from spinning. Usually if you remove the brushes and clean them thoroughly, this will fix the problem. This sounds to me like what is the problem on your machine, as you make it seem as if the brushes spin, but only stop spinnning when you put them down on the carpeting.

The brushes on your Hoover are driven by a turbine brush gear assembly, not a belt. Sometimes this part can go bad, but usually when it does, the brushes won't spin at all, even when they are not on carpeting.

Anyways, here a helpful guide that I've done that shows you step by step how you can diagnosis the problem with your brushes:

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine.
d6c0881.jpg


I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

Now look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

adc2d4f.jpg
If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

232c8b0.jpg

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

If you find that your turbine needs to be replaced, I have written a step by step guide that shows you each step on how to replace your brush turbine gear. Here's a link to that repair if you need to do it:
http://www.fixya.com/support/r4530769-diagnosis_fix_hoover_steamvacs_when

Hope this helped you, please be sure to rate my repair or leave me feedback if you found this helpful, thanks so much!

Chris Jones
GoVacuum.com

May 01, 2010 | Hoover F5866-900 SteamVac Deluxe Wet/Dry...

1 Answer

Brushes stopped spinning during carpet cleaning.


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose2_bing.gif with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to email me at chris.jones@govacuum.com, and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I do carry all parts for your machine, and would be happy to provide any technical support you need.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
GoVacuum.com
chris.jones@govacuum.comd6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg

Mar 16, 2010 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Clean inside of brushes


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose2_bing.gif with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If your brushes still wont spin, you may need to replace the brush block itself. Check the model number on your SteamVac which will be located on the back of the Steamvac on a stick with model information. GoVacuum.com does carry ALL of the SteamVac Brush Blocks on our site if you need to buy a new brush block.

Here's a picture on how you can remove these clips;

d6c0881.jpg

If this does not fix your problem, there are a few other problems that could be causing this.

Feel free to call me, or email me if you have any questions about your SteamVac, I'm more then happy to diagnose the problem overthe phone / email.

Chris Jones
GoVacuum.com
chris.jones@govacuum.com
1-866-468-2288

Nov 27, 2009 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

The brushes spin fast until I put it down on the carpet


raise the bottom to level of the carpet , just so it hits, must be a lever in the back, its meant to sweep up debree to **** up, there is nothing yet to bring pile up

Sep 28, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

The brushes aren't spinning


The brushes are belt drive by a belt. The belt is probably broken. You can purchase a new belt at a local discount store and replace it. You won't find anything that looks like a pulley, it'll just be a bare round metal portion of the brush assembly that is located at one end. The motor end will look similar.

Feb 23, 2009 | Hoover SteamVac F5914-900 SpinScrub...

4 Answers

Brushes wont spin


Greetings from GoVacuum,

The Hoover SteamVac's are notorious for this exact problem. There are several things that can be causing this probelm.

First, what you'll need to do is take the brush block out of the machine. To do this there are 4 clips on the brush block. You will need to turn the machine upside down, and pull down on the brush block to where it won't pull out any farther. There are 4 clips, 2 on top, and 2 on the rear of the brushes. (See picture, I have circled one of the clips in red). Simply press these clips at the same time, and pull the brush block out of the machine. I'd say that 60% of the time that I see this problem, the main issue is that the brushes just need to be cleaned. If you have pets in the home, a lot of the time the pet hair will just be lodged inside the brushes, will prevent them from spinning. Use a pressurized water hose (garden hose with spray nozzle is ideal) and spray each brush with water to dislodge any pet hair. You should be able to get these brushes spinning when you spray them. Spray each brush until the brushes are spinning pretty fast. Re-insert the brushes into the machine, and test to see if the cleaning has fixed your problem. If the cleaning still fails to fix the problem, take the brushes back out of the machine.

One you have the brushes out of the machine, the first thing you should look at the brush stem that goes into the turbine inside the machine. This is the green pole pictured in middle of the brush block. Examine this pole to determine if the top of it has broken off. It should exactly how the picture shows it. Make sure that the plastic has not broken.

If the pole has broken, you will simply need to replace the brush block. If the pole is not damaged, the next thing to try is to turn the machine on while you have the brushes out. Look inside the machine, where the pole goes into the turbine (also important, make sure the switch for the brushes is turned to "Rotating Brush Speed Hi), this female receptacle should spin when the machine is turned on. It is important the try this when the foot pedal is released, and the handle down, and not in the upright position, as there is an internal switch that shuts the brushes off when the machine is in the upright position.

If you notice that the female receptacle where the brush pole is inserted is spinning, then your turbine is fine. If this part is not spinning, then most likely you will need to replace your turbine.

I hope this helps you with your problem. If not, please feel free to email me at chris.jones@govacuum.com, and I'd be happy to walk you through the diagnosing. I also can provide you with a blown up parts schematic to your machine, please just get the model number off the back of the machine and provide, and provide me with the full model number. I do carry all parts for your machine, and would be happy to provide any technical support you need.

I tried uploading the pictures to this solution, however Fixya will not allow the pictures because they are too big. Please email me, and I'll send you the pictures.

Chris Jones
GoVacuum.com
chris.jones@govacuum.comd6c0881.jpg232c8b0.jpgadc2d4f.jpgb64e530.jpg



Oct 03, 2008 | Hoover SteamVac F5914-900 SpinScrub...

Not finding what you are looking for?
Hoover SteamVac F5914-900 SpinScrub Upright Vacuum Logo

Related Topics:

243 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...