Question about Kenwood Car Audio & Video

1 Answer

I've wired my system through my capacitor then to my amplifier. When I turn on my vehicle the capacitor drains and my amp. goes into protection mode. I believe it's wired correctly but I don't understand why I can't get my amp and capacitor to keep a consistent charge. Any ideas?

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

How did you connect the capacitor? it must be in paralel with the amp..you can also try to mesure in the amp and capacitor, the tension in the positiv and negative connection, it must be 14,4vdc when the car is working..if not, check the batery, fuse and ground connection until you get 14,4vdc. hope this help.

Posted on Oct 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

My protection light is on and the amp goes in and out. how can i fix this problem?


Either there is a malfunction on the amplifier , or more likely there is a short on the speakers cabling. If the cables are shorted, or broken, not allowing a sufficient load, the amplifier will protect itself by tripping a fuse. After a while, or on restart, the fuse will rearm itself, only to be tripped again by the malfunction.

Jul 28, 2011 | Dual XPA2100 2/1 Channel 300 Watt...

1 Answer

I hooked up 2 capacitors into my amp and every time I put power to it the amp shuts off and 10 seconds later a red light comes on for 5 seconds and the amp don't turn on, basically it goes into protect...


Well, I have no idea why you would have two capacitors on a 500 watt amp but, did you charge the capacitors? Have you tried the amp without the capacitors? What size power wire are you using?

Sep 20, 2010 | Kenwood KAC-9102D Car Audio Amplifier

2 Answers

Why does my sub and amp go into protected mode when i turn my headlights on


Hi.

Devices go in protect mode when a fault condition is detected. These include insufficien voltage, excessive load, shorts and contact, overheating.

In your case the problem is usually excessive power draw. A contact in wiring can also cause the problem, but this is far less common.

Use a capacitor fix the excessive power draw from the amp and sub.

See:Capacitors - BOSS AUDIO SYSTEMS

Regards.

Ginko.

Jul 01, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My amp goes into protection mode when i turn on my car. It gets hot too. I had 2 kicker 12" l5's and blew the subs with that amp, could i just have a simple problem with the amp? What are all my options?


Protection LED on, no output? Amplifi er is very hot = thermal protection is engaged. Test for proper
impedance at the speaker terminals with a VOM meter (see the diagrams in this manual for minimum
recommended impedance and multiple speaker wiring suggestions). Also check for adequate airfl ow around
the amplifi er. Amplifi er shuts down only while vehicle is running = voltage protection circuitry is engaged.
Voltage to the amplifi er is not within the 10–16 volt operating range. Have the vehicle’s charging and electrical
system inspected. Amplifi er will only play at low volume levels = short circuit protection is engaged. Check
for speaker wires shorted to each other or to the vehicle chassis. Check for damaged speakers or speaker(s)
operating below the minimum recommended impedance.
No or low output? Check the balance control on source unit Check the RCA (or speaker input) and
speaker output connections.

Jan 29, 2010 | Kicker ZX10001 Car Audio Amplifier

1 Answer

Light


The red light indicates that your amplifier is in protect mode. Amps go into this mode if there is something wrong with the setup of the system to prevent fatal damage to the amplifier circuitry. This is bad thing since the amplifier will not function until the problem is solve and it can remove itself from protection mode.

Amplifiers can go into protect mode for many reasons but one of the most common is incorrect mounting. Is your amp sitting on the metal of your vehicle? Is it bolted down and screwed into the metal of the vehicle or your seat? The amp should never be touching any sort of metal. Only the ground should touching the metal of your vehicle.

Speaking of grounds, many people often neglect proper grounding which can cause an amp to go into protect mode. Do you have a solid ground? Is the wire less than 3 feet long and directly connected to a non-painted metal part of your vehicle? Is the ground wire the same gauge as your power wire?

These are just a few reasons why an amp can go into protect mode. You can find more information here. Or simply google for why your amp is in protect mode.

Aug 06, 2009 | MTX Thunder 81000D Car Audio Amplifier

1 Answer

Audiofonics adf-241 no power all wires connected fuses ok.


Hello pimprascalz,

Many amps will go into protect mode if one of the speaker wires is shorted or grounded, or if the voice coil(s) are defective. Try disconnecting the speaker wires one at a time and see if the amp still goes into protect upon power up. Likewise, some amps will go into protect if one of the inputs is grounding out. Again, to troubleshoot, disconnect them one at a time and try the amp. Next, make sure that the amp itself is not grounding. Most amps need to be mounted to a nonconductive surface. If the case contacts the frame of the vehicle, it can cause a problem. If the problem is not in the speaker wires or the input cables, the amp case is not contacting the vehicle frame, and you have checked your power, ground and turn-on leads, then the amp itself is probably faulty.

Hope this helps.

May 19, 2009 | Audiofonics ADF-241 Car Audio Amplifier

1 Answer

My amp turns on and off


Sounds like there could be a short somewhere. Check to make sure that there aren't any (exposed/bare) wires touching each other or if there is a bare spot of wire touching something metal. Check both ends of all the wires. A speaker wire may have come lose and is shorting out against the frame or some other place. Usually if it goes straight into protection mode or you're popping fuses you have a short somewhere. I assume the capacitor you installed is somewhere on the power line, which would be for helping with
noise. You can also try disconnecting your amp from your stereo and see what happens but leave the speakers connected, you don't want to run the amp with out a load on it (the speakers). If your amp doesn't go into protection mode when the stereo is disconnected, then you have a problem with the stereo and not the amp, assuming you already checked for any possible shorts first.

Jun 15, 2008 | Pyramid PB1236GX Car Audio Amplifier

1 Answer

Amp goes into protection


First change the wire,and disconnect the subwoofers to check if the amplifier turn on without going in to protection mode,if the amplifier go to protection mode you gotta change the Audio amplifiers IC's because they are in short circuit.And if don't go in to protection put one speaker at a time to check if one of them are damaged.Good luck.

Jun 02, 2008 | Kenwood KAC-9102D Car Audio Amplifier

2 Answers

Protection Light irritation


If the amplifier goes into protect when there are no speaker wires connected to the amp, the amp is likely defective. The most likely culprit is shorted output transistors. If it's new, return it to the place of purchase for repair/replacement.

Sep 28, 2006 | Lanzar VIBE266 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

294 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4874 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76846 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...