Question about Amplifiers & Preamps

1 Answer

Jvc amplifier when i turn it on , no display is being given back and the red light for power it there but it disapeer when you turn on .

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 15 Answers

Hi, This is not a big issue, but you need to be carefull when you fix this. The main supply is ok. You need to look for that they call a Zener Diode. This will be connect in serie with a resistor so the time you going to spend finding this fault will be a lot. Also check your supply to the front panel and see that the supply is good

Posted on Jun 02, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Poineer deck amplifier dc-z74 relays click but set deck does not come on no display lights dead unit


Part of your PowerSupply is Frito.
Probably the +/- 15 volt rails, could be other.
Check inside power voltages, probably some regulators are gone.
Preferably get a tech unless you have the know-how and test equipment...
PEACE---

Feb 09, 2016 | Amplifiers & Preamps

1 Answer

I have a sony s-master digital amplifier which will not power up: when I plug it i to power it takes about 30 minutes before the red standby light comes on but no other functions operate.


So the standby indicator never changes state? If so, more than likely, your amplifier has DC Offset(a damaged amplifier inside) which will keep the speakers off, and disable any use of the front or remote functions. If you are interested in having your Sony repaired, please refer to my website, audioserviceclinic.com. You may contact me there. Thank you.

Jul 11, 2015 | Amplifiers & Preamps

1 Answer

Red power/protector light


The amplifier has gone into protect mode and will stay in that mode until the cause is corrected.

Nov 17, 2013 | Sony Xplod 800W Class AB Bridgeable...

1 Answer

NAD M3 power light turns red immediately and PROTECT message displays. Amp keeps functioning but volume control doesn't work up or down.


Hello
Check the connection to speaker with this amp, for any short or any other fault. disconnect the outputs, ie, speakers from the amp, and switch it On, and see the protect display comes or not. If it comes, the fault is internal and the set need service.
Your M3 dual Mono integrated amp, is of high output power and its outputs are protected against any overload or short circuit. If the system detect any among this condition specified above, it will show protect mode display.
Never load this amp, as protection display is there, as it may damage the speaker or its internal power amplifier section circuits, may cause more money to get it repaired. OK.

Jan 23, 2012 | NAD M3 Master Series Integrated...

1 Answer

I have been given an old Sharp music center but dont know how to connect the speakers to the amplifier sockets on back of amplifier look like this L I I R but I dont know how to put...


l means left r means right connect speaker wires by phono sockets or if no phono sockets then the wires go direct into the colour sockets red to red etc

Jun 08, 2010 | Sharp SX9860 2-Channel Amplifier

1 Answer

I have a jvc a-s5 intergrated amplifier that recently stopped working the power still comes on but previosly there would be a little pop and then the power light would come on, now the power light just...


Hi... There may be a couple of internal glass fuses inside. Check those. Make sure speakers are firmly connected.
Try the amp w/o speakers on.

If those fail it will need real service

Mar 16, 2010 | JVC Amplifiers & Preamps

1 Answer

Relay clicks, no display only the volume lights


Hello,
This is a common problem with a few of the Pioneer of that era (VSX-3300, 3700, etc). A secundary power supply line is faulty and it prevents your display from working. It is not an easy DIY, but a local tech should be able to fix. It is not always the same exact cause, as there are a couple transistors, a zener diode and a cap that can fail.
You can continue to use it without any detrimental effects on the unit, and can guess the settings.
Good luck

Jun 14, 2009 | Pioneer Amplifiers & Preamps

1 Answer

Behringer EP2500 trips immediately when turned on


Power supply section is overloading probably because of audio power amp problem.
Paul

Mar 31, 2009 | Behringer EUROPOWER EP2500 Amplifier

1 Answer

No sound from my amp


the red light usally means its over heating and turns off the amp as a protection

Mar 26, 2009 | Sony Xplod 500W Bridgeable Multichannel...

2 Answers

Europower Beringer PMH3000 power turns on then turn off?


when you turn on the AMP and the red light comes on give the amp 2 seconds and turn it back on the red light should turn off. That is what I do with the amps at my church and it works for me, I hope that this works for you too.

Mar 25, 2009 | Behringer EUROPOWER EP2500 Amplifier

Not finding what you are looking for?
Amplifiers & Preamps Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4590 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68301 Answers

Are you an Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...