Question about Car Audio & Video

1 Answer

When i hooked it up to my amp it was blown is ther any way i can fix it

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Expert
  • 417 Answers

Does the head unit still work?or is it just the speaker thats gone,must have been a sh*t hot amp or a **** speaker lol...does the amp work?
the resistor has probably gone on the sub or if not then the fuse has gone on the amp or on the back of the head unit.
i don't know i need more info about unit/sub & amp like watts & amps of them makes & models etc.....

Posted on Sep 30, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I hooked jumper cables up backwerds on my 95 vw jetta and killed all my electronics. is ther a safty fuse fore that or did i fry my computer brain?


Hi. I have found that the procedure fries the Gateway and the radio. The gateway will stop everything working. There is a 200 amp fuse on the front of the fuse box in the engine compartment. See if this has blown and replace this first though. It may have saved you.

Aug 29, 2014 | 1995 Volkswagen Jetta

1 Answer

Power light flashing


This means it is blown. Whenever the power light flashes on any amp it is blown or something else is wrong with it. Most likely its blown. You can blow am amp by hooking it up to a powerful sub and blaring it, or just overheating it. Hope this helps. This can usually be fixed as well

May 07, 2013 | Pioneer Gm-d8400m 1200w Max, Class D Mono...

1 Answer

I completely disconnected my amp and then hooked everything back up again, however the red protection light still came on. My ground is fine, as well as my cap... Any suggestions on how to fix the amp...


you may have already blown the amp...if it is doing this with no speakers hooked up to it trace your power and negative line to ensure there are no breaks or kinks in the line...also verify you ohm loads and such and that the amplifier can handle what you are introducing to it( if in fact there are speakers hooked up to it)..as i said b4 however there is a good chance the amp is blown already

Jan 08, 2011 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

No power after i unhooked the wire from amp, left wire uncovered at ends for couple days tried hooking them back up and no power now. is amp blown


if you unhooked the wire from the amp while the amp was on, you may have possibly blown a fuse, or mayb a transistor or compacitor inside the amp! easy fix, just find new transistors and compacitors and soilder them on after removing old ones!

May 03, 2010 | Rockford Fosgate Punch P8002 Car Audio...

1 Answer

All wires are hooked up but no lights come on, is


Hi Wex,

Wires being hooked up is fine. With no lights coming on the question becomes one of power.

Ground needs to be grounded.
+12VDC should have +12VDC
Remote should also have +12VDC when the stereo is on.

Check these with a volt meter. Negative lead on the ground terminal, Positive on +12V then Remote.

Both combinations should read +12VDC.

Next check the fuses if any that your amp has. Make sure they aren't blown.

Comment back if this doesn't point you in the right direction.

Mike

Dec 08, 2009 | Infinity Car Audio & Video

1 Answer

Hey my amp seems to be dieing on me. when i turn


maybe your frequency wasn't calibrated properly. If that doesn't fix it then next check the rms of both amps and go with the one that has the higher rating.

Sep 17, 2009 | Car Audio & Video

1 Answer

Have power but no sound


U may have blown the High Out put.


Not sure but is the Protection Led light on the AMP. if it has one it should be green if everything is Fine. Red or Flashing Red is not good.

U can test it has a low in out put . But if only has RCA out then u may want check the Fuses inside the AMP... Be careful because if u open it up after it was just turn on u will get a ZAP if the amp is not fully discharged.Look for any burnt Resistors etc,

Let me know if this works!!
Thank U Jayson
Please feel free to rate my suggestions.
we depend on your votes!!!

Jul 04, 2009 | Clarion APX400.4M Car Audio Amplifier

1 Answer

Subwoofers cut out while driving but amp LED light is still on...


To test if subs are blown push them in with your hand lightly and listen for any crunch noise if you hear one then they are blown

Jan 12, 2009 | Car Audio & Video

1 Answer

If it is not blown than what could it be ?


how do you know its not blow or fried?? is the amp good??? arte the input leads to the amp good??is ther at least 12 volts on the amps b+ wiring??

Apr 25, 2006 | Eclipse SW8102.4 Car Subwoofer

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

18 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4836 Answers

yadayada
yadayada

Level 3 Expert

75077 Answers

The Knight
The Knight

Level 3 Expert

73665 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...