Question about Crown CE1000 2-Channel Amplifier

1 Answer

Crown CE1000 My fan does not work, I bought it used and I recall it was working when I had used it earlier. Also, channel one would not play abd then three days later it was fine just no fan... Wavey

Posted by on

  • waveybnc May 30, 2008

    Robotek,



    I cleaned it and tested it. The fan works when I put a 9V battery to it. It does not work when it is in the amplifier.



    What do you think is the problem?



    Wavey

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 1,512 Answers

Hi waveybnc

The fan has failed, or is clagged up with dust. Remove it and clean it first. But best to just replace it. They are not that special and there is not alot that stops them from working. You can get a replacement device for the amp from Crown direct, or once you know its dimensions and power requirements, from here.

Thanks for using FixYa. Please rate my advice to you here as FixYa if it helps you.

regards
robotek

Posted on May 28, 2008

  • Graeme Ross
    Graeme Ross Jun 03, 2008

    Wavey,



    The fan circuit used in the CE1000 is a proportional control type that runs at 3 different speeds. It is possible that it is not operating at lower voltages presented in the slow fan setting. A couple of questions


    1. You say that it operates at 9 volts. What is the voltage rating written on the fan

    2. do you have a multi meter to measure the voltage being supplied to the fan. It is possiblk that the variable power supply to the fan has failed. Checking what voltage if any will help to isolate the problem.

    A thanks for trying rating is generally reserved for incorrect or useless answers. I have a careers worth of ability in repairing this type of product. Although my first suggestion may have been deferred by your testing the fan with 9volts, you had not indicated that to me initially, so we can go from there. Happy to assist you with sorting it out, an upgrade of your rating of my ability would be appreciated. :)



    regards

    Graeme

  • Graeme Ross
    Graeme Ross Jun 05, 2008

    any new info about the fan yet? Can easily get this problem to a resolve if you can provide me the info.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why fan stop working


If the fan is not working, it could be the fan itself, or it could be missing the voltage to drive it. I wouldn't use the amp with this condition, as you may cause output failure. If you need more information, or would like to inquire about a repair, please visit my website at audioserviceclinic.com. You may contact me there. Thank you.

Sep 03, 2014 | Crown CE1000 2-Channel Amplifier

1 Answer

The fan on my CE1000 does not come on when the amp is powered up. The amp seems to be playing normally, but I am afraid I may over heat the amp if the fan is not working. Is this normal?


The Thermal Senser on the Heat sink may be Defective. Heat the Thermal senser and see if Fan Turns on. It is a device with 2 screws holding it to the heat sink

Oct 07, 2010 | Crown CE1000 2-Channel Amplifier

1 Answer

Crown CE1000 and CE2000 both clipping with low signals


for some reason channel one of one of our amps started clipping. i first noticed it with the drum kit but it slowly moved to the vocals as well. i haven't noticed this issue before today. what do i need to adjust to keep it from clipping?

Jun 04, 2010 | Crown CE2000 2-Channel Amplifier

1 Answer

Fan running


Yes, many of the pro sound amps throttle the fan based on an internal temperature sensing device.

May 14, 2010 | Crown CE1000 2-Channel Amplifier

1 Answer

CROWN CE1000- slips into fault immediately after connection


if ur output power amp is defective u will have that problem - meaning the moment u connect load across it it will go into circuit protection to limit/stop excessive output current. make sure the speaker terminals are connected to +/- output terminals. in bridge mode use only channel 1 and that too with 4 ohms speaker only otherwise amp will clip. considering all connections are okay if it still clips when speaker is connected, u have a faulty power amp section. this the way ur amp is designed

Apr 05, 2010 | Crown CE1000 2-Channel Amplifier

1 Answer

Fan running


This is a very sophisticated amp and it will turn the fan on at various speeds when it feels the need for it. Of course, if it's running REALLY hot, going into thermal protection and/or posting a fault you might take a look at it to see if it CAN turn (no obstructions).

Mar 26, 2010 | Crown CE1000 2-Channel Amplifier

1 Answer

Crown CE1000 amps, 1 dead channel - Can I diagnose via RJ-45?


Before asuming it is the power transistors check the power on relay first as mine had the same proble and it was because of the Relay that did not switch on the one channel or amp (remember this is a power amp and consist of two mono amps)

Nov 07, 2009 | Crown CE1000 2-Channel Amplifier

1 Answer

Crown CE1000


Cuold be the final power amp ic. Might be imput transistors to that channel. Its possible to have a cold solder joint on pcb.
Look close at board with good light and a mag. glass to see if any foggy looking joints and heat up with soldering iron then dab with fresh solder.
Good Luck
BigRED

Oct 20, 2007 | Crown CE1000 2-Channel Amplifier

Not finding what you are looking for?
Crown CE1000 2-Channel Amplifier Logo

Related Topics:

368 people viewed this question

Ask a Question

Usually answered in minutes!

Top Crown Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4852 Answers

The Knight
The Knight

Level 3 Expert

72620 Answers

Paul Bade

Level 3 Expert

1398 Answers

Are you a Crown Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...