Question about Line 6 Spider Iii 30

1 Answer

My son has a Line 6 Spider III amp. The sound disappeared. I was told the problem is the power transformer had no power any longer. I need a 1X-5730-04H0 to replace the bad one. Where do I order from? How much does it cost? Help.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Line 6 Master
  • 5,603 Answers

Transformer failures are VERY UNCOMMON. I would verify the problem before trying to find one.

Most failures are with circuit board cracks and electrolytic capacitors.

Find a very competent electronic technician to check this out.

The RARE failures that occur in transformers are often poor soldering right near the terminals or lead wires. These can often be repaired without replacing.

Posted on Sep 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Line 6 spider ii. As soon as I turn on the power I get a huming sound. can not adjust anything. The only sound is the hum. Could it be a transformer problem! much appreciated


Not a transformer problem... this is likely filter capacitors, rectifiers, and PROBABLY a bad amp chip. Service this before it wrecks the speaker.

Jul 18, 2010 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Don't need a repair. I need a manual. know where I


Line 6 has the manuals on their site.

The Spider III 15 is in two parts: part 1 and part 2
The first is the manual, the second is the sample settings.

Both are PDF files.



Jan 20, 2010 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Hi My line 6 spider 111 30 has a problem The amp will switch on but there are no light showing and no sound, there is power to the amp as it will hum slightly when switched on


The hum MIGHT be directely from teh power transformer vibrating the chassis RATHER than via the speaker. This is an important detail to investigate.

Jan 14, 2010 | Line 6 Spider Iii 30

1 Answer

On any channel I've begun to get a intermittant


If this has a digital effects processor read on.., I had a SIMILAR problem on a Behringer GX110.

The electrolytic filter cap for the 5 volts of the DSP effects had gone bad. The 5 volts was dipping when the DSP reset and it would repeatedly reset causing a clicking at about once a second. 50 cent part fixed it. The part is a little undersized electrically so is more prone to failure in the unit I have.

That particular one had the DSP as a seperate board with its own 5 volt supply from the main transformer.

Dec 18, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Line 6 spider III 15 watt sound problems


Hi there. Sounds like the power amp IC is shorted. Must replace.
Paul

Jul 04, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

2 Answers

Amp turns on but no sound even with diff guitars and cords


Hi Dan
I wish I could just say what to fix, but you can not do this at home. Line 6 is a great amp and worth the time taking it down to the music shop , to be looked at an give you a repair estimate. good luck keep on rocking in the free world. DFD

Apr 12, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Black boxes on the lcd screen of the spider 6 III amp


unplug it and open it up. there are ribbon tape connections in there that arent very secure. maybe one came loose...

Mar 28, 2009 | Line 6 Spider Iii 15 Modeling Guitar...

1 Answer

Black boxes on the lcd screen of the spider 6 III amp


Make sure both the master volume and channel volume is up. If that does not do it, take it to the nearest Line 6 repair center.
http://line6.com/support/serviceCenters/

Mar 28, 2009 | Line 6 Spider Iii 30

Not finding what you are looking for?
Line 6 Spider Iii 30 Logo

Related Topics:

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Line 6 Music Experts

Vito Vacirca Jr.

Level 2 Expert

140 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Lawrence Nentwig
Lawrence Nentwig

Level 1 Expert

8 Answers

Are you a Line 6 Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...