Question about Hoover Windtunnel Deluxe U54219RM Vacuum

1 Answer

Deluxe windtunnel by hoover

Motor shuts off after a minute of running

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Check for a clog in the hose or the dirt inlet by the brush roll. When there is a blockage, the thermo protector will shut the motor off to protect it. That protector could be bad, or a problem with the motor. Is the brush roll turning freely and or is it froze up and won't move.

Posted on Jun 03, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Where do i check for the fuse on my hoover windtunnel vaccum


Most Windtunnels do not have a fuse but have a thermal reset in the motor which shuts the motor off it overheats.

Jan 23, 2018 | Hoover Vacuums

1 Answer

My vacuum got wet, still starts, but shuts off after couple minutes. It also sounds & smells funny.


It may not be safe to use anymore, the motor may be failing from the water intrusion.

Jul 23, 2017 | Hoover Vacuums

1 Answer

Mach 4.7 runs for 2.5 minutes and shuts off


Did you use it to vacuum up fine materials like powder? If you cleaned the filters, but they are original to the machine, replace them. Try changing the bag to a fresh one as well. Beyond that, check how freely the brush turns. If it doesn't turn freely that can but excess load on the motor, if its covered in threads, remove those.

Aug 01, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Why does my vacuum cleaner quite working about two minutes into vacuuming? It just shuts off. I have the pet fur picker upper version


Sounds like overheating of motor operating a thermal cut out ..Clean all filters you can run machine with no filters fitted to try if okay first.....

Jan 31, 2011 | Hoover U5753-900 WindTunnel Bagless...

2 Answers

Hoover U5780-900 Windtunnel a month 1/2 old just started stopping when it is running and wont turn back on for a few hours why?


The motor has a thermal protection sensor on it. So your motor may be going bad, it is pulling to many amps for some reason, could be a clog somewhere or a bad bearing in the motor.

Feb 21, 2010 | Hoover U5780-900 Windtunnel Cyclonic...

1 Answer

Hoover Windtunnel shuts down after 15 minutes


Might be that its not exausting enough heat & stutting its self down..

Try cleaning all the filters & the hepa filter..
This will increase air flow & maybe fix the issue..

Hope this helps !!
rate me good ;o)

Jul 14, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover windtunnel bagless shuts off when warm


it is a heat thermostat in the motor.
contact hoover or a local dealer

Mar 29, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover windtunnel..runs fine for 5 minutes then stops?


OK - sounds like your machine has a blockage somewhere. Follow manufacturer's instructions for clearing blockages and all should be well. If you no longer have the manual, you can download it from the Hoover website.
Good luck!

Mar 08, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Windtunnel shuts off after a few minutes of use.


yes i think i can help. all new hoovers have a thermal motor senser that turns the motor off wen it heats up to a certain point mine hade the same problem so i toke it apart and the bering in the motor was worn and heating up and tripping the senser if u have wd40 put some on the bering and be shure to wipe excess wd40 off so it doesnt get in the wires.

Feb 03, 2009 | Hoover U5450-900 Windtunnel Supreme Bagged...

Not finding what you are looking for?
Hoover Windtunnel Deluxe U54219RM Vacuum Logo

Related Topics:

124 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18424 Answers

Jim Parker
Jim Parker

Level 3 Expert

1041 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...