Question about Hoover Windtunnel Deluxe U54219RM Vacuum

1 Answer

Deluxe windtunnel by hoover

Motor shuts off after a minute of running

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Check for a clog in the hose or the dirt inlet by the brush roll. When there is a blockage, the thermo protector will shut the motor off to protect it. That protector could be bad, or a problem with the motor. Is the brush roll turning freely and or is it froze up and won't move.

Posted on Jun 03, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mach 4.7 runs for 2.5 minutes and shuts off


Did you use it to vacuum up fine materials like powder? If you cleaned the filters, but they are original to the machine, replace them. Try changing the bag to a fresh one as well. Beyond that, check how freely the brush turns. If it doesn't turn freely that can but excess load on the motor, if its covered in threads, remove those.

Aug 01, 2013 | Hoover U6437-900 / U6439-900 Windtunnel...

2 Answers

Why does my vacuum cleaner quite working about two minutes into vacuuming? It just shuts off. I have the pet fur picker upper version


Sounds like overheating of motor operating a thermal cut out ..Clean all filters you can run machine with no filters fitted to try if okay first.....

Jan 31, 2011 | Hoover U5753-900 WindTunnel Bagless...

2 Answers

Hoover U5780-900 Windtunnel a month 1/2 old just started stopping when it is running and wont turn back on for a few hours why?


The motor has a thermal protection sensor on it. So your motor may be going bad, it is pulling to many amps for some reason, could be a clog somewhere or a bad bearing in the motor.

Feb 21, 2010 | Hoover U5780-900 Windtunnel Cyclonic...

1 Answer

HOOVER WINDTUNNEL SELF PROPELLED OVERHEATING AND SHUTTING OFF


It sounds like it is overheating because of a blocked flow of air that keeps the motor cool. Check for a blockage from the area of the
roller brush through the hose to where it goes into the bag.

Tom

Oct 22, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Windtunnel shuts down after 15 minutes


Might be that its not exausting enough heat & stutting its self down..

Try cleaning all the filters & the hepa filter..
This will increase air flow & maybe fix the issue..

Hope this helps !!
rate me good ;o)

Jul 14, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

A burning smell is coming from my vacuum and it starts to smoke after using it for a couple of minutes


i love those situations... i wish i could be there to help you. anyway, the brushes on the motor could be bad... if the motor gets hot, i wouldn't suggest running it until you fix the motor. click here to check hoover.com for the brushes for the motor.

Apr 05, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover windtunnel bagless shuts off when warm


it is a heat thermostat in the motor.
contact hoover or a local dealer

Mar 29, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover windtunnel..runs fine for 5 minutes then stops?


OK - sounds like your machine has a blockage somewhere. Follow manufacturer's instructions for clearing blockages and all should be well. If you no longer have the manual, you can download it from the Hoover website.
Good luck!

Mar 08, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Windtunnel shuts off after a few minutes of use.


yes i think i can help. all new hoovers have a thermal motor senser that turns the motor off wen it heats up to a certain point mine hade the same problem so i toke it apart and the bering in the motor was worn and heating up and tripping the senser if u have wd40 put some on the bering and be shure to wipe excess wd40 off so it doesnt get in the wires.

Feb 03, 2009 | Hoover U5450-900 Windtunnel Supreme Bagged...

Not finding what you are looking for?
Hoover Windtunnel Deluxe U54219RM Vacuum Logo

Related Topics:

106 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...