Question about Audio Players & Recorders

Open Question

Marshall Haze 40 Combo On my MHZ40C's overdrive channel I sometimes get a "sizzling" sound that comes and goes when engaged in playing my guitar. (sounds like bacon frying) This doesn't happen when the guitar volume is off. Also, the sound seems "off in the distance." Like the amp itself is 100 yards away. The only remedy that I've come up with is switching channels back and forth via the foot switch or turning the stand-bye switch off and then on again. Can you tell me whats going on with my amp?

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

SOURCE: Samson Servo 170 - 1 dodgy channel

http://www.soundonsound.com/forum/showflat.php?Cat=&Number=403253&Main=351397

Posted on Dec 17, 2007

Ad
petraman7
  • 1175 Answers

SOURCE: Gem Sound XP-350 both channels failed

Speaker fuses are generally fast-blow styles 250 volt glass
If an amp shuts down, with speakers connected, it sounds like one of the power supply lines does NOT like what it's "seeing" . Probably output transistors bad ( or module)

Take it to a tech.

Scott out.

Posted on Jan 08, 2008

  • 726 Answers

SOURCE: Rotel Receiver RSX-1067

the rotal reciver is on the way out to the bin ,,,i chucked mine out and got a new one and was all good again i had same problems thats all i have to say and i dont think there is a fix to that

Posted on Jul 29, 2008

  • 4234 Answers

SOURCE: Marshall Valvestate 8100 Head volume

I believe that your model uses a 12AX7 tube for the pre-amp section. The tube is bad and needs to be replaced. Start there.

Dan

Posted on Oct 21, 2008

robotek
  • 1512 Answers

SOURCE: Marshall valvestate 40 guitar combo,

Hi Andy

The problem you face is most probably the same that stops most all valve state amps from working. They suffer terribly from fry/cracked solder joints. You will have to remove the main circuit board from the chassis, and resolder any suspect joints you can see, particularly about the rear loop in out jacks, control pots on the front panel, and power supply. There is a large power resistor and zener diode that cause problems in this model from memory. The valve never fails in these amps. Due to the lower supply voltages they are run at, they are not under alot of pressure, and as such give good reliable service. Go over the amp for dry joints first, and see how you get on. I have repaired so many of these with that problem.

regards
robotek

Posted on Nov 08, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Marshall Haze 40 Amp started making a very loud humming noise after a couple hours of playing.I let it cool down,and turned it back on and the noise came back after a few minutes


may be one of the electrolytic capacitors in the power supply has become leaky...this is a common problem among amplifiers...so you let it cool down..then after a period of time the capacitor heats up and then causes the hum...the power supply caps filter out the 60 hertz ac line noise...which is probably the frequency of the sound it is making...this is a good indication of these caps going bad....another thing you can check is to see if the amp is properly grounded(eg: the ground pin on the plug is present) and that you dont have an open cord or input

Jul 10, 2011 | Marshall Amplification Marshall Haze 40...

1 Answer

No sound when on overdrive


I am guessing that an IC is at fault. You don't really mean something like "no sound when switching to channel two" do you? If that's the case it could be a defect in a pot such as the volume pot. I have worked on hundreds of Marshall amps over the years. You can email me at computerlen@hotmail.com anytime for help if you want.

Jun 17, 2011 | Marshall Mg100dfx 100-Watt Combo Guitar...

1 Answer

When I use the over drive effect channel the head makes a rapid beeping sound.


Make sure your guitar cannot "hear" the amp as the guitar can be a pretty good microphone to cause feedback. Feedback sometimes saturates an amp and causes "squeging" which is a cycling into and out of feedback.

Apr 22, 2011 | Marshall Mg100dfx 100-Watt Combo Guitar...

1 Answer

Where is the serial no. on a mhz40c


The serial number for this will be on a sticker on the back. If it is missing then perhaps someone removed it. You may be able to contact Marshal and they may be able to tell you as well. http://www.marshallamps.com/

Mar 22, 2011 | Marshall Amplification Marshall Haze 40...

1 Answer

I play Gibson USA Sgs, one with 490/498 humbuckers and one with 57classics....The Amp has a loud buzz like feedback all the time on the overdrive channel.


If the amp is quiet with cables unplugged at the same settings as observing the buzz, the amp is OK.

In this case, cables and/or shielding and wiring in the guotar is suspect.

Guitar pickups are sensitive to magnetic fields and you can search out these fields by moving and orienting your guitar to find maximum buzz.

If the amp has objectional buzz with teh cables UNPLUGGED then the amp needs servicing. Filter capacitors among other things are suspect.

Sep 12, 2010 | Marshall Mg100dfx 100-Watt Combo Guitar...

1 Answer

I've had my marshall mg 50dfx for 3 months and it doesn't sound right to me because the overdrive is just barely different to the clean channel and doesn't have as sharp as sound as other mg50dfx models


Play around with your placement and where you are compared to the amp. I have a line 6 spider jam and I was getting pissed everytime I went into guitar center b/c theirs had more bass than mine. Then I realized that I put the amp beside me when I play but I play infront and over it when I go there. Have you ever noticed how much gain you lose when you take it outside compared to in your room. I would just look up the owners manual and see if you are missing anything. Check the fuse in the back too. If you clean isnt "that" clean and your overdrive is sucking then maybe the fuse is on its way out. Only $1 problem though. good luck

May 09, 2010 | Marshall Mg50dfx 50-Watt Combo Guitar...

2 Answers

Marshall MG50 DFX, the volume knob OD channel crackles


Either the control is damaged (happens if they get hit) or it is possible the circuit board it is mounted on has broken solder OR worse, a crack near the control. The unit will require servicing. Parts are readily available.

Jan 28, 2010 | Marshall Mg50dfx 50-Watt Combo Guitar...

1 Answer

Amplifier sound difficulties


When I turn on my marshall amplifier its makes this unusual, anoying sound. it sounds like a small motor or a fan going. the sound of the amp is good but its just makes this motor sound when I switch it on. can you help me find the problem.

Mar 25, 2008 | Prime 40 Watt 2 Channel Lead Electric...

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

81 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5151 Answers

The Knight
The Knight

Level 3 Expert

74383 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...