Question about Scosche Industries Scosche High Performance Amplifier Car Audio Amplifier

Open Question

The thermal light keeps comming on, on my 550 scosche amp. and i don't know why it keeps happening, i tried replacing the power wire from the amp to the battery. its used to run my sub fine, but it cut off one day and i wouldn't get it working right since. i have no problems with taking it apart, i'll try anything to get this amp working again becuause funds aren't the best to go buy a new one haha

Posted by on

3 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 83 Answers

SOURCE: Fuse problems

output leads shorted by chance?

Posted on Jul 12, 2007

  • 1 Answer

SOURCE: Scosche EFX work with MOS-FET Amplifiers

CAN YOU E-MAIL ME THE MANUALS FOR THE VOLFENHAG ZX 7150 AND THE ZX 7170 MY E-MAIL IS smas5305@yahoo.com thank you Thomas Anderson

Posted on Mar 23, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a scosche sa550 my overload light kept coming on then the amp switched to thermal mode. bigger gage wire running from my amp too my sub and yet it still does it what do u think the problem is?


The gauge of the wire isn't going to change anything in the amp. One or more of these is causing the amp to protect itself:
1. The sub has too low an impedance.
2. You're playing louder than the amp was designed for
3. One or more of your subs has a short in it.

Dec 07, 2015 | Car Audio & Video

1 Answer

Hey i have a scosche in-line fuse block i purchased. I haven't had any problems until recently. My fuse fried. So i bought more and went to replace it and every fuse i try instantly fries. i cant seem


Most likely the amplifier you have hooked up to that fuse position is defective and causing the fuse to blow. Or you have a short in the powerline somewhere. Disconnect the power wire from the amplifier, tape up the end so it won't short out to anything. Replace the fuse, if it doesn't blow then you will need to get the amp checked, if it does blow, then you have a short somewhere along your power wire.

Jan 30, 2014 | Scosche Industries Car Audio & Video

1 Answer

The thermal light comes on and all of the wires are connected properly. What does this mean?


unplug all speaker wires and turn on. if you still have a protect light on then there is an issue with the amp itself and if the light goes away plug in the speakers one by one while its on and the speaker that turns on the protect light has a problem

Jun 08, 2010 | Scosche Industries Scosche High...

1 Answer

Scosche amp and subwoofer not working


Be sure you have 12 volts on the remote wire. Fuse power for amp is switched using the REM (remote) wire.

May 30, 2010 | Scosche Industries Scosche High...

1 Answer

The fuses in my amp are good and so is my inline fuse from the batter, the thermal light is on but the amp is far from overheated. what can i do?


Not big enough gauge of ground wire. You should always match the ground wire gauge with your power wire gauge.

Dirty or burnt ground wire ends
Bad place of where ground wire connected

the load you on the amp might be lower that the lowest ohms it can handle...

Jan 15, 2010 | Scosche Industries Scosche High...

1 Answer

Have a 07 700 grizzly the battery keeps going dead and I just replaced it. the bike has 550 km


something is on ... somewhere.

That OR you arent charging.

Disconnect the battery put a amp meter between the + and the + wire. What is the reading? Anything above zero is a drain on your battery. Turn on the ignition ... what happened ... more drain?

Check your diodes in the rectifier to assure you arent loosing power to ground there because one is shorted.

Need more help, let me know ...

thanks

a

Oct 13, 2009 | 1997 Yamaha XJR 400

1 Answer

Popped fuses


make sure that the amp is properly grounded, paint somtimes makes it hard for the wire to be grounded, scrape off the paint with a screwdriver or whatever. also make sure that none of the wire are crossed exept if that was done on purpose

Jul 08, 2008 | Scosche Industries Scosche Build Your Own...

1 Answer

Lanzar amp


If it keeps blowing fuses then #1 its internally damaged or "blown" .. Or #2 i would make sure you have the battery power hooked up to the + terminal and the ground wire running from the car body to the - terminal.. so if its hooked up correctly and keeps blowing fuses then it requires repair.. I wish i had better news but thats all it can be...

Aug 20, 2007 | Scosche Industries Scosche High...

1 Answer

Fuse problems


output leads shorted by chance?

Jul 05, 2007 | Scosche Industries Scosche High...

Not finding what you are looking for?
Scosche Industries Scosche High Performance Amplifier Car Audio Amplifier Logo

Related Topics:

237 people viewed this question

Ask a Question

Usually answered in minutes!

Top Scosche Industries Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4844 Answers

ravie__s

Level 1 Expert

10 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Scosche Industries Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...