Question about Hoover F7425-900 SteamVac V2 Widepath Upright Vacuum

1 Answer

Leaking water and soap from bottom rear of machine. How do you disassemble to find the problem?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 11 Answers

VERY CAREFULLY!

Posted on Sep 28, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Wont spray soap


Please look at my other posts for this solution

Aug 24, 2009 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Leaking


Could be that the despensing tank has melted and deformed at the connection point. This is what happened to me when I put in really hot tap water. The heat allowed the connection (where the water/soap outlet is) to deform when using it. Now when I fill the tank and place it in the machine the water just leaks out all over the place with no control.
If you look at the bottom of your tank, where the water comes out, you may be able to see that the plastic is mis-shaped or deformed slightly. It probably doesn't take much for the seal to be broken.

TEA

Sep 22, 2008 | Eureka Atlantis 2591A Upright Steam Vacuum

2 Answers

Soap from dispenser will not release into carpet cleaner.


These are two different problems the first could be a clogged heater soap coagulates in the heater passages and clogs the flow of water to see if this is indeed the problem turn the unit on and try and spray water with the top trigger (floor nozzle) then try to spray at the hand nozzle if you get water at the hand nozzle but not the floor nozzle it is the heater. The hand nozzle water bypasses the heater. Also check the solution or soap tank if you pull it out and there is not red seal on the bottom it may be stuck in the machine and won't create a good seal check to see if it is still in the hole where the tank inserts. As for the unit not turning on that could be a number of issues cord,switch or just over heated. Visit www.stevessewandvac.com for any parts or questions about this machine or any other.

Aug 13, 2008 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

Whill not dispense liquid


There is a panel on the side for belt access, open this and inspect your belt. Usually replacing the rubber belt will fix this problem, as the belt from the main motor is what drives the water pump unit. (The cogged belt in the front is what drives the brushroll, but if the rubber belt isn't functioning properly the brushes generally won't turn either.)
If the rubber belt seems ok and the brushes are turning either you have soap clogging the lines, or your pump has gone bad.

Flushing out the water lines can help clear a soap clog, but to effectively do it requires disassembly of the lower chassis. Both this procedure and pump replacements in these units are a nightmare because all of the rubber hoses running around in the machine have a tendency to get pinched closed on reassembly, so if you do disassemble your unit, be very careful to align all of the hoses so that they are not crimped upon reassembly.

-R

Aug 09, 2008 | Vacuums

2 Answers

Bissel powersteamer clearview will not spray water


Did the gasket on the bottom of the water tank come off and is either missing or sitting in the hole where the tank sits? It needs to be on the tank.


Does water squirt out of the hose nozzle, if it does, then check the heater inside the handle asm. Make sure that where the tubes hook up to it are not clogged. If water doesn't squirt, check for the seal at the bottom of the tank, it needs to be on the tank, not in the hole, this is for the soap bottle also, there is a seal on the bottom of it as well. The flow indictor cap is leaking air or maybe is too tight. If you had the top cover off, make sure that the tubes are routed right so as not to get pinched when the cover is put back on, the smart mix knob should be in the water setting and that the piston is on the bottom of the smart mix knob. Pump is bad. Try running a mix of vinegar and water to see if that unclogs the lines. Is the top cover and the base tight together in the back, sometimes the top breaks loose and it will raise up and it can't spray, just re-fasten it down.

Jun 19, 2008 | Bissell 1699 ProHeat Clear View Upright...

3 Answers

Bissell 1699 ProHeat Clear View uses very little soap.


The valve at the bottom of the soap tank may have gone bad, Also try running a mix of water and vinegar(not on carpet) to see if it will clean the system out. The system may just need cleaning out.

Jun 06, 2008 | Bissell 1699 ProHeat Clear View Upright...

2 Answers

Steamvac drips when tilt to pull back


May have a problem with the seal at the bottom of the tank, the valve and seal sometimes go back and need to be replaced(#43513026).

Feb 22, 2008 | Hoover F7431-900 SteamVac Vacuum

1 Answer

No water out bottom..


Pump may be bad, also the cap for the flow indictor may be leaking air. Does the automix vale knob turn easily? If it turns real hard, then piston that the knob works may be jammed. Ckeck the seals on the bottom of both tanks to make sure they are on the tank and not sitting in the holes.

Oct 04, 2007 | Bissell 1698 PowerSteamer ProHeat Upright...

1 Answer

Will not dispense soap from handle


The soap dispenser, on the side, make sure the seal is on the bottom of it and not in the hole. You may have to replace the valve asm for the dispenser part # 2101795

Sep 30, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

3 Answers

Not dispensing water and no suction


I'm assuming the belts are OK.... Your heater is clogged. Unplug the machine and let it sit for 30 minutes. Take the handle apart, there will be a 4 inch by 8 inch metal box inside. This is the heater. Remember I said to let the machine sit for 30 minutes? If you didn't, the heater may be EXTREMELY hot!! Disconnect the two hoses going into it, and clean the metal pieces out (that the hoses connected to) with a needle or very small drill bit. You may want to remove the 6 or 8 screws holeding the heater together and remove the cover to clean it out. Reassemble and fill both tanks with VERY hot water ONLY and run the machine to rinse the entire system.

To prevent future reoccurences... use only Bissell extraction shampoos. Never put anything in the detergent tank except shampoo. (And only water in the water tank) Mixing chemicals with anything else turns the water/detergent mix to sludge. Also, when finished shampooing, put ONLY water in both tanks, and run the machine until one of the tanks run out of solution. Doing this rinses the hose lines out and prevents hardening of the solution in the heater ports.

I've fixed these machine for years. No dispensing is almost always the heater clogged.

Sep 29, 2007 | Bissell 7901-1 ProHeat Scotchgard Upright...

Not finding what you are looking for?
Hoover F7425-900 SteamVac V2 Widepath Upright Vacuum Logo

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18390 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1460 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...