Question about Jl Audio 500/1 Car Audio Amplifier

2 Answers

Whats the difference between jl audio 500.1 amp & jl audio 500/1v2? why is the price range so different?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    MVP:

    An expert that got 5 achievements.

    Habit-Forming:

    Visited the website for 3 consecutive days.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Contributor
  • 69 Answers

I believe the 'other' off brand line that JL represented was "TMA" or Total Mobile Audio. As JL attempted to break into the lower-end of the audio market they tested the reception of TMA to see if there really was a strong middle market that they were missing out on.

Once the decision was made to commit to this middle market they now sell the identical looking TMA amps using the well known naming nomenclature of the 'slash' and replaced it with the 'dot', then added their logo and voila, a 'new' middle-tier amplifier competitor.

make no mistake though, the dot amps are NOT competition amps.

Posted on Jun 16, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

500/1 is JL upper line, and the 500.1 is their lower line. They also have another line altogether that is under a different brand name.

Posted on Oct 22, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ok i have a jl500/1v2 amp with 2 w6v2 subs and i haveing a problem dont no if the amp is two much for the subs becouse i turn the amp to get more tump and the subs pop and the yellow light filkes so i turn...


its real simple. your under powered.

your W6s RMS at 500 watts EACH and your sending em 250RMS (half what they need)
The 'pop' your hearing is the failure to supply enough power to draw the cone back in time and collides with the next wave of sound.

prove it?
drive a single W6 with your 500/1 bridged.
i'll bet your pop goes away.

long term, get another 500/1 or jump up to a 1000/1v2.

I also HIGHLY recommend JL's in-line audio cleaner. If i recall it was like 60 bucks but waaaay worth it. makes sure that theres no distortion in the source input to your amp(s), which...keeps your subs from trying to reproduce transients and delivers only clear signal to your subs void of all clipping signals. Its an active electronic compoent.


PS: if you are pushing 12W6's, i had the same setup once...I had W3s connected to my 500/1 and upgraded to the W6s...had the same issue your describing, and then got the 1000/1. happy ending.

May 03, 2011 | Jl Audio 500/1V2 Car Amp

1 Answer

I have a jl audio 1000/1v2 my probem is the low volt ligth blinking and dosen t work wath shut I do


The low voltage light would indicate that there is not enough power reaching the amplifier through the power wire. Are you using 4awg or bigger wire? Is the amp grounded well? Does this happen all the time or just at high volume?

Try checking your power and ground connections and ensure that you are using the correct size of wire.

Mar 11, 2011 | Jl Audio 1000/1V2 Car Amp

2 Answers

I looked up the correct way to wire my JL 13.5W7 1.5. Therefore it said to wire it in parrallel. I understand this will put it at .75 ohm. As I start to turn it up it sounds great, very loud but once the...


1000/1v2 Class D Monoblock Subwoofer Amplifier Specifications:
  1000/1v2

Rated Power:
1000 W RMS @ 1.5 ohm - 4 ohm (11V-14.5V)

THD at Rated Power:
<0.05% @ 4 ohm

S/N Ratio:
>95dB below rated power (A-weighted, 20 Hz - 20 kHz noise bandwidth)

Frequency Response:
5 Hz - 250 Hz (+0, -1dB)

Damping Factor:
>500 @ 4 ohm / 50 Hz


According to the chart your amp is only stable down to 1.5 Ohms, so running at .75 Ohms the noise you are hearing is the amp clipping (running more power than it can handle at low ohms)
I would suggest wiring it in series, or you could adjust the gain on the amp until the popping goes away.

Hope this helps.

Nov 10, 2010 | Jl Audio 13W7 Car Subwoofer

1 Answer

I HOOKED EVERYTHING UP CORRECTLY BUT THE AMP WOULD ONLY STAY ON GOR ABOUT 20SECONDS THEN IT WOULD SHUT OFF. AFTER THAT WE TRIED ANOTHER AMP AND THAT ONE WOULDNT SHUT OFF. WHAT WOULD BE THE PROBLEM?


If the amp is a JL 500/1v2, it has a sensing switch which enables it to sense voltage, instead of running a remote wire. If this switch is set to on, and you have a remote turn on wire running to the amp........this can happen. I own one of these, and made that mistake myself.

Oct 18, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Have a JL audio slash 500 that isnt putting out any audio... i know the sub is fine. but i noticed the RCA inputs are loose and dont hold the cables very tight.. is this my problem and what can i do to...


Yes it possible that the inputs have been damaged on the circuit board of the amp. If the amp has hi level inputs you could try running a speaker wire input to it and see if it works. You might try another pair of rca cables to.

Aug 20, 2010 | Jl Audio Slash v2 500/1v2 Car Audio...

1 Answer

I have a jl 500/1v2 and when i have the volume up for some time it teens to turn the amber color light on and turns off my amp and sub i turn down the volume for like 30 sec turn it back up and every thing...


its probably wires touchin or the ground not connected well with fat enough wire. i would try to rewire and do everything all over again because one wire or fuse is messing up i had t he same probelm. its the red light on the amp is ur amp shut off or ur warning light?

Jun 03, 2009 | Jl Audio E1200 Car Audio Amplifier

2 Answers

Amp not putting out on speaker end


The audio amplifier IC´s maybe are fried

Nov 28, 2008 | Jl Audio Slash v2 500/1v2 Car Audio...

Not finding what you are looking for?
Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

316 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...