Question about Televison & Video

1 Answer

I have a Mitsubhhi VS-5043 Has sound but no picture

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 120 Answers

Try re soldering the pins on the yoke connectors. Common problem on that model that causes no picture.

Posted on Sep 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Mitsubishi VS-5071 rear projection turns on, has audio but no video


That is a VZ3 chassis, similar to Mitsubishi models Ts-4545, Ts-5045, Ts-5545, Vs-4543, Vs-4544, Vs-5043, Vs-5044, Vs-5047, Vs-6043, Vs-6047 and has common failures in the vertical circuit, specifically vert Ic401 which is a La7845 which is usually caused by defective C402 100uf 50v and/or open 1.2 ohm 2 watt R510 next to FBT.
If not that check C268 off Q215 on signal board 22mf/50v and Ic200 on signal module Cxa2025s. However the vertical failure is more likely.
Bill

Sep 10, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Mitsubishi vs 5043 no picture


have the tubes checked out you may have a loose connection

Jul 15, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Tv repair


try resoldering the vertical output IC and the horizontal output transistor. It sounds solder related

Mar 25, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

No pic but have sound


CHECK C268 (22 UFD 50 V) OFF C OF Q215 V-PROTECTOR ON THE SIGNAL PCB

Mar 22, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Sound no picture


Try resoldering the vertical output IC this is acommon problem with this model

Mar 20, 2008 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

No picture


check out info at ctechnicians.com

Dec 25, 2007 | Mitsubishi VS-5043 50" Rear Projection...

1 Answer

Black horizontal lines on mitsubishi VS-5043


Is the noise in all inputs (line, tumer) ? If it is in the tuner alone, check the coax lug to see if you knocked it loose. This could be the problem. Check you picture with a DVD player on the Video input. Let me know what you find.

Jul 03, 2007 | Mitsubishi VS-5043 50" Rear Projection...

2 Answers

Mitsubishi model vs-5043


I just had this same exact problem. I looked for an answer on here and could not find one. So I took the back off, vacuumed and cleaned everything out with the hose on my house vacuum, cleaned the bulbs and wiggled them around some. Voila !!!! lights on and all is working fine and better then ever. I hope this helps someone fix their problem. Just saved me tons of money and a morning of hassle.

Jan 06, 2007 | Mitsubishi VS-5043 50" Rear Projection...

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

22 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74459 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...