Question about Denon AVR-1908

1 Answer

Sub not working

I have done everything the manual told me to do but my sub is not working

Posted by on

  • maxliebo Nov 19, 2008

    denon avr1908 receiver is connected to a new phillips monitor, new phillips dvd player, and the hd cable box with hdmi connectors. my problems: when i play dvds the video works but stereo does not. when playing cable tv the stereo works but the video does not. i've checked the connections like ten times and it's all kosher according to the denon manual. help please!

  • Anonymous Nov 24, 2008

    speaker on for music but cannot play tv at the same time

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 3 Answers

Try going into the GUI and making sure that you have the setting correct for your components. Make sure that HDMI is selected for your gear. Make sure Auto is selected, if that is an option. If sound like your AVR is confused as to the connection sources (optical for audio, component for video, HDMI for both). Good luck and hope this helps.

Posted on Jan 05, 2009

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Power sub woofer is not working on my pioneer vsx-81txv everything is working all the speakers except the power sub connection at the back all i can hear is the hissing sound when i try to connect the sub...


Hissing? How loud? A sub isn't even capable of making high frequency sounds at normal volumes.

The Pioneer manual would tell you how to enable and test the subwoofer output.
Page 17 and the MACCV procedures on Page 33 (auto) or 43 (manual)

Jun 13, 2011 | Pioneer VSX-81TXV Receiver

1 Answer

Sub-zero model 532 side-by-side icing on inside panel


I would get in touch with SUB-Z customer service, they are the only company that still cares about customers
800.222.7820
They will be able to get it fixed

Jun 08, 2010 | Refrigerators

1 Answer

I just installed a kenwood dnx7140. Everything is


Have you checked to see if the sub amp is turning on. Check to make sure you have at least 12 volts on your power as well as your remote turn on (Blue/White on radio harness).
If everything is hooked up correctly, it is possible that the preout is turned off. Some headunits have selectable preouts. If so you should be able to turn the sub on and off in the menu.
Hope this helps
VOTE

Mar 08, 2010 | Kenwood DNX7140 Car GPS Receiver

1 Answer

(new owner) How do I tighten the rods? I was told it has to be done cold.


thats right it best if done cold. Chilton Manual Have a great Manual for that bike and will give a step by step process of everything you do to it. With pics too

Sep 12, 2009 | 1979 Harley Davidson XLH 1000 Sportster

2 Answers

Denon avr 2802 can't get subwoofer to work all else fine


in the Denon setup under speaker configuration set the sub to LFE+Main

Jan 02, 2009 | Denon AVR-2802

1 Answer

My Panasonic Cd player works and im getting power to my amp but no output though my subs..


mine's doing the same thing and i don't know whats causing it either other than its a factory defect

Jan 20, 2008 | Panasonic CQ-C1303U CD Player

2 Answers

Intermittent Problem Part 2


try getting new subs and an amp and see what happens. but i have two 12" pioneer subs and the wirings fine so i know they're blown.

Jan 16, 2008 | Sony XS-L1035 Car Subwoofer

1 Answer

No sound from Subwoofers


Did you check the gain level on the amp? Sometimes a bad or loose ground can cause this also. Was it working previosly and it stopped or did it never work at all. Let me know. Hope this helps.

Sep 13, 2007 | Alpine IVA-D300 6.5" LCD Screen DVD Player

1 Answer

Can't get to turn the sub On-Off


I had the same problem. The people at Kenwood are idiots when it comes to writing instructions. What you have to do is go to standby mode, hold the menu button until the menu displays. Now, scroll down to where it says "Rear." Push the control knob to the right. Now you have the ability to turn your sub on and off. Once that's done, just go back to CD or Tuner, push the knob down, hold for the two seconds, then it should say "On Sub." It took me a while to figure this one out.

Aug 28, 2007 | Kenwood KDC-135 CD Player

Not finding what you are looking for?
Denon AVR-1908 Logo

Related Topics:

93 people viewed this question

Ask a Question

Usually answered in minutes!

Top Denon Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

4990 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

The Knight
The Knight

Level 3 Expert

73460 Answers

Are you a Denon Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...