Question about Kenwood Car Audio & Video

1 Answer

I have a Kenwood KVT-911DVD in my tahoe. I heard a pop coming from the back of my truck, i have an amp under my back sit. i thought i blew my amp, as luck has it, my transmission went a couple of days later. i started trouble shooting the problem and found my amp to be working fine. because they disconnected the battery i needed to put in a password, i typed in my password and the screen went black. have you ever heard of a problem like this? what does this mean for my radio? any ideas. Thanks! Rob

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 4 Answers

Do any of the lights on it come on. Have you tried to take it out and connect the red and yellow wire to the battery and the black to the truck frame? This to see of any of the lights come on. Did you try to press the reset button? If you press the button and nothing happens then you may have to send it back to Kenwood for them to reset it.

Posted on May 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Kenwood kvt-911dvd disc error for dvd play?


you just bought it? take it back it may be a rare case of Dead on arrival.

Jun 10, 2008 | Car Audio & Video

1 Answer

Need unlock code for a kenwood excelon kvt-911dvd


You will need to visit an Authorized Dealer or service center for that product to get the unlock code reset. You can find a dealer listing on their website, or call them.

Jan 28, 2011 | Kenwood Excelon KVT-915DVD Car DVD Player

1 Answer

Does the kenwood kvt 617dvd have a brain bulit in or not


no it dont i have one for this unti not sure if it works thought bought it off ebay with my kvt-715 but they say the hideaway wont work it so i need to find one for my deck and this one as no wire harness either

Jul 10, 2009 | Kenwood KVT-617DVD Car DVD Player

1 Answer

I Have A Kenwood Excelon Kvt 911dvd,And It Is Locked due To My Battery Dying!


this guy will give you the code for free...but he is extremely busy and turnaround is 1-2 days

http://mike-unlockcodes.blogspot.com/

Oct 26, 2008 | Car Audio & Video

1 Answer

Blowing fuses


you may have the rem wire hooked up to the yellow 12v battery wire located on your harness. try yellow to yellow and if your rem is not working correctly when is hooked blue to blue put in on the red ignition wire located on your harness. should solve the problem. or return it

Mar 02, 2008 | AudioControl KVT-911DVD Car Video Player

5 Answers

KVT 617 CD/DVD "reads" but only audio from tuner


Ok, so I called Crutchfield, where I had purchased the unit, and the guy there said this is a common thing. Believe it or not, it IS the wiring. The guy said the blue wire on the harness needs to be connected to the blue/white wire on the Kenwood unit. Which is weird, since it's usually color-coded. He said the blue wire is a 12-volt amp wire, which works with the tuner, but when you take it off tuner, it kills the 12 volts and so you get no sound.

I haven't fixed it yet to be sure it works, but I thought I'd post this anyway, in case someone else is waiting on this. I'll post again if it doesn't work. :0)

Jan 29, 2008 | Kenwood KVT-617DVD Car DVD Player

2 Answers

Kenwood DV4100


Check the navigation setup and make sure the voice guidance is set to on. If it is, then the installer didn't catch the right wire for vss. Had the same problem, after getting my unit professionally installed, figured it was a problem with unit so I upgraded to the G510 and installed the DV4100 in my other vehicle myself, caught the right vss wire and now the unit works perfectly,displays turn by turn and gives voice guidance. Read previous solutions, they really help.

Dec 25, 2007 | Kenwood KNA-DV4100 GPS Receiver

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

101 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

6880 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...