Question about Vacuums

1 Answer

Vaccum overheating I have a hoover u5458-900 wind tunnel and the auto shot off has kicked in for overheat protection. i've cleaned the entire thing and let it sit like i was supposed to but it still won't fully turn on and stay on. it will turn on for a few minutes and then shut off and just cycle like that for a few times. is there anything i can do to fix this or should i just clean it more (if possible)?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Either the motor protector is bad, or you have a clog in the hose or the dirt inlet by the brush roll. Are the filters clean? It is also possible that there is a problem with the motor.

Posted on May 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why is it my vacuum cleaner keeps shuting off after ten minutes. i have a Hoover wind tunnel uh70086


Sounds like it has an overheat problem and is shutting down to protect itself. Make sure the exhaust filter is clean and that there are no blockages. Hoover UH70086 WindTunnel Cyclonic Pet Rewind Plus Upright Vacuum Parts...

Sep 17, 2015 | Hoover Vacuums

1 Answer

Hoover wind tunnel the red light dirt finder stays on


There's a microphone inside the tube the dirt runs up. It listens for dirt coming up the tube. They just go bad and there's no making it better. You can either replace that entire assembly or ignore it. Fairly easy to replace. I'll include the part so you know what you're looking at.
Good luck! The Vac Dr.

http://vacuummedic.com/product.php?id=481

Jan 13, 2013 | Hoover Company Wind Tunnel U53019 Upright...

2 Answers

My Hoover wind tunnel keeps overheating and the red I dictator is on. I have cleaned all filters and checked for clogs....could the motor have dust in it? How do I check?


Okay. I read these posts and decided to take the advice of checking the hose.
I had cleaned all filters, checked all hose (as-is) and did belt checks, etc.
The indicator was always showing red and it would shut down after about 5 minutes.
It ended up being a clog that I discovered after taking the hose completely off and seeing a clump right where the hose detaches. I began swinging the hose round and round and sure enough, more cat hair clumpls shot out. Big clumps.
So, you literally need to check every inch of hose to find the culprit.
After that, my indicator stayed green and it works like a charm.
Best wishes, Mike D

Dec 03, 2010 | Hoover UH70120 WindTunnel TSeries Rewind...

2 Answers

Hi My Hoover wind tunnel cyclonic stopped working when i was using it. I tried different plug even then it doesnt work . What to do??


If the motor stopped running, it most likely did because it was not being cooled, becuause something was stopping up the air flow. If you have cleaned the secondary filter out and it still stops while running, then remove the exhaust filter cartridge and try it then. If it does not stop running now, then the problem is the previous models like this had a foam filter as the exhaust filter, not a heppa cartridge filter. You will not hurt the machine by running it without the heppa cartridge. Cut a foam filter to fit to replace it. I do not think Hoover knows this yet.

I have a customer working on this problem today (Sept 2010) I have repaired machines for 30 years. This filter is meant to just catch the tiny particles from getting back into the air. However, it worked fine on the previous machines with the foam filter here instead of this Heppa cartridge.

Dave in Texas

Aug 31, 2010 | Dirt Devil Hoover Uh70085 Pet Cyclonic?...

1 Answer

WHAT VACCUM BAG TO I GET I HAVE A HOOVER WIND TUNNEL PLUS


Uses a "type Y" Hoover bag. Hope this helps, if so, leave feedback when asked. Thank you, Rene(the Vacuum Doctor)

Nov 09, 2009 | Hoover Vacuums

1 Answer

I have a Hoover Wind Tunnel Supreme mach 3.9. It


Check the filter above the dirt tank. If you take out the dirt cup and look where in slides into the machine, there is a filter that is probably dirty. It can be cleaned or replaced

Oct 08, 2009 | Hoover Vacuums

1 Answer

No suction on wind tunnel vaccum cleaner


Your brush might be clogged with hair. while uplugged, flip over the vacum and check to see if there is any hair or string wrapped around the brush...

Jun 03, 2009 | Hoover U5194-900 Mach5 Multi-Chamber...

1 Answer

Hoover Wind Tunnel Problem


motor burnout. replace the motor or get a new vacuum

Dec 15, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

186 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18330 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...