Question about Eclipse Premium 34230 Car Audio Amplifier

1 Answer

Amp turns on and off

Iv had my amp for like a year now and starting a couple of days ago it started to just turn on and off. i tried another amp to make sure i didnt blow it and the other amp i hooked up did the same thing.

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 137 Answers

Loose power connections. check your terminals.

Posted on May 19, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have an ma audio hk2000d. A couple years ago I hooked it up to a set of subs an it played just fine underpowered then it popped a fuse on the amp. Now every time I Start playing music the fuse pops. I...


Have you tried different speakers? If a speaker has a short, it will draw too much current from the amp and pop the fuse. Also, does the amp pop a fuse on idle, or just under load. What is the gain set for?

Nov 04, 2013 | Car Audio & Video

1 Answer

Subwoofer popping noise


i had an amp do that a few years ago i did everything it turned out that it was the cdplayer. then agin myfriend had the problem and it was his altonator he had to get a ground loop isolator they are cheap

Feb 02, 2010 | Hifonics Brutus BXi 1206D Car Audio...

1 Answer

Amp doesnt power on no lights or anything


To test if the amp even turns on take the amp and three wires (does not matter what guage) and connect it straight to the battery. Two wires (one for the power and the other one to the remote) and the third wire goes to ground. This will verify that the amp does in fact work. If this test fails then something has happened to the amp. If the test passes and you see that you do have power to the amp with this test then you know that you have a wire issue. Trace out your wires and make sure that you have a good connection throughout the car. This should fix the problem

Mar 16, 2009 | Kenwood KAC-9103D Car Audio Amplifier

1 Answer

I am ordering 2 pioneer TSW307D4 or D2 is a 2400 watts amp good?


ok theres a amp called slugger they came out about 7-10 years ago its small but very very powerfull i was picking up my 2 15 inch l7 kickers i drove from my house to vegas with no problem about 4 and a half hrs and didnt turn off ,on the other hand i had my fosgate wich i love t1000 wich turned off on me a couple times

Mar 15, 2009 | Hifonics Brutus BXi 1206D Car Audio...

2 Answers

Amp staying on but cutting out?


Hello Willb2396,

Actually you answered your own question in your paragraph. I draw your attention to your statement of:
"It will work for as long as I'm driving I will park my car, and when I turn it back on every thing will be working just fine and, then a couple minutes later, amp cuts out and won't hit for a couple hours or a couple days.... I have checked the sub multiple times and I don't see it being the sub or the amp"

You are correct it is neither the Sub nor the Amp. The problem is either your voltage regulator or your alternator. one and or the other is going bad.

Here is some advice check your ground wires, the buy a dual alternator kit, it contains the parts you will need to add an additional alternator to your car. This will provide the power you need.

I hope this helps,

Thank you,

Shuttle83

Nov 10, 2008 | Alpine MRP-M650 Car Audio Amplifier

1 Answer

481 doesn't work


did that to mine. Bat went dead and went to jump the car. What happends is when you attach the jumper cables, it surges the power to the amp. This gets worse with caps. I would say you blew the relay in the amp and needs to be replaced. It is worth fixin but youll have to send it off or take it to a repair shop to have the new relay put in

Oct 05, 2008 | Nitro BMW-481 Car Audio Amplifier

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

Car audio amp or speakers bad?


If you know how to use a multimeter, you can test the amp this way:

-unhook the subs
-hook up a cheapie speaker you know for sure works to one of the channels
-unhook the audio inputs
-turn the amp on
-set your meter to VDC
-put the positive probe on the inside of the input connector, being sure you make contact with th inner contact
-take the negative probe and tap it on the outside of the connector

What you are doing is sending a low voltage (replicating an audio signal) into the amp audio circuit and allowing the amp to amplify it. If the amp makes the speaker pop each time you strike the probe, the amp is working.

There is an inherent problem with band passes. The naturally filter out high frequencies like a crossover, including distortion, so it makes it hard to hear when the subs begin to protest.

Nov 22, 2007 | Dual XAF-460 Car Audio Amplifier

1 Answer

Strange Starting hum as amp tries to turn on?


First of all you need to look at the specs on the amp and see what ohm load rating it runs at. for example  (4 ohms @ 200watts)   and check your configuration because if you go below that rating  for instance if the amp only can do 4 ohms and you parallel them speakers down to 2 ohms  the amp will go nuts and blow up.    After you find out informations about the amplifier ohm your speakers out with an ohmmeter and see what resistance you have on your single / dual coils   and wire them up to proper configurations so that your amp and subs are matched.     ALso check your RCA'S  For signal problems.

Oct 13, 2007 | Eclipse DA7232 Car Audio Amplifier

1 Answer

My amp turns on then off while it slowly blows the fuse out


If I were a guessing man, I'd guess that you had your amp hooked up in a bridged configuration. And also that you connected your two speakers in parallel (plus to plus and minus to minus). And if I were to further guess, I'd guess that you have a blown amp now because of what I mentioned above. Sounds like you need to spend some quality time with your favorite electronic repair shop. Good luck.

Feb 23, 2007 | Hifonics BXI 1606D Car Audio Amplifier

Not finding what you are looking for?
Eclipse Premium 34230 Car Audio Amplifier Logo

Related Topics:

42 people viewed this question

Ask a Question

Usually answered in minutes!

Top Eclipse Car Audio & Video Experts

The Knight
The Knight

Level 3 Expert

69610 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

xxxxxx xxx

Level 3 Expert

4724 Answers

Are you an Eclipse Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...