Question about JBL GTO75.4 Car Audio Amplifier

1 Answer

Protect on car amp

My amp was working for a long time and now I dont hear any music from my subs. what do you think is the problem.

Info: I have a capacitor also.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If the amp is in protect mode, it probably has shorted output transistors. To eliminate other possible problems, do the following. I'll assume that you've checked the amplifier's on-board fuses.

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

If the voltage remains near or above 12v, disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still shuts down, the amp almost certainly has shorted output transistors and will need to be repaired.

Posted on May 17, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My amp was working good and i didnt use like for two months and know it doesnt work the green light turns on but the red light too of over current and i cant hear nothing i dont know what is it..


if it turns red its a protection light you most likely got the ohms wired wrong on the speakers and the amp is going into protect mode so you dont fry it or the subs

Mar 04, 2011 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

I think ma kicker kx1200.1 amp is blown or ma kicker L7 are gone


that would be the amp. sorry to say. when a wire crosses over, it sends a shock through the amp, there are a few things to try just to see if you fried the amp. the first thing to try is to move your ground to a different location. second thing to look at would be the fuses. alot of times the fuses will blow at the slightest shock. the amp will still turn on if you have an amp with 2 fuses, it just wont be getting all the power it needs, which could be causing your problem. also, it is worth the hour and a half to mount everything down in your vehicle. you might check the kicker website, because i have herd rumors that kicker offers a lifetime warranty on almost all of their products. best of luck, and i hope you didnt fry your amp.

Apr 09, 2009 | Kicker KX1200.1 Car Audio Amplifier

1 Answer

Visonik amp problem... amp goes in and out of protection


Check for intermittent shorts on the speaker leads.

Turn down the volume control on your head unit while operating the amp, you could be over driving the amp.

Remove Speaker leads and reset the amplifier. IF the protection LED still comes on amplifier is faulty.

Below is the link to put in a help request with the manufacture for repair.
http://www.visonikcaraudio.com/category.jhtm?cid=27

Mar 25, 2009 | Visonik V408XT 250W x 2 Car Amp Car Audio...

2 Answers

Rockfordfosgate P6002 amp protect light goes on


are u sure u have them running at the right ohms, for not only the subs but the amp too...if you go lower than your amp is rated you can fry stuff...via protect mode......hopefully this helps

Mar 17, 2009 | Rockford Fosgate p-450.4 Car Audio...

1 Answer

Amp gets power but no sound


Hello, First of all with these new Alpine amps everithing adjustable just about is digital, as well as the internal workings of the amp to a point. If you bought this amp new then check your warranty or take it back where you purchased it if you can. Check that your amp is getting an input signal from your head unit. Check your head unit sub output settings, something could have gotten turned off or down. On this paticular amp if there is a problem internaly it would let you know or go into protection mode. You say your sub has ben tested and is good, check again. Hook another speaker up to the amp. Unhook that speaker and try, you never know. Like I said, if the amp is'nt going into protect mode and the digital display is'nt telling you any types of faults then it has to be the input signal. Make sure you are getting a signal. That has to be your problem otherwise amp would be in protect mode. Let me know what you find.

Feb 12, 2009 | Alpine MRD-M605 Car Audio Amplifier

1 Answer

My Subs blew out but I dont know why??


rewire the whole system with new wires,you could have a bad ground or wire try it first if that dont work rewire

Jan 08, 2008 | Jl Audio 12W3 Car Subwoofer

1 Answer

Problem with amp...


In virtually all instances where the protection light is illuminated, the amplifier has gone into protection because the output transistors are shorted. To eliminate external wiring problems do the following.

Disconnect all speaker wires from the speaker terminals of the amp and disconnect signal cables from the amp. If it powers up, the wiring needs to be checked. If it still goes into protect, the amp likely has blown output transistors.

If it does have blown outputs, it's is likely due to the speaker wires shorting together when the woofer was out of the vehicle.

Dec 29, 2007 | Jensen XA4150 Car Audio Amplifier

1 Answer

I do not hear any music through my 10" M Audio Subs (M Audio Sound System)


If you know how to use a multimeter, you can test the amp this way:

-unhook the subs
-hook up a cheapie speaker you know for sure works to one of the channels
-unhook the audio inputs
-turn the amp on
-set your meter to VDC
-put the positive probe on the inside of the input connector, being sure you make contact with th inner contact
-take the negative probe and tap it on the outside of the connector

What you are doing is sending a low voltage (replicating an audio signal) into the amp audio circuit and allowing the amp to amplify it. If the amp makes the speaker pop each time you strike the probe, the amp is working.

You mentioned you need a 4 channel amplifier make the two, dual voice coil subs operate. The is not true and by hooking them up like that, there's a chance of damaging the subs. The reason is that the dual voice coils are interwoven and they have to get electrically identical signals or they fight against each other. The can mechanically fail, then, electrically fail, then even damage the amp too.

Nov 21, 2007 | Nakamichi PA-504 Car Audio Amplifier

Not finding what you are looking for?
JBL GTO75.4 Car Audio Amplifier Logo

76 people viewed this question

Ask a Question

Usually answered in minutes!

Top JBL Car Audio & Video Experts

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1144 Answers

isaac johny
isaac johny

Level 3 Expert

796 Answers

yadayada
yadayada

Level 3 Expert

70381 Answers

Are you a JBL Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...