Question about Hoover L2310 GUV Central System Vacuum

Open Question

I am looking for a hoover inlet valve assembly type WV. made by Hayden Mfg. I also need the power connection that fits above the hose inlet. It has one black wire and one white wire. I have been trying to find this for a week. I have seen one on line but it did not include the power connection.

Posted by on

Ad

6 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad
  • 55 Answers

SOURCE: Hoover F6028-900 Need to replace

It's probably harder to explain than it is to do.

Take off the recovery tank and underneath it you can see where the hose attaches to the unit. On the bottom side of that inlet is a clip that latches the hose onto the machine. Slide a flat underneath that clip and gently lift it(It breaks very easily) while pulling on the hose. After you get that part off the just pry that corner piece out off the machine(Okay to use some force with that) and the hose comes off and the new one just pops back on the same way.

If you do break that clip(It happens to the best of us), just drill on small hole on the top and use a screw to hold it in place, thats all that clip does anyhow.

Good Luck! Let me know how it goes, and let me know if there is anything else I can do to help.

Posted on Dec 01, 2008

Ad
  • 18 Answers

SOURCE: Hoover steam vac hose broken so I get no suction.

The entire hose has to be replaced. I beliive they run about 39.99

Posted on Jun 11, 2009

  • 18 Answers

SOURCE: Help!!! I bought a replacement nozzle valve for a

Hessco.com

Posted on Jun 11, 2009

SOURCE: wiring diagram s3755 hoover

Today I shortened my hose by 4" to get around a tear problem. You can use an Ohm meter to find the right 4 wires. When looking from the top of the canister with the hose heading to your left, the wires should be:
White (furthest connector away from you)
Black - to the switch
Red
Blue
With the Red and Blue going to the speed con trol curcuit board.

Posted on Sep 20, 2009

  • 430 Answers

SOURCE: i need a replacement hose assembly for the hoover

Only through a Hoover warranty/ service center if still available. If not save your hose ends and find a different hose with adaptable ends

Posted on Nov 27, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do i replace a valve assemblyon a hoover widepath f6020


You don't need a new hose. Remove the two Phillips head screws which hold down the wand cover. Be very careful when removing these parts. Pay close attention on how these parts are assembled. They are spring loaded and will fly out the end of the hose assembly when the cover is removed. The wand valve assembly or the nozzle valve assembly or usually the parts that break. Vac Parts Warehouse Here is a link of the parts breakdown.

Oct 12, 2014 | Hoover SteamVac Carpet/Upholstery Deep...

1 Answer

Hoover troubleshooting


Hi! Try these quick and easy steps to get the water from your hose to spray.

Assemble the hose to the unit.

While holding the hose at an angle towards the ground, pump the trigger about 30 times. Turn the cleaner on then squeeze the trigger for 30 seconds.

If the water is still not dispensing there may be soap residue bulid-up clogging the nozzle/valve. Try soaking the trigger end in warm water for a couple hours, then repeating the steps above.

If the cleaner is still not dispensing from the hose but dispenses from the unit, a replacement hose may be needed. Follow the link below to order a replacement hose for your cleaner. Search Results

Aug 23, 2014 | Hoover F5826-900 SteamVac Upright Wet...

1 Answer

Hoover max extract leaks from end of upholstery hose


Hello! The nozzle/valve assembly, the white piece at the end of the hose that releases the solution may be clogged with build-up residue. Try soaking the trigger end in warm water for a few hours. If this does not help, the nozzle/valve assembly may need to be replaced. Order the nozzle/valve assembly by following this link. Search Results or order the complete hose assembly by following this link. Search Results

Hope this helps!

Jun 06, 2014 | Hoover SteamVac F5914-900 SpinScrub...

2 Answers

I have a built in vacuum with a Hayden Deluxe Superpack carpet nozzle. The vacuum works but the Superpack power nozzle does not turn on. Reset does not work. Are there steps for troubleshooting, or...


Find a local vacuum repair center. Could be a short in the hose. The PN could need a new motor or circuit breaker. It will be cheaper to repair than replace, but check the hose for current at the handle end.

Jul 02, 2010 | Hayden Industries SuperVac 6000 Central...

1 Answer

I have a Hoover steamvac ultra. The handheld hose


If you have installed the hose properly, try to hold your hand over the suction end with the cleaner on to prime the water in the hose. There is no way to dissasemble the hose. You could have a possibility of a few thing that have failed,
1. the pump that feed the hose
2. the valve on the hose end
3. the check valve where you connect te hose to the machine
Also verify that you are dispensing solution to the floor, if so, then the above needs to be checked.
Have it looked at at repair shop for diagnosis

Oct 09, 2009 | Vacuums

1 Answer

I've just installed a hoover central vaccum SH800CA and when i plug the hose in the inlet, it doesn't turn on. It turns on when I turn on the switch on the canister


The hose connects to a set of low voltage contacts inside the top of each inlet. The vac wiring is connected by a low voltage circuit to each inlet as well. your hose when plugged in completes the circuit when you turn the hose switch on. For simplicity ,I also use a coin to connect the terminals mentioned below instead of dragging the hose with you.
Reinsert the hose with the tongue or cord at 12 o clock or 6 o'clock position. If the vac does not start, rotate the hose cuff to 3 oclock.This over rides the hose handle switch to test the vac circuit.
if the vac still does not start you have a loss of LV signal in your wiring. You will need to back track to make sure you have continuity from the vac to each inlet.
if you have colored alarm or telephone type wire, it is very easy to break a wire strand while fastening so go back one connection at a time and inspect.
If you have no power to any inlets,your problem will be in the main run of wire from the vac, likely to the first connection. If you have power at only some inlets, your issue will be at one of your wire junctions, either at a pipe intersection or where two wires meet at an inlet, depending on how the system was wired.
Post back to say how you are making out

Sep 27, 2009 | Vacuums

1 Answer

Hose to the machine split just above the connection


Not a fixable problem. You have to purchase a new hose assembly.

Sep 15, 2009 | Hoover F5872-900 SteamVac Wet/Dry Vacuum

1 Answer

Need a front wheel assembly for my Hoover Tempo model u5144-900. I see similar looking Hoover wheel assemblies online for different models, will they fit mine?


The Tempo series cleaners look similar, but are different colors. The wheel assemblies will work if they look identical in appearance to yours.

Aug 07, 2009 | Hoover U5144900 / U5146900 / U5147900...

1 Answer

Hayden 6000+ wont run


Define hose works or doesn't, no suction, hose will not activate vac , etc.
Test the vac by shorting across the low voltage terminals where they enter the machine. If the vac works here your problem is in the internal wiring, at the valve or the hose to wall connection. If the vac will not run, you will need to check the motor for continuity across the motor leads.

Apr 18, 2009 | Hayden Industries SuperVac 6000 Central...

1 Answer

Hoover Portapower hose won't stay on, when it does poor suction.


In reply to the problem you have about the hose not staying attached very well, we had this problem years ago with one of our old cylinder vacs. Sometimes after several years of the hose connector being rotated to attach/remove it from the machine, the lugs that lock it into the hole can wear down or become mis-shapen as they are only made of plastic.

I have a UK model Hoover Portapower and luckily have never had this problem as I hardly remove the hose at all (except when emptying the bag). If you remove the hose from the machine and have a look at the connecting part of the hose where it attaches to the machine, there should be two lugs/clips either side of it. If these lugs look a bit mis-shapen or the plastic on them looks worn, then the hose will not fit the two slots either side of the hole on the inlet fully hence the hose being loose. The only way to cure this problem is either put a little bit of electrical tape on them which will stick the hose to the machine better as that's what we did. Overall though you are probably best replacing the hose for a new one if this is the case as these lugs will then be the correct shape to fit the machine properly on a brand new one :)

Mar 04, 2009 | Hoover Portapower C2094 Bagged Canister...

Not finding what you are looking for?
Hoover L2310 GUV Central System Vacuum Logo

Related Topics:

17 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18415 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1474 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...