Question about Alesis iO | 2 Sound Card

3 Answers

I have an Alesis iO|2 device that I am using with Cubase 1.0.8 running on Windows 7 64 bit. Effectively the iO|2 is my sound card. It works fine with all MP3s played from my hard drive, but when I use it with Cubase it sounds okay for a little while then breaks into an extremely loud static noise. If I switch to another application and then back to Cubase, the sound is normal again, but soon after, I get the aweful static noise again. I must use the iO|2 as it is the only way to record guitars and bass guitars into Cubase. Even when the sound in Cubase is normal, I still hear a crackling noise and as I said above, soon after the horrible loud static noise happens. I had the same setup on a Windows XP machine and it was reasonably stable, with the static noise occurring very rarely. Hope you can help. Cheers, Brent

Posted by on

  • 1 more comment 
  • Brent Taylor Sep 16, 2010

    While Silverdragon's response was useful, I don't think it is a hardware problem. It is definitely software related. I guess one useful option would be for someone to point me in the direction of a current Alesis driver for iO|2 written for Windows 7 64 bit. As I mentioned in my initial problem description, it did work okay in Windows XP service pack 3.
    Cheers, Brent.

  • Brent Taylor Sep 16, 2010

    I have already done what Ryan has suggested with Cubase, and have changed some of the settings to the point where I have removed the crackling BUT the horrible static noise still persists. I guess what I really need is for someone to point me in the direction of a 64 bit driver for iO|2, but from other stuff I've read on the Net, Alesis only produced one driver and no others for the iO|2.

  • Brent Taylor Sep 16, 2010

    I have already gone to that site and came back with nothing - all that is available for iO'2 are manuals downloads. No firmware or software in sight. I've already done the uninstall reinstall thing to no avail.

×

Ad

3 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Alesis Master
  • 19,396 Answers

Hi.

Go to Alesis website and update firmware and software. If that does not work you may need to uninstall Alesis software, uninstall Cubase, then reinstall Alesis software, update software with download from website, and finally install back cubase.

Here download page.

If that does not fix the problem contact Alesis describing the problem.

Posted on Sep 16, 2010

  • Ginko
    Ginko Sep 16, 2010

    Hi.

    If there is no download, send the message to Alesis using their form. The problem is between Alesis software and Cubase, which is bundled software sold with the unit. I do not think there is an hardware problem either, and the only ones that may be aware of a particular software issue like this is Alesis.

    Also reinstall Alesis and Cubase in order, as suggested in my previous comment, that can sometimes fix software problems.

×

Ad
  • Level 1:

    An expert who has achieved level 1.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Contributor
  • 942 Answers

You may check the sound settings of Cubase by disabling / enabling it. If you have other ports that you can connect with your Alesis device, try it and observe if there is static noise going on. Since in other devices like Windows XP or any other computer products in which they are working, I guess you need to take adjustment on Cubase. That is my analysis for that..

Posted on Sep 16, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 12,061 Answers

Ok, static noises are usually caused by a few things, please check, replace the Power Supply. Check for Dry joints inside the unit, also earthing, this is critical, for it to be properly earthed, BETWEEN units, (This is a major cause) Drivers, are another area to look into, make sure you have the latest up-to-date drivers. Make sure they are written for the 64 bit system, or you will have problems, it may even pay to downgrade to a 32 bit system. Make sure any possible feedback paths are minimised, (Good Earthing again) Check all Variable Controls, spray inside them with GO-Contact Cleaner, or similar, sometimes the Potentiometers have carbon buildups if they are kept at one setting for a while, this will cause this noise too.
This can also happen if you have a bad switching IC too... Clean all connections make sure they are all tight and make good contact, again spray with contact cleaner, and even use a fine abrasive to clean them.

Posted on Sep 16, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My pc does not recoginze it any more. Power do not come when plucked but only flash once


1 have you change OS (operating system0 that is have you upgraded to Windows 7
2. Have you upgrade or changed anti virus software.
3. check the " Device manager" for corrupted USB ports.
4. make sure the contact for the male end of the USB are making contact to the female input of the USB port.

Sep 08, 2011 | Alesis IO/2 Portable 2-Channel/ 24-bit/96k...

1 Answer

Why my pc don't read io2?? i have windows xp. is there a driver ??


Go to this site just type this address drivers.softpedia.com/get/SOUND-CARD/OTHER-SOUNDCARDS/Alesis-iO-2-Driver-10.shtml

Jul 01, 2011 | Alesis iO | 2 Sound Card

1 Answer

When i import an instrumental into cubase it will playback but will be very distorted, if i change the device settings in cubase and dont use the io2 it will playback fine so im assuming its something to...


In order for an imported file to sound correctly in Cubase, the bit rate and KHz must be the same or you will create garbage when going through your interface. For instance if you have ripped something from a CD it will be in 16 bit 44.1 KHz format. If you were to pull this into Cubase at 24 bit with 48 KHz selected as your projects rate you would encounter this problem. (I'm guessing this is what is causing your problem.)
Please open up cubase and click import, a window should pop up asking if you want to convert formats, please select the check boxes for conversion for the bit rate and KHz (depending on what version of Cubase it will be something similar to this.) An alternate solution is to go to the project preferences and select the rates that match the imported material before importing and no conversion will be necessary. (Although, I recommend always working in 24 bit and 48 KHz if you're machine can handle it.) A final possibility is that you have the latency set really low and the converters can't handle the speed at which the information is being processed. If the above should for some reason not work, check in your preferences box in Cubase if possible or through software that came with your interface and increase the latency. This can cause an audible delay between the time you hit a note and hear it back so make sure to decrease it before recording and increase it while mixing since you won't being recording new material and can use that processing power that would have gone to making sure you hear your live audio quickly can be steered to use plug-ins and get crackling free playback. Remember, with latency, even if get crackling from a low latency you will not hear that crackling upon mixdown! However, I'm quite sure your problem is with conversion rates, but if never hurts to know or get a reminder on things like latency. Cubase is a high quality product and I hope you enjoy using it. Thank you and I hope this helps.

Feb 25, 2011 | Alesis iO | 2 Sound Card

1 Answer

My alesis io2 express isnt working, doesnt work with my mac, not on garage band or cubase, is it compatable? what should i do?


When using with PC you have to go into soundcard settings and disable the internal sound card and select io2 or asio drivers.
I'm thinking it's the same on a mac
David

Oct 03, 2010 | Alesis io 2 Portable 2-Channel 24-bit...

1 Answer

No playback sound on cubebase le4/alesis io2


I am not 100 % with cubase but I am pretty sure it defaults to playing via midi and that you HAVE to set up the sound devices from the options first.

Hope it is of some use

Aug 22, 2009 | Alesis IO 2 Sound Card

1 Answer

How do i get Cubase Le 4 to recognize and record my Alesis Io2


You may have a conflict with the onboard sound. If that is not turned off your card will not function.

Jan 07, 2009 | Alesis IO/2 Portable 2-Channel/ 24-bit/96k...

2 Answers

Alesis io on a dell vista inspiron machine


I have one of these io/2 boxes and they are great, shame windows doesn't keep the drivers for long, and crashes on resttart so ythe box will not load at all.
The solution is to do a destructive uninstall.

To do thus, you need to carefully drag the device out of your laptop, and away to a safe place, and then smash it to pieces with a hammer. In this way you will totaly remove the need for any drivers.

lol... seriously, i dont know how to fix this issue. I think my box is broken, i'm sending it back, i dont think alesis have thought this box through enough.

May 01, 2008 | Alesis iO | 2 Sound Card

1 Answer

Distorted, horrible sound with IO|2 and guitar


I'm new at it too, but if you increase the buffer to around 256 or higher than you have it anyway, you might get rid of the distortion. Look in the ASIO control panel

Mar 01, 2008 | Alesis iO | 2 Sound Card

Not finding what you are looking for?
Alesis iO | 2 Sound Card Logo

Related Topics:

476 people viewed this question

Ask a Question

Usually answered in minutes!

Top Alesis Computers & Internet Experts

yadayada
yadayada

Level 3 Expert

76691 Answers

Raghavendra Nagaraj
Raghavendra Nagaraj

Level 2 Expert

108 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you an Alesis Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...