Question about Kenwood KAC-8103D Car Audio Amplifier

1 Answer

Transistors I have a Kenwood KAC 8103D 1000 watt Amp. I had 3 tens hooked up. Sold 2 of the Tens. Plugged in one and of course blew the 1 Ten. I bought a new 12 to connect to the Amp. But... when I plugged in, the Amp power light Flashes on and off rhytmatically. It's not a flickering. It's a flashing. I read in here that this can be fixed. Yet... no one can tell me how. So... can someone tell me what my options are other than trashing my brand new Amp? It's not even 2 months old.

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

If it's only 2 months old, it should be under warranty. Have you tried to get it repaired under warranty?

Any car audio repair shop should be able to repair it.

If you want to repair it yourself, it's possible but you'd need basic test equipment and soldering/desoldering tools.

The following page shows you the basics for amp repair. Your amp is somewhat different than the one shown but the troubleshooting/repair procedure would be similar.

Basic Amp Repair Primer

Posted on May 17, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My light on my Kenwood Kac-8103D amp is constantly on red and nothing is coming out? How do I fix this


Check your fuse. Also make sure all your wiring and terminals are correct and not loose.

Dec 11, 2011 | Kenwood KAC-8103D Car Audio Amplifier

2 Answers

My kenwood KAC-7204--- the wiring is hooked up right, I just got a 2000 watt max sub 1000 watt rms, i was running the amp in bridge mode and it ran for 1 day than it turned off. I checked it and the fuse...


when i was running my sub off bridge mode this kept happening to me. I ended up just running two subs and for some reason the fuse stopped blowing. i think there is something wrong with these amps.

Jun 04, 2011 | Kenwood KAC-7204 Car Audio Amplifier

1 Answer

How should i have my 4ohm single voice coil JL audio 12in subs connected to my kenwood kac-9104d 1800 watt max power (500x1 @4) amplifier?


On the outputs of the amp there is:

+ + - -
1 2 3 4

terminals. Internally in the amp the positives (1 and 2) are connected together and negatives (3 and 4) together. So there is no difference between hooking up in any of the configurations 13, 14, 23 or 2->4. If its a matter of style, probably use the 14 set, since they're furter apart and harder to short out that way, but electrically it doesn't matter.

Feb 21, 2011 | Kenwood KAC-9104D Car Audio Amplifier

1 Answer

How well will a 1000 watt kenwood amp pump with 2 1200 watt suns


2 will push more air but be careful how they are wired so you dont go to low on the ohms your amp sees.That amp should be 2 ohm stable so read up on how to wire in series or parallel.

Sep 06, 2009 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Amp Turns off after 30 seconds of song play.


Check your ground and make sure it is grounded to metal in your car with no paint. Also, make sure you are running 4 gauge power wire. Another possible cause could be that the ohm load is too low on the amp. Also, if your car battery drops below 10v it will send the amp into protection.

Apr 15, 2009 | Kenwood KAC-8103D Car Audio Amplifier

2 Answers

Can u fix a blew amp


yeahhh but you would have to send it in and hope its under warrenty. best bet do waht all the other jackasses do. sell that **** on craigslist

Apr 08, 2009 | Kenwood KAC-8103D Car Audio Amplifier

3 Answers

Adjusting wattage on kenwood kac 9103 class D mono amp


That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.

Jan 02, 2009 | Kenwood KAC-9103D Car Audio Amplifier

1 Answer

Amp light turning off and on


if you see that happen you might need to your i c sound chip or your trasistor change then and check

Dec 11, 2008 | Kenwood KAC-8103D Car Audio Amplifier

1 Answer

Low output from amp


From a former DJ, make sure that the speaker circuit is matching the load that is required by what ever amp that you are using. If the amp is rated at 1000watts/ channel into 8 ohm's then your equivalent speaker circuit has to match. I repeat has to match! If it does not the amp will either short out or be overloaded. If you are using all 8 ohm speakers on a amp that rate its output at 1000 watt/8ohms then you you have to match the watts and the ohms. Depending on how much power your speakers take you may have to use more than one speaker to handle the power. If you have to use more than one speaker you will have to use a series/parallel circuit to keep the ohms at 8ohm. You have to use ohms law for adding resistor in series and paralell. If more is needed please reply.

Nov 20, 2008 | Kenwood KAC-8101D Car Audio Amplifier

3 Answers

Kenwood KAC-8103D 1000 watt issues


The speaker may have shorted and caused the output transistors in the amp to fail. This is fairly common. It can be repaired.

May 14, 2008 | Kenwood KAC-8103D Car Audio Amplifier

Not finding what you are looking for?
Kenwood KAC-8103D Car Audio Amplifier Logo

Related Topics:

168 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Amplifiers Experts

Matthew Spark
Matthew Spark

Level 3 Expert

1042 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Pieter Vleeshouwers

Level 3 Expert

1417 Answers

Are you a Kenwood Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...