Question about Pentair White/Gray Legend Platinum Automatic Pool Cleaner - Ll105pm

1 Answer

After two years of perfeft performance, the Legend Platinum start to misbehave. Whells runing at 23 to 25 RPM after cleaning the hose filter. Main pool filter runs at 23 psi, booster pump runs and pressur relive valve is closed comletly. The sweeper runs alot on its side and not sweeping efectivily. Any thoughts on what might be the problem? Any idea

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 640 Answers

If your RPM is low, you will need to increase pressure to the cleaner. If the sweep hose is laying on the side and not sweeping, you will need to adjust the screw that holds it on to get it to a gentle sweeping motion. It is also possible that you have too much hose weight on the pool cleaners sweep hose. Try removing some of the weight and seeing if that changes.

Posted on May 11, 2011

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Pentair legend platinum sweep hose doesn't sweep


open up the screw on the bottom that will let water to the tail

Apr 28, 2012 | Pentair White/Gray Legend Platinum...

1 Answer

My Platinum cleaner follows the same pattern all day long - one big circle. Are there any adjustments that can be made to make the pattern more random so that my whole pool would get cleaned and not just...


Check the "teeth" or gears on the inside of the 2 front wheels you'll likely find that one or both are chewed up at some point. This is the most likely cause but lack of pressure at the head can also be the problem. For that check the filter screen at the wall fitting to be sure it's clean. Also check the hose swivels for excessive leaking. (some leaking is normal)

Jul 18, 2011 | Pentair White/Gray Legend Platinum...

1 Answer

My great white pool clearner is not moving in the pool what might be the problem?


There are several thing that you can check. Be sure that both the filter pump and booster pump
are on and working properly. They might need to be cleaned. Also, check the wall fitting screen for debris and rinse clean. Test your pool cleaners wheel RPM and make sure that it is in the desirable level of 28-32. Make sure that your back-up valve is cycling. Check all the hose connections and
swivels for leaks that can cause loss of water pressure.

Nov 22, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

I just replaced the tires on my Legend Platinum because the originals were totally wore down. I unplugged the pool fitting to clean out the little filter. After I reseated the connection (nice and tight)...


You may need to replace the wall fitting and the fitting that houses the screen. If you look at the fittings and find a tab broken or the track it runs in hurt that will tell the tale. The least amount of damage will cause pressure loss and the noise you hear.

Oct 10, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

The cleaner stands on front wheels and barely moves.


With these pool cleaners, there are several things you will want to try. Check the filter screen in the in line filter and the skimmer basket, pump basket, and pool filter. Clean any if necessary. Make sure that all hoses, connections, and swivels for leaks that could cause loss of water pressure. Make sure that your wheel RPM is correct. Make sure that your thrust jets are positioned correctly and that you have proper waterflow.

Oct 01, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

I just moved into a house with a pool and i hook up the legend and it doesn't crawl


If these pool cleaners are moving, there are several suggestions in the users manual. I have attached a copy below in case you didn't get one when you took the pool over. Basically, make sure that your filter ,booster pump, and wall fitting screen are all clean and working properly, check wheel RPM and get it to 28-32 RPM, make sure that your backup valve is cycling, and check all of your hoses and connections for leaks or cracks that would allow air into the line.

http://www.poolcenter.com/Platinum_Manual.pdf

Jun 15, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

My Legend cleaner (8 yrs. old) starts off fine but after a few minutes runs very slowly. any ideas what may be causing this?


First check the metal screen inside the fitting that connects to the pool wall. Make sure it is clean. If there is no inline screen on the feed hose then the jets inside the pool cleaner could be clogging. If there is a screen that keeps getting clogged with debris(like every couple days) then there is a problem with your pool filter or multiport valve that is allowing dirt to pass into the pool cleaner and the pool. Also it could be the back-up valve hanging up(due to a bad bearing or bushing) The back-up valve is the large canister on the feed hose about 3-6 feet above the cleaner. Check for holes in the feed hose and in the cleaner tail.

May 31, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

My Pentair legend pool cleaner is not moving


On this automatic pool cleaner, this is usually an easy thing to fix. First, make sure that your filter bag is clean and free of obstructions. Next, take of your head float and shake it. If you can hear water inside, you will need to order a new head float and install it. They are usually inexpensive and easy to replace. Make sure the hose floats are evenly placed and make sure that the cleaner is not getting too much pressure from the return lines.

May 25, 2010 | Pentair White/Gray Legend Platinum...

1 Answer

Not BACKING UP


The valve is called a back up valve but that jet of water just hauls the cleaner out of corners, but the unit itself dosen't back up.

Oct 14, 2009 | Pentair White/Gray Legend Platinum...

1 Answer

Legend 2 pool cleaner auto back-up feature stopped working


Make sure you have a clean filter and clean wall fitting screen. Pull hose out of water and lay it so you can watch the back-up mode go through its mode. The housing might be crack and have a leak which might not give the valve enough power.

Sep 05, 2009 | Pentair White/Gray Legend Platinum...

Not finding what you are looking for?
Pentair White/Gray Legend Platinum Automatic Pool Cleaner - Ll105pm Logo

240 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pentair Pool & Spa Experts

Pj Kiley
Pj Kiley

Level 1 Expert

21 Answers

Jay Finke
Jay Finke

Level 3 Expert

1339 Answers

Bill Jordan

Level 2 Expert

372 Answers

Are you a Pentair Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...