Question about Hoover F5826-900 SteamVac Upright Wet Washer

1 Answer

Will not turn on

Unit was working fine, changed water and went to turn back on and it will not start back up

Posted by on

  • tanyapatters Aug 09, 2008

    I have the same steam vac and the same problem. It started making a loud noise and had a burning smell so I turned it off and now it won't turn back on. It sounds like it must be the motor to me.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

I assume you tried a different outlet? Otherwise you could have a problem with the cord, switch or motor. You will just have to check it over to find out what went bad.

Posted on May 15, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

We used it then turned it off and went to turn it back on but wouldnt do anything.latches are locked and has water in it. im getting power to the switch


E series vacuums have a safety switch underneath the motor unit to insure the water basin is on. You can see the part here and where it is located (left of the separator)
Rainbow interlock plunger

Sometimes this part may have fallen out and gotten lost when you were putting your vacuum away, or your water basin where it would depress this switch broke of.

If your motor is good and power nozzle is good, it may be this.


GoodVac.com
800-775-6586

Mar 24, 2014 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

Unit not working to heat water--cant hear compressor starting up like normal


Did you make sure that it was closed all the way? Sometimes if the water canister is not on all the way it can cause this. And depending on how old the steemer is maybe that part went out. But I would check all the lines to make sure nothing is clogged or pinched

Jun 07, 2012 | Vapor Professionals TR6 Canister Steam...

3 Answers

Vacuum working perfectly and everything stopped. Went to the utility room and found a plastic bag on top of the equipment. Tried the reset button, etc. nothing works.


sounds like a bad relay in the tank just a simple repair but should be done by a vacuum tech or electrician. Could be a motor is nothing is starting at all, but not as likely.

Jun 14, 2009 | Broan-NuTone CV353 Central Vacuum

1 Answer

Hoover SteamVac Dual V Carpet Cleaner just hums when I turn it on


if the motor doesn't run sounds like you either have a bad motor or your motor armature might have gotten wet and created a dead spot.if you have any contact cleaner spray a little on the armature then turn the motor by hand make sure its uuplugged first if you can turn the motor then plug it in and try to start it

Apr 04, 2009 | Vacuums

1 Answer

NO POWER WHEN I PLUG UP THE VACCUM


I had the same problem when I first bought mine. I let it set for a while and did some online research. I can't remember the site I went to, but it said that this sweeper will shut off when overheated to protect it and will start back up later. I went back and turned mine back on and it was fine.

Jul 27, 2008 | Hoover U5507900 Elite Rewind Bagless...

2 Answers

My Electrolux upright worked fine


Are you using the proper bag? There's a kill/reset switch that needs to be pushed down by the rim of the bag before the unit will run.

Jun 22, 2008 | Electrolux Epic 6500 Vacuum

1 Answer

Handle unit came off


http://geeksquad.fixya.com/ThreadView.aspx?prdid=49977&thid=623558
Handle unit came off
Posted by Mcnarymoss on May 26, 2008
Hi. My unit was working fine. Then my wife started using it. She was going back and forth using the Power Drive feature. Now, the entire handle slips off, and the unit is not working correctly at all. Any ideas

Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. The Bissell 1698 Power Steamer ProHeat Upright has a – let’s call it a power drive rod that has come apart and is no longer working and needs to be re-connected. The best results of the power steamer is that the power steamer works better on the pull back, which means that you dispense the water, the brushes scrub the carpet and the vacuum picks up the water and it goes into the recovery tank – if you go forward use the trigger assm to dispense the water so I t get a chance to soak in but the best results are on the pull back. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.bissell.com/ Customer Service 1-800-237-7691
Hours of Operation Monday thru Friday 8:00 am to 10:00 pm EST
Saturday 9:00 am to 8:00 pm EST
Mail To: Headquarters, Bissell Homecare Inc
P.O. Box 3606 Grand Rapids. MI 49501
http://www.a-1vacuum.com/ 1-800-657-1874 Customer Service
Thanks, Don the Vac Man


May 26, 2008 | Bissell 1698 PowerSteamer ProHeat Upright...

2 Answers

Sprays soap, but not water


My Bissell is quite fussy. Sometimes I have to wiggle and push down the tank before the water will start to flow. The water doesn't flow properly if the soap container is low - I fill it with water when rinsing. It has a viewport with a red cross that turns when the water flows. Sometimes just removing that and the white filter below (and putting them back) makes it go. Mine is easy to take apart - 6 screws in the base unit and the top comes off. There are two water tubes going into the handle hinge under where the water tank goes - very easily squished or damaged. Last time the water stopped flowing, I ran it with the cover off and just fiddled around with the tubes and away it went. Maybe it is spraying soap only. The water flows up through the handle to the finger valve and heater. Some people say the heater in the upright/handle gets plugged. I haven't had that apart, but it should be easy to bypass the heater.

Sep 07, 2007 | Bissell 1699 ProHeat Clear View Upright...

1 Answer

Battery light goes red after bumping/backing up


try this: turn it upside down and run it-then bump it to reverse it...same result?

May 29, 2007 | iRobot Roomba 4210 Bagless Robotic Vacuum

Not finding what you are looking for?
Hoover F5826-900 SteamVac Upright Wet Washer Logo

Related Topics:

53 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18381 Answers

Roger Potts

Level 3 Expert

694 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...