Question about Car Audio & Video

1 Answer

The red triangular light on my 1800 watt kenwood amp is flashing and i do not know what to do to fix it. no sound is coming out of my subs

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Expert
  • 324 Answers

I have a smaller kenwood amp but it has the same triangle, i had that problem too, so i ran a ground wire from the battery to the amp, with 12 ga wire, and then i also grounded it with the chassis ground, on the big amps its better to have really good grounds and connections

Posted on Sep 12, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a 1800 watt kenwood amplifier an the red light on it blinks when i turn my volume up but i have no sound coming out of my subs an it did this while driving today an all the wiring is fine so idk...


sounds like wiring. could be two much sub for the amp. your sub max power should be less than amp max. from your description its trying to go into protect mode. trace wires, cheking for breaks , loose connections and such. also make sure your fuses are in all the way.

Jan 13, 2011 | Car Audio & Video

1 Answer

Hey i just bought a new pioneer subs 2coils and a kenwood class d 1800 watt how can i connect them to get the clearest sound ?


That amp can run at 1 ohm so if your subs are dual 4ohm then run in parellel. All positives will be conected together and the negetives and then run to the amp.
2_4ohm_dvc_1ohm.gif

-please give pos feedback david

Nov 09, 2010 | Pioneer Car Audio & Video

1 Answer

I have a 1800 watt amp but the red light is on but it dose sound like the bass works but not it its prime


the red light is for power in protect mode it should be orange and it will not emmit sound if you think you should have better sounding bass or more bass you can try to play with the gains on the amp or possibly if you have the negative or positive hooked up wrong from a speaker to the amp this will cause the bass to be lower and somewhat distorted double check your positive and negative wires from the speaker to the amp and make sure they are correct

Feb 28, 2010 | Kenwood KAC-9152D Car Audio Amplifier

2 Answers

My subs/amp are not working


when you car is running, it charges the battery somewhat. So the voltage problem is not a problem. The red light means the amp is going into ''Protect Mode". This usually happens when something is wrong with the amp. Usually the amp is getting hot. Check all of you connectiong and check the final impedance of the subs. Make sure the amp can handle the impedance of the subs. If you need anymore help, message me.

Feb 12, 2010 | Kenwood Excelon KAC-X621 Car Audio...

1 Answer

I NEED TO KNOW HOW TO WIRE THREE 3012 THWELVES TO A 1800 WATT KENWOOD AMP


Its hard to tell what you can or cant do without knowing exactly which kenwood amp you are using. Generally speaking though most kenwood amps are stable only down to 2 ohms. you will be better off just using 2 of your 12s wired in parallel- that will give you a 2 ohm load. There is a way to use all 3 simply by wiring them in series, it will end up giving you a 12 ohm load on the amp though which will work fine but you wont ever achieve the full power that the amp can do.

Jan 17, 2010 | Kenwood Kfc-w3012 12" 2400 Watt Car Subs...

1 Answer

Repeated blown subs


Unfortunately some of these speakers today... DO NOT PERFORM up to peak as they should.The on logical reason for this to be happening it that the speakers are NOT very DURABLE and cannot take constant playing. I would recommend to L7 the can take alot more abuse than your average speakers. Good luck and thanks for using FIX YA

Mar 23, 2009 | Kenwood KAC-X401M Car Audio Amplifier

3 Answers

Adjusting wattage on kenwood kac 9103 class D mono amp


That amplifier is 900W x 1 @ 2ohms.
If your subs are 4ohm SVC wired Parallel, resulting in a 2 ohm load, each sub will only see 1/2 of the rated power. (450W ea.)
Your gain (sensitivity) setting should be between 75% and 85% to max. You will be fine.

Jan 02, 2009 | Kenwood KAC-9103D Car Audio Amplifier

1 Answer

Kenwood KAC-8401 light goes from blue to red when turned on


Either the amp is ad or the sub got shorted? You can check itby disconnecting the Sub and seeing if the amp comes on blue then. If yes, then the sub is shorted. If no, then the amp is shorted. Also chck the voltage AT THE AMP. Make sure that it is above 12 Volts.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Dec 29, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

I need help


Most of the time if the red light is on the amp is no blown but some times it does this cause the subs are hooked up in the wrong way. If the amp is only 2ohm stable and you hook the subs up to it at 1 ohm than the amp will not work so I would check this frist.

Oct 17, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

2006 12" Kicker L7 4 ohm


first whats the range in terms of WATTS that your 12" sub can handle in 4 OHMS ? second , lets check the AMP , POWER ACOUSTIK 1800 WATTS , Now thats a lot of power to drive a single 12" sub speaker . your amp is 1800 watts , per channel is around 500 watts , if BRIDGE thats around 1600 watts rms for ONE channel , if your sub can handle that kind of wattage fine , but it will not blow the amp , what it does is shuts down , some kind of protection mode , it will come back on after a minute or so. I suggest to use one channel in stereo mode , or purchase another sub to use the other channel. i hope this helps AJ

May 06, 2008 | Kicker 06ZX750.1 Car Audio Amplifier

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

176 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4869 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

yadayada
yadayada

Level 3 Expert

76691 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...