Question about Rockford Fosgate Punch 700S Car Audio Amplifier

1 Answer

I hooked up my amp it seemes to have power but no music comes out of the subs the remote wire comes on and i have it grounded correctly can you help.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 62 Answers

Check your rca connections or the head unit to make sure the sub switch is on

Posted on Sep 13, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why doesn't my Receiver tell my amp to turn on


Ok get a test light and test the remote on the amp and on the back of the radio if it is good in both places then check power and ground

Apr 24, 2014 | Kenwood Remanufactured KDC-HD548U CD...

1 Answer

I just bought a hifonics amp the brz2100.1D and when i tryed to hook it up every thing is correct as far as the wireing compared to the manual and the blue lights come on power light is on but its not...


MAKE SURE YOUR GROUND WIRE IS GROUNDED GOOD,,AND IT IS IMPORTENT TO HAVE YOUR REMOTE WIRE HOOKED UP. IT WILL BE A BLUE WIRE,,FIND THE HOT WIRE FOR YOUR TAIL LIGHTS AND HOOK IT THERE THEN WHEN YOU TURN YOUR CAR ON THE AMP WILL ALSO COME ON.THAT SHOULD STOP ALL THE NOISE AND POWER YOU UP.

Jul 15, 2011 | Hifonics BRZ21001D Car Amp

2 Answers

XA10002 dual channell amp pushing a single 12 inch JL Audio sub and continues to go into protection mode. All setting are turned to the lowest possible and remote wire, power wire, and ground wire are all...


Make sure you are wiring the sub to the correct ohm's. Some amps have a protective feature that will send them into protect mode if they do not since the right ohm load. If the sub is wired correctly double check your ground wire on the amplifier, and if that if also fine then your amp will need serviced.

May 31, 2011 | xXx XA10002 Car Amp

3 Answers

I have this hooked up and works fine with the key on, but when i start the car, sub light, amp and sub dont come on.


You have connected it to the wrong power wire - one that is only active in service mode - first key position.
You should draw a wire directly from the battery (don't forget to add a 40 amps fuse on the wire) to the amps. If you don't want them constantly operational (you will have to manually shut them down) install a relay on the wire with the command coming from a wire from the instrument key position - second position of the key. Use a voltmeter to identify the wires.

Oct 15, 2010 | Rockford Fosgate Power 351M Car Audio...

1 Answer

The main problem I have having is I am getting power to my AMP but no power to the subs. I tested my AMP and subs in another car and everything worked so I know my hardware all works fine. I had someome...


okay , well you need to make sure all your conections are in the right spots, and that your IN LINE FUSE, between your amp and battery, the big glass one is not burnt, just take a look at the metal piece inside , if its a sold metal piece its good, if its burnt in half like a broken bridge it needs to be replaced. the next thing is the fuse on your amp, you need to make sure it is not burnt also. Check your remote that it is hooked up to the right wire. then check that your sub/speaker wires are connected properly and secure. YOUR GROUND WIRE IS HUGE HERE also. MAKE SURE IT IS GROUNDED TO A GOOD SPOT, YOU MAY HAVE TO MOVE IT AROUND A FEW TIMES TO FIND A GOOD GROUND!!!! if you check all of these things, it should work fine.. you can fiddle with your amp and bass settings levels. turn em up so when it works you know it, but not too much you dont wanna blow nothing :)

Mar 12, 2010 | Car Audio & Video

1 Answer

Amp has power but sub doesnt work


You say the amp has power so you mean the green l.e.d. comes on correct? If so and you don't get any juice to your sub, check your RCAs make sure they're hooked up correctly. If they are check the wires to your sub, make sure they're making good contact, if its a binding post connection to the sub it can look connected but not be i've had it happen to me before. If the l.e.d. is red, you either blew a fuse on your amp, or your sub is blown, but if you get a green l.e.d. on the amp don't worry about those. If everything checks out and you still don't get power, take your setup to a professional and have him personally look it over for you....... hope you get your bass bangin!!!

Sep 15, 2009 | Kicker KX600.1 Car Audio Amplifier

1 Answer

Basslink Powerlight comes on then fades quickly


check to make sure your remote wire is hooked up to your amp turn on that runs straight out of the stereo not your power antenna also make sur you have a clean ground(no paint or rust) and also check your connections make sure you have a strong connection to all wire hook ups.......you should check to see that your remote wire has no tears in it or small rips or cuts because that can interrupt your current to and from the amp and radio

Jun 25, 2009 | Infinity BASSLINK Car Subwoofer

1 Answer

Music not playing from subs


Do this for the sub amp...

With your multimeter set to DC volts, the black meter lead on the ground terminal of the amp (not on the point where the ground wire connected to the vehicle) and the head unit on (so the amp will have remote voltage applied), touch the red lead alternately to the B+ and remote terminals of the amp. If the voltage is below ~11 volts, you need to check the wiring feeding whichever line is too low.

Jul 03, 2008 | Kenwood KAC-9152D Car Audio Amplifier

1 Answer

Cant figure out my car audio problems!!!!!


There are a couple of tests you can perform. I'd first recommend checking the shield ground. You'll need an ohm meter. The details can be found on the following page.

RCA shield ground test

You can also test the output with the multimeter. Set the multimeter to AC volts. If it's not an auto-ranging meter, set it to a voltage range of ~2v AC. Disconnect the RCA cables from the head unit. Touch one meter probe to the outer ring of the head unit's RCA jack. Touch the other probe to the metal contact in the center of the RCA jack. With the head unit near full volume and a clean signal source, you should read at least one volt on musical peaks. If you have a bass disc or a test tone disc (~60hz sine wave), use those.

May 04, 2008 | MTX Thunder 8302 Car Audio Amplifier

2 Answers

AMPLIFIER PROBS


check all power coming to your amp remote especially

Jan 21, 2007 | Fusion FEW12PK Car Subwoofer

Not finding what you are looking for?
Rockford Fosgate Punch 700S Car Audio Amplifier Logo

Related Topics:

61 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

seankane89

Level 1 Expert

25 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...