Question about Magellan GPS

Open Question

Magellan 5000d i have not used in several years just put new batteries in and it went into sky search ok than after it found 3 sats ot said in 2d but every time i push pos it just goes back to the ready mode and says push pos i cant get it to give me a latitude etc help?

Posted by on

5 Suggested Answers

  • 1 Answer

SOURCE: Magellan GPS 310

to reset the unit hold down the right arrow while turning it on this fixed mine!

Posted on Aug 21, 2006

  • 13 Answers

SOURCE: "NO POS"

Have you gone through the "Initialize" process again? If the memory has been cleared you will need to re-initialize. Refer to page 4 of your manual. Power On > Select Language > "ENTER" > INITIALIZE screen > "ENTER" > Select Region > "ENTER" > Select Area > "ENTER" > Enter Elevation > "ENTER" (if you don't know elevation, press enter) > Enter Time > "ENTER" > Enter Date > "ENTER"

Posted on Jul 08, 2007

marketex
  • 371 Answers

SOURCE: Magellan Roadmate 1212 won't stay on when unplugged

Man, I DO commiserate with you on that one, but did you specify to them that the battery should be checked?
as that is probably your problem, now that I know the unit has been checked and the worst possible outcome
from your buying an extra battery is that you will HAVE AN EXTRA BATTERY for those times when you need
total portability.

So, make sure you try a brand new battery and if that solves your problem, then buy several.

Posted on Apr 17, 2009

toms920
  • 1 Answer

SOURCE: Magellan Maestro 4250 freezing up

I just purchased a referb from TigerDirect and the only issue I discovered was a lockup when the unit goes to sleep. Try holding down the power button for 15 seconds then release it to cycle the unit. Then hold the power button down again for 5 second to start it back up. I had to do this for my bluetooth to work and not freeze up. Now I just turn it on and off manually and avoid having it go to sleep. I also downloaded the firmware update to 4.86, you can download it from Magellan's website. My unit works great so if that doesn't work contact Magellan and I'm sure they will have a solution.

Posted on May 29, 2009

  • 1 Answer

SOURCE: magellan explorist 400 gps won't power up with usb cable

fhfj

Posted on Jan 31, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Magellan Roadmate 2000.. No GPS signals


make sure the battery is charged up good, then take it outside and turn it on and leave it in clear view of the open sky for up to 30 minutes to acquire the satellites especially if its been reset.

if that fails, reset the unit...turn it on, then locate the reset button on the left side bottom of the gps and use a paper clip to depress the reset switch...it should restart on its own..take it back outside and let it in clear view of the open sky for up to 30 minutes.

if that fails..go HERE and get the update and follow the instructions..you will have to sign on to the Magellan site before you can download anything.

if you need more help, just post back


bill

Jul 16, 2010 | Magellan RoadMate 2000 GPS Receiver

1 Answer

Self tests show ok, reset ok, satellite just says searching


make sure the battery is charged up good, then take it outside and turn it on and leave it in clear view of the open sky for up to 30 minutes to acquire the satellites especially if its been reset.

if that fails, reset the unit...turn it on, then slide the reset switch on the top of your 800 to the opposite position and once it turns off, slide the reset back to the normal position and turn it on again and take it back outside and let it in clear view of the open sky for up to 30 minutes.

if that fails..go HERE and get the update for which ever 800 model you have...you will have to sign on to the Magellan site before you can download anything.

if you need more help, just post back


bill

Jul 04, 2010 | Magellan RoadMate 800 GPS Receiver

1 Answer

I have a craftsman Lt 1000, 17.5 hp tractor. It


Check for cracked fuel lines, plugged fuel filter, if all ok, then check fuel pump.

Mar 14, 2010 | Craftsman 24 Hp 48" Deck Yard Tractor

1 Answer

Magellan roadmate 1430 no sat signal


replace the or recharge the battery to capacity and see if that helps usually low battery, incorrecty baud rate or port out cause no satellite connection, unless you are under a thick concrete or tin roof. take it outside and show it some sky and see if that help

Jul 23, 2009 | GPS

1 Answer

Problem locking on to sat and loosing sat once locked on


position and battery.. make sure its fully charged. keep it away from other radio signals and ensure it has a clear view of the sky.

Please rate my help++++Thanks for using FIXYA

Jul 04, 2009 | Magellan Roadmate 760 GPS Receiver

1 Answer

Magellan wont get signal?


charge the battery fully, then set it outside in clear view of the open sky. it may take as much as 30 minutes to acquire the sats if that fails, try and leave it out longer...does it appear to try and link to ANY sats. on the map screen in the top righ t corner is a icon with bars in it, tap that and you should see it trying to acquire sats. if not, you might have other problems

Jun 02, 2009 | Magellan Maestro 4040 GPS Receiver

1 Answer

Ford Escape Hybrid goes dead if not driven for 3 days straight


I have the same problem with my 2007 Escape Hybrid... First experienced it about 1 year ago. The vehicle produces periodic sounds like an electric motor running for several seconds. I believe this is from the motor driven safety relay that disconnects and reconnects the high voltage hybrid battery when the vehicle is not in use. I also can hear a high frequency scream that sounds like a switching inverter power supply. If the vehicle is unused for a day or two the 12V battery is discharged and a jump is needed to start the engine. Ford service could not diagnose the problem. The +12V battery tested OK, but since it was almost 3 years old it was replaced anyway. This helped for a while, but the problem returned after I recently left the vehicle unused for several days. I know the battery is good, it tests OK and is less than one year old! Somewhat reluctant to go back to the same Ford service agency because of their previous failure to fix it. Please advise if you have found a solution or have additional information. This is the only problem I have ever had with the hybrid Escape, but it is very annoying. I am forced to carry a jumper battery to make sure I don't get stranded.

Dec 30, 2008 | 2005 Ford Escape

1 Answer

The unit is a Magellan Nav 5000. We understand they are no longer being serviced and we are not looking for repair work rather hopefully some simple explanation to our problem. We are currently in Adak...


Sorry to say have had the problem from November 2007 again with this unit and despite ontact with Mgellan, they were as helpful as ice on a skillet. I have two units,like you, one new and boxed bt stil no acquisition from either,,,,

May 31, 2008 | Magellan GPS

1 Answer

I have a model c-700 camera that will not power on. The camera sat in a drawer for several years and the batteries went dead. Installed new lithium batteries and will not power on.


clean the battery terminal/connector inside the camera's battery compartment using a cotton buds with alcohol or metal cleaner

May 05, 2008 | Cameras

Not finding what you are looking for?
GPS Logo

Related Topics:

95 people viewed this question

Ask a Question

Usually answered in minutes!

Top Magellan GPS Experts

Jungle Ghost
Jungle Ghost

Level 2 Expert

154 Answers

yadayada
yadayada

Level 3 Expert

71043 Answers

The Knight
The Knight

Level 3 Expert

73056 Answers

Are you a Magellan GPS Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...