Question about Vacuums

Open Question

The RO system is moaning where the three filters attach to the main body of the unit. Any ideas what this noise could be and how do I fix it? It wakes me up in the night. Thanks.

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Weird noise when running - belt?


Hi there,


We are sorry to hear you are having difficulty with your DC16. Based on the description you provided, your machine may have a blockage or your filters may need to be cleaned. Washing the pre-motor and post-motor filters for your DC16 Handheld every 3 to 6 months is an important step toward ensuring that your machine continues to function properly.


To locate the pre-motor filter:


Remove the machine from the charger



Remove the clear bin and cyclone assembly by pressing the button on the top of cyclone assembly then separate the cyclone from the main body of the machine



The post-motor filter is located underneath the vents on top of the main body assembly just above the handle. Lift up on the small lip at the edge of these vents.



Wash both filters, including the white and blue plastic scrim, in cold water (no soap)

Leave the filters to dry at room temperature for 24 hours or more


When placing the filters back into your machine locate the small plastic "pin" that sticks out just beneath the black motor cover in the main body of the machine.


Be sure to position the pin in the small hole on the blue plastic portion of the scrim and the blue sponge will face away from the motor cover.



If following the steps above does not resolve the problem, please contact us directly, 1-866-693-9766 (US) or 0800 298 0298 (UK), so we can provide further assistance.



Best wishes,



Jessica

Aug 06, 2012 | Dyson DC16 Root 6 Bagless Handheld...

1 Answer

There is a break in the cord where the clamp is entering the unit of our Majestic IAQS system Filterqueen Lux have tried to get into it but cant seem to get it open! Any ideas?? This unit is approximately...


undo the side clamps so that you can get to the dirt below.
Grab the handle and remove the top portion of the canister.
Take the top portion and to go the table.
Remove all the attachments (if they are even attached).
twist and remove the cap under the handle at the top.
remove the three screws under the cap at the top of the machine.
when the screws are out, pull up on the handle and the chrome top should come off from the plastic cone underneath. all of your wires and switch are under the chrome dome there.

cut your cord about 1 inch from the machine, and re-insert it into the machine making sure you do it safely. Wire connectors and NO TAPE.

Good luck.

Nov 18, 2010 | Filter Queen Majestic Canister Vacuum

1 Answer

The unit comes on and the exhaust blows out however no suction at all. l placed a wet vac on the unit where the bag goes and all of the outlets pull some air. The unit is the cv350. Thanks.


there would be 2 things potentially wrong here...

1) the black rubber gasket is missing off the body where the pail goes onto the machine. If that is missing there will be no suction.

2) This is a little more complex but will also lead to the same problem. up above where the bag goes there, is a filter. It could be clogged, but if you are getting a lot of air blowing out of the unit, I think it is more the rubber gasket between the motor and the body. You can check for this by looking behind the little motor pre-filter there (if it is even there) and check the motor intake for the unit. It is probably blocked or partially blocked with the motor gasket. To fix this you will need some weather stripping or another motor gasket.

Good luck.
Mark

Nov 08, 2010 | Broan-NuTone CV350 Performance Bagged...

1 Answer

Please advise the type of bags used for the Shark Euro-ProX vacuum cleaner as it does not say anywhere on the unit. Kindly advise. Email diannes@live.ca. Thank you.


That is a bagless vacuum. It does not require any bags, but you do have to clean the filters every so often. There are three filters in the top canister, and one in the base by the motor. Press the black button on the front of the canister and pull out to release it. Pressing the lever on the back will release the bottom black piece, emptying the contents. Do this over the garbage, or outside. It can be messy. Twist the top gray piece (the part with the first button and handle) counter-clockwise to open the filter area. This will reveal a black lid. Remove it, and the three filters underneath. One is a round black and gray conventional style filter, one is a foam disk, and one is a screen area on a tube. Shake them out (outside), tapping them on something hard like a railing or the ground, and rinse them under running water. Shake the water out of them, and reinstall them.
The last filter is behind the gray slotted panel in the bottom of the main body. Press the tabs on either side and pull the panel outwards. Shake this filter outside, but don't wash it. This is the intake filter. If you get it wet, water may get on the electric motor. Keep it dry.

Hope this helps!

Nov 20, 2009 | Euro-Pro UV209 Upright Vacuum

1 Answer

My dyson is not picking up like it should and I have cleaned everything - about a year ago this happen and went to a site that told me how to tear down the unit - not i can not find it - help


Again take off the beater bar sole plate and check for blockages, where it connects to the small hose, change filter, is the bucket aligned to the main body?
on the bucket they should be a black rubber seal on the hole where it connects the main body

Sep 10, 2009 | Dyson DCO3 Absolute Bagless Upright...

1 Answer

Very loud "spitting" sound


After reading some other entries about similar problems, I turned to the bottom of the vacuum and where the hose starts, just behind the roller. What I found was a large Lego wedged in the opening. Removed it and we're as good as new. I actually wonder how it got in there because it was a B***H to get out. I thought I was going to break the plastic molding around the rollers, but I finally got it loose after about 20 minutes of fiddling with it. Kids!!

Jun 23, 2009 | Kenmore Progressive Bagless Upright with...

1 Answer

Central Vac will not turn on.


These problems are nearly exclusively caused by a bad circut board and replacing it is the fix. Bad boards can cause many different effects so its nearly impossible to be sure. The 9v signal wire is not enough to short out an entire unit so it is unlikely the hose. If it is a direct connect system and you are pulling power from the 110 somehow that would cause main unit problems but that is unlikely at best. Sounds like a failed board to me.

Best of Luck

Jun 04, 2009 | Easy Flo EF1400 Central System Vacuum

1 Answer

My EL7020 so call Electrolux!


Check the electrical connections between the hose and the body of the machine, and also the wand connections all the way to the power head. Sometimes a faulty connection can send a false "off" signal back to the main body of the machine, and turn it off; but usually it will restart if that's the case. It sounds like you have a clog somewhere which is tripping your motor's thermal cutout, but you did say there are no clogs... so if you have full suction all the way down to the powerhead that's not the issue. You could have a faulty thermal switch, but I think the likely cause is, as usual; the sumo board.

Good luck. Sorry I didn't have a more concise answer for you.


-R

Dec 06, 2008 | Electrolux EL7020A Oxygen 3 Ultra Canister...

1 Answer

Lost the plug from the main body to the hose


You can call the 800-344-1840 and say you need a replacement part and ask for the nearest Authorized Service Center.

FQ Master
888-637-4692 in Iowa
Your Authorized Filter Queen Service & Supplies

Nov 22, 2008 | Filter Queen Cheetah II Ash - MU305...

1 Answer

Hoover SteamVac Model F5887-920 - hand attachment won't spray


I have a model I got in 2001. I found that the water sprayer on the hand tool is driven by a little turbine that relies on suction from the main vacuum motor. I eventually found that the spindle inside the turbine had separated and hence the hand-tool wouldn't spray. I glued it together but that only fixed the problem until it broke again. I am going to buy another (about $23).

Jul 29, 2008 | Hoover SteamVac Carpet/Upholstery Deep...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

34 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18392 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...