Question about Dyson DC07 Animal Bagless Upright Cyclonic Vacuum

1 Answer

We are having suction problems. ran over a chord and there is now no suction when we turn it on. last time we brought it in, they said something about a gasket??

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 944 Answers

Hi,

There could be various reasons why this could happen.
I will tell you the reason's that could cause this problem and its solution.

1) Internal hose has twisted small corrugated tube
Twist this a quarter turn clockwise and then try the machine again. You may find that this hose twisted pulling the cleaner head up very slightly preventing it from contacting with your surfaces correctly.

2)Roller brush-Roller brush not working or not rotating at proper speed.Your roller brush must have been worn out or damaged or clogged with dust clean or replace it accordingly

3)Bottom plate (sole plate) is installed wrong.If there is gap then the sucking will not take place properly.

4) cyclone component, needs to be cleaned properly.Run lukewarm water over the entire grid of small filtering holes.
5)Inspection ports at the back (U) shaped create blockages.

Note:Blockages mainly cause this problem.

This is the manual helps in a pictographic way about how to clean it.Page no 4 explains more clearly where to look for blockages.

Click here to download the manual.


Gasket has no issue with this..
Thank you for using fixya.

Posted on Sep 11, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a eureka 4D boss vacuum that won't go into barefloor mode and has no suction in carpet mode


turn the beater head over and see if something is stuck ours was totally plugged with stuff till I cleaned it last week for wife .

Dec 24, 2015 | Eureka Vacuums

2 Answers

Vacuum not clogged but has low suction


Check all the pipes, there could be something stuck in them which hasn't come out.
Also check the base of the vacuum if there is something stuck in the base.
Lastly check if there are any leaks in the pipes.
Also check the suction without using the handle, by pulling the pipe in your hand and see if it has more suction.

Apr 28, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

My simplicity 7200 does not have vacuum. Air comes out the front post filter area


If air is coming out of the filter air has to be going in through the suction hose but it may be restricted with a clog. Replace the bag and both filters. If it's been over six months since the belt has been changed start by changing the belt. Most of the vacuums brought to my store with the customer stating "it has no suction" actually have great suction but no agitation from the brush roll. If the belt is not turning the brush roll fast enough when vacuuming the carpets it will not even pickup lint and hair.

Oct 28, 2013 | Simplicity 7850 Premier Bagged Canister...

1 Answer

No suction


OK - Details details details.....

If the motor turns on and only sucks a little bit or you are experiencing a great loss of suction,.
THEN
You have a plug somewhere
Be it a partial block from say a HEPA Filter
or else it is a block in the path of travel where items get sucked up into your vacume.

If you look back to the last time someone used it, was it a fine powder which was cleaned up? then look to the filter (see owners manual for maintenance and or cleaning of the vacume machine) Otherwise is it possible that someone else used it and get it clogged with something larger? Although I'm thinking it is the HEPA filter needing cleaning...

The good news is that if the machine turns on, then you know you have a block somewhere in it, bottom line is you will need to find the clog and you'll be back up and running in no time.

Best regards
Ck

Jan 05, 2011 | Hoover Elite Rewind Bagless Upright...

1 Answer

Hi. I have a Kirby from back in the early 90s (model G3D). Never had major issues with it. Can't remember the last time I had maintenance/tune up done. It's just sounding different when I run it the last...


check the belt. this is a strong vaccume and even without the belt it will still have a decent amount of suction. If the belt is not tight or intact it can let the motor turn faster which will sound louder. other than that check all the hoses for holes and blockage, be very picky.( look deep and everyware!
good luck
~John

Oct 04, 2009 | Kirby Ultimate G Bagged Upright Vacuum

1 Answer

Seems to have proper suction but dirt is not reaching the bag? I have checked all the hoses and there is no blockage.


There may be a blockage on the inside of the vac. I have had this happen to me a couple of times. The first thing I try to do is to make sure the beater brush is turning. If it isn't turning the dirt will not go into the bag. The other thing to do is to take a shop vac or something similar with high suction and see if you can suction out your hose. There may be something so high up in it that you can't see it. The last thing I would try is to take apart the inside where the hose connects to the bag and make sure that nothing is up in there. Try the shop vac first....this has always worked for me.
Good luck.

Aug 06, 2009 | Vacuums

1 Answer

No suction when hose is removed from base


Most suction problems are caused by a clog from picking up something you probably didn't see or if you have pets an accumulation of pet hairs!

To clear it out take a metal coat hanger and unbend it til it's straight, then bend the end and tape it so when you push it through to unclog your vac it doesn't rip the hose.

Push the coat hanger in from the bottom brush area through the opening where the suction is. Also push it in and out anywhere else you can......You'll probably find something clogged....keep working it til it loosens and intermittently turn on the suction.

If you have a second vac with a hose, use that hose for suction on the clogged vac!

This should do it!
jack
aef470a.jpg

Feb 06, 2009 | Dyson DC07 Animal Bagless Upright Cyclonic...

1 Answer

Loss of suction....HELP!


TRY TAKING THE BELT AND BRUSH OUT AND SWITCH IT ON. iF THE NOISE HAS GONE YOU KNOW YOU NEED TO REPLACE THEM.

Dec 18, 2008 | Euro-Pro NV31 Infinity Vacuum

2 Answers

My Miele vacuum full bag indicator


Check the suction at the vac, without the hose, if it is strong, then you hose is clogged. If it is weak, filters could be the problem, one is the back where the bag sits, the other is on the top, you can see it when you raise the lid.

Dec 07, 2007 | Vacuums

Not finding what you are looking for?
Dyson DC07 Animal Bagless Upright Cyclonic Vacuum Logo

Related Topics:

26 people viewed this question

Ask a Question

Usually answered in minutes!

Top Dyson Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

Nick Olsen

Level 2 Expert

183 Answers

Are you a Dyson Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...