Question about Kicker 06ZX750.1 Car Audio Amplifier

1 Answer

My amp zx750.1 turn on protection all time - Kicker 06ZX750.1 Car Audio Amplifier

Posted by on

Ad

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 6 Answers

Transistors if this is not the solution then trash it

Posted on Sep 25, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get to try the service completely Free afterwhich it costs $6 per call and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Protection light came on what cut off


Amp in Protection - Troubleshooting - Basic Car Audio ...

www.bcae1.com/.../troubleshootingbasicsampinprotect.htm
Some simply shut down and the power light will not illuminate when in protect mode. If the power light blinks then goes off, the amp is either going into protect ...

How do I fix my amp it keeps going into protection mode ...

? 2:00
https://www.youtube.com/watch?v=DQ1bdsm6s2c
Apr 24, 2013 - Uploaded by Nathan West
My MTX 600xd amp light won't even come on. ... Red light comes on. ... one.. and some times it goes into protection... once I turn the car off...

Jan 11, 2016 | Car Audio & Video

1 Answer

When I turn my dvd player on, the volume will lower on its own to almost mute. It is hit or miss weather or not the unit will turn off on its own saying protect. All connections are good. Inside is clean....


When you've got good volume, try unplugging the speakers (only for a very short time) to see if that whining noise is still there or if it's stopped. We're trying to see if the whining is related to the low volume and "protect" or if it's only coincidental.

Try unplugging all the cables (except the power cord). Turn the player on & off several times & see if that whining noise acts the same. Also see if the player goes into "protect". What we're trying to do here is see if it NEVER goes into "protect" with the cables unplugged.

Last... try to get it to start & run without going into "protect", with all the cables unplugged (except power). Plug the cables in, one at a time, and see if plugging one of the cables in forces it into "protect". If so, there's something wrong with that cable or whatever's on the other end of that cable. Unplug it again & restart the player - no "protect"? Wait a little while, plug the cable in. "Protect"? Check the other end of that cable.

If it goes into "protect" with nothing plugged in except the power, then the player is probably a write-off, ready to be replaced (it's not very often that DVD players are worth repairing these days).

Nov 05, 2013 | Samsung HT-Z310T Theater System

1 Answer

What does my protection light come on after hooking everything up


There is something shorting out the amp. What you will need to do is disconect all wires and hook up one at a time. Connect ground, !2 volt and remote see if amp turns on ok. If it does try connecting each speaker seperately to see if either one sends the amp into protect mode. Then connect the rca. See what causes the amp to go into protect mode.

May 08, 2013 | Car Audio & Video

1 Answer

I have used the amp for a while running 4 speakers. the front are components, and 6x9 in the back. The amp worked great and was loud. The amp just stopped working one day when i turned it on. Turns on...


One of your speakers might have burned out, shorting the wires that connect it to the amp. Disconnect one speaker at a time from the amp, turn it on(try all four, turning the amp on and off each time you disconnect a speakers wires) and you can pinpoint which speaker might be causing the amp to go into protect mode. If you disconnect all the speakers and the amp still goes in protect mode, then the amp is shorted internally and will need to be replaced or repaired.

Sep 22, 2010 | Clarion APA450 Car Audio Amplifier

2 Answers

Amp goes to protection mode. if the fuse is too small?


Disconnect all speaker connections and rca cables. Leave power, ground and remote wires intact. Try turning on again. If you still have a protection light your amp is faulty. . Double check all connections. Good luck.
A thumbs up would be greatly appreciated if this answer is helpful to you. Worth fixing.
amp-goes-protection-mode-fuse-small-yyiigz0vif4kye35rdc5kjb1-5-0.jpg

Jul 15, 2010 | Autotek MM125.2 Car Amp

1 Answer

Red protection light stays on all time....


try disconnecting one at a time each speaker till the red turns to green. One of your speakers may be bad. Amp is just telling you that its clipping and overheating due to the change in ohms of a shorted or bad speaker. Its also possible the amp is on its last leg due to heat. Heat breaks down electronics part and eventually get worse.

Apr 05, 2010 | Car Audio & Video

1 Answer

My jvc ax6300 amp is wired in and the protection light is on. no sound from the subs?


Try to rest amp (turn off power) be sure subs are disconnected. Se if protection light comes on. If it does the amp needs to be serviced porbably a burnt component. If the protection light does not come on, connect one sub at a time to see if either one surges. Could also be that the gain is turned up too much.

Nov 06, 2009 | JVC KS-AX6300 Car Audio Amplifier

1 Answer

Sometimes my amp works sometimes it dont.


it could be your wiring or grounding to your amp, also check fuses on amp

Sep 16, 2009 | Car Audio & Video

1 Answer

Red protection light wont turn 2 green no matter what so the amp wont work


Hello mcis43fan,

The protection circuit can be activated by shorted or grounded wiring or it can be caused by a defect in the amp itself.

First, disconnect all wires except power, ground and the remote turn-on lead and see if the amp powers up normally. If it still goes into protection, the amp is defective, most likely shorted outputs and needs repair or replacement. If the amp powers up normally, test the other wiring for shorts and grounds. You can reconnect them one at a time to determine which one is causing the problem.

Hope this helps.

Aug 06, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

Fusion Amp Starts In protected Mode


check remote wire coming from back of radio

Jan 08, 2008 | Fusion FEW12PK Car Subwoofer

Not finding what you are looking for?
Kicker 06ZX750.1 Car Audio Amplifier Logo

Related Topics:

69 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kicker Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

76630 Answers

Are you a Kicker Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...