Question about Fitnex T50 Treadmill

4 Answers

THE LCD SCREEN SEEMS TO WORK FINE BUT THE TREADMILL ONLY RUNS ON SLOW SPEED EVEN IF THE LCD IS SET TO A FASTER SPEED

Posted by on

  • 1 more comment 
  • rio65 Sep 09, 2010

    Hi araracaty2
    It runs slow right from the start and then seems to slow down even more. I can not here any belt slipping and i don't think that the motor is overheating. I have let it rest overnight plugged it in set it to a high speed and press select. still runs slow. what next

  • rio65 Sep 10, 2010

    Hi I got your solution however can you be more specific. Where would i find these parts , what do they look like and how can i test
    thankyou

  • rio65 Sep 10, 2010

    Hi Tim
    Yes i have unplugged it overnight
    i don't know if this helps but the problem did happen suddenly
    one day it ran properly and the next it didnt.
    no matter what you set on the LCD which seems to work fine
    the treadmill seems to run at about 3 to 4 km/hr for a few seconds and then slows down even more
    possibly 1 to 2 km/hr
    thanks Tim

×

Ad

4 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 17,130 Answers

The LCD displays what the commands are set for by the user but the controller ( microprocessor) outputs the data to the motor drive to work faster.
So in this case it can be a failure off the motor control which is not reacting to the variable settings of the user.
Open the section, check on the drive board for errors.

Posted on Sep 11, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,777 Answers

Have you done a full reset of the device? At this point I'd imagine someone has guided you through that, but just in case, please make sure you unplug it completely from the wall, and then replug it in after a good 2 minutes of being unplugged. Please confirm for me that you've tried this and I will continue to help you out!

Thanks
Tim

Posted on Sep 10, 2010

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,768 Answers

This issue is due to a logic problem in the control panel.
The main board is malfunctioning and needs service.
The Central processor is not able to give the signal to the step motor that varies the speed set by the user.
You may need a new main board to resolve this or a current/ voltage regulator or sensor to be replaced by a qualifier technician.\
I hope this helps. Have great day.

Posted on Sep 09, 2010

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 503 Answers

Hi,

If u r seeing the increasing variation takeing effect on the panel but the speed does not increase in real, then there is nothing wrong with the push button for sure.
what it could be is ,
1. Your motor is getting overheat quickly and does not accept the higher speed commands.
2. it could be a belt slip also (do u hear any extra noise / vibration when u increase speed)
3. next time, pls unplugg the unit for atleast 4 hrs and when u start after that increse the speed very next moment and see if it works. if it does increase this way then it is time take look first on the belt and then check the motor.



Please post your feedback and Vote if the problem resolved as per your satisfaction.

Posted on Sep 08, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to an Expert (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When i start my proform 750 it doesnt slow down. It goes straight to max speed and never slows down.


try to calibrate the speed on the treadmill look in the trouble shooting section of the manual

Nov 04, 2014 | Proform 750cs Front Roller Model 299560

1 Answer

When on treadmill there is a "studder"


Check if the running belt is lubricated. You can't run an engine without oil. So, spray a good quality silicone lubricant on the base of the running belt. It is best if you spray on a lint free cloth just enough to make a wet patch. Do it outside so that no spray residue lands on the floor and becomes slippery or lands on the carpet and stains it, then return inside and lift the treadmill running belt and soak or smear the base with the wet patch of the cloth and run for a full minute. Then lift the belt again and give it another swipe on the entire base, then feel the base with your fingers or hand to see if it feels wet and smooth. Run the treadmill for another minute at slow speed, otherwise the liquid can fly and splatter on wall or floor. If it still hasn't solved the problem, then it must be the motor brushes, or it may be set to run slow and fast according to the running settings on the console. Mine does the same thing if it is programmed to do 1 minute slow and one minute a bit faster. Good luck.

Jul 30, 2014 | Proform Crosswalk 395 Treadmill

1 Answer

I set the speed at 5.5 but it wanders while I am running even with no one on the treadmill you can hear the motor slow and speed up.


Please Run the utility software calibration for easy diagnostic and fix it.
Go under the Hood cover motor, follow the steps .

God bless you

Oct 09, 2013 | Epic View 550 Treadmill

1 Answer

When I turn on the machine it speeds up to max speed while I am on it


Run the software calibration for diagnose, repair and troubleshooting.

God bless you

Jul 02, 2012 | Evolve Horizon SG Compact Treadmill

1 Answer

The treadmill speed is faster than reallife speed. I can easily run 7 minute miles on the roads (not racing, just running) and my wife is an eight minute metronome. But on the treadmill if I set it below...


the speed of treadmills are based on the companies regulations and are machine made. so they might not be 100% accurate. a treadmill is a simulated devise so it is never the same. var fctb_tool=null; function FCTB_Init_c8c9213424bf492d84f2bfaa8e62c574(t) { fctb_tool=t; start(fctb_tool); } FCTB_Init_c8c9213424bf492d84f2bfaa8e62c574(document['FCTB_Init_c3525ba5f17e4280b024b96d82d11976']); delete document['FCTB_Init_c3525ba5f17e4280b024b96d82d11976'] var fctb_tool=null; function FCTB_Init_6836227ebca14782a6c9f0284529fff9(t) { fctb_tool=t; start(fctb_tool); } FCTB_Init_6836227ebca14782a6c9f0284529fff9(document['FCTB_Init_f3124b0bb88c423dafd62627ed1118bc']); delete document['FCTB_Init_f3124b0bb88c423dafd62627ed1118bc']

May 05, 2011 | NRS Sole S77 Treadmill

1 Answer

Speeds up and then slows down fast, fluctuates extremely


I had the same problem. Sears came out and ran a diagnostic and had no clue. I replaced the control board ($70 used $120 new) and it seems to be running fine.

Feb 10, 2011 | Startrac Fitness Products Star Trac Pro S...

1 Answer

I have a proform 740CS, it sometimes slows way down, if I step off it will sometimes speed up much faster than what it's set at, but then slows down again when I step back on. Other times, it remains...


Please LUBE very well the Walking Belt.
2) Inspect the drive belt motor, if is loose, Retight.
3) See if there loose wires for MOTOR.and retight.
4) The walking belt LIFT wiht your finger must be 2-3"
otherwise Readjust with the allen screw rear.
Blessing.
cuadra2016@yandex.com
cell+whatsAPP:+50588611441
How To Lubricate Treadmill

Nov 22, 2017 | Proform 7.0 Crosstrainer Treadmill

1 Answer

I have a model 297980 J8 proform treadmill. when I first start it up without the safety key in it, the treadmill runs at full speed for about 2 minuets. After that it slows down and stops. The speed is set...


You have to put the safety key in if you want to select speed/incline or predefined programs.
It starts and runs at full speed on that occasion because it's part of the maintenance process, that lubricates the inner rollers so that it will continue to work perfectly for as long as possible.

May 01, 2010 | Proform Exercise & Fitness

Not finding what you are looking for?
Fitnex T50 Treadmill Logo

Related Topics:

55 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fitnex Exercise & Fitness Experts

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Howard
Howard

Level 2 Expert

115 Answers

Tom Chichester

Level 3 Expert

37979 Answers

Are you a Fitnex Exercise and Fitnes Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...