Question about Ford Tractor Naa Golden Jubilee Emblem

1 Answer

Got a Ford Jubilee, that has had a lean run problem, was running ok and brushhogging the other day. It backfired pretty hard and blew black parts out of the stack, (new muffler, so doubt it was that) after that it won't run over 1200 rpm but Idles well and start up are great. Rebuilt the carb and put in new points. Messed with it a little yesterday moving the float level. Noticed that had a lot of foam in the radiator. Unit will not make power to go past idle or 1200 again. Would a head gasket disallow power or RPM? Need to get the old girl running as I need her in the field. Thanks. Jerry

Posted by on

  • 1 more comment 
  • Ben Dover Sep 09, 2010

    hi Jerry, so not to waste your time or mine, what has been suggested already...copy and paste the previous failed solutions and we will go from there.

    bill

  • Ben Dover Sep 09, 2010

    hi Jerry, so not to waste your time or mine, what has been suggested already...copy and paste the previous failed solutions and we will go from there.

    bill

  • Ben Dover Sep 09, 2010

    hi Jerry, so not to waste your time or mine, what has been suggested already...copy and paste the previous failed solutions and we will go from there.

    bill

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,111 Answers

Hi Jerry,

i tried to post a clarifacation request, but it wouldnt post, so not to waste your time or mine, what has been suggested already...copy and paste the previous failed solutions and we will go from there.

bill

Posted on Sep 09, 2010

  • Ben Dover Sep 09, 2010

    well thats fixya for ya...please forgive the multi post...it said id dint go thrugh


    bill

  • Ben Dover Sep 09, 2010

    thrugh means through....sorry can edit, just one of a thousand bugs on this site

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

O7 rhino 660 runs good,then backfires and stalls.starts every crank,but will run short time then stalls.does not backfire everytime.seems like it runs longer when it sets couple of days.


I would overhaul the carby and check for corrosion in the main jet and other circuits
if it is a 2 stroke I would check the crank shaft seals as they may be hard and leaking mixture and running lean ( backfiring)

Oct 11, 2015 | Rhino Motorcycles

2 Answers

Wont start backfires


These have a problem with developing a crack in the heavy rubber intake between the carburetor and engine. Once the crack opens up, the engines runs much too lean (sucking in extra air through crack). Not too hard to replace and part is readily available at most Polaris dealers.

Aug 19, 2014 | Polaris ATV

2 Answers

What is causing my 12hp kohler engine to backfire and quit running when given any throttle?


That sounds like either bad (old) gasoline or the carburetor needs cleaning very badly - it's running very lean.

Jul 19, 2014 | Kohler Engine 12hp Cs Command Horizontal...

1 Answer

Single cylinder yanmar diesel engine on log splitter back fires out of exhuast & blows out black smoke


Engines runs for a couple of seconds then loudly backfires with a flash of flame out of the exhaust followed by a plume of black smoke. Then runs sort of ok for a couple of seconds then repeats the backfire again AmanStino Lightning Cable Apple MFi Certified 1M Nylon Braided Charging...

Apr 21, 2012 | Cars & Trucks

1 Answer

I bought a 89 ford bronco it will back fire through the fuel injection when you give it gas but not all the time


sounds like it is running lean. Check engine light on?

You mean backfiring through the intake manifold right?

A tip in hesitation or backfire is usually a lean condition. If you have a MAF sensor, clean the inside exposed wires with carb cleaner. Do no touch.

Mar 06, 2011 | 1989 Ford Bronco

1 Answer

I have a 1978 ford inline six has a newer holley card having hard time adjusting it. Runs great at lower rpms and idel but when you drive it loses power and backfires.


As you know, you have one of two things going on. it is running too rich or too lean. Run it hard for 15 minutes pull the plugs and check for black, wet looking soot = rich. Brownish, whitish dry looking soot = lean. Be sure your vacuum advance on the carb is hooked up to the proper port. Check the full advance of the timing with a light to be sure you have proper advance during rev up. You want 22 degs. full advance. If you have a pull choke try to close the choke to see if that will level out the hi end. If that works you are running to rich. adjust as necessary to lean it out. Too big a carb can also be your problem. For the best carb to engine size double the cubic inch of you engine. If your engine is a 290 ci you max size carb should be approx 550 cfm, Now if you engine has a hi rpm cam profile you have to factor in needed cfm at hi rpm. Thats why such and engine for racing will not have good bottom end or low rpm power. Sounds like you have just the opposite going on. Which can still be caused by a over sized carb. Too much fuel not enough air or room in the engine to burn it.

Sep 04, 2010 | Ford F-150 Cars & Trucks

1 Answer

Backfiring on deceleration from exhaust pipes


May be running too lean or too rich. Check the color of your plugs, black dry and sooty means they are rich, white with blisters lean.

Apr 03, 2010 | 2005 Honda VTX 1300 R

1 Answer

Carb is acting weird cant seem to adjust


That is the choke adjustment,have you checked your timing on the motor and check and see if the vacum pod on the distributer is working. also check your vacum lines for any tears or cracks in them.

Mar 29, 2009 | 1984 Ford F 150

Not finding what you are looking for?
Ford Tractor Naa Golden Jubilee Emblem Logo

Related Topics:

318 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ford Garden Experts

Dennis Key
Dennis Key

Level 3 Expert

2475 Answers

fordexpert

Level 3 Expert

5467 Answers

yadayada
yadayada

Level 3 Expert

74896 Answers

Are you a Ford Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...