Question about Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348

1 Answer

I have a husqvarna riding mower that when i engage the blades the engine stops running

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Cheetah:

    An expert who has answered 20 or more questions within one hour.

  • Expert
  • 188 Answers

Could be something jamming a blade or belt. With the engine OFF and the key OUT make sure the blades and belts all move freely by hand. Clear out all grass and c**p from the blade and belt areas. You may have to remove the blade deck to do this - instructions are in your manual or download a manual from the Husqvarna website. Good Luck!

Posted on Sep 10, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a Husqvarna GT54LS riding mower with a B&S engine. It starts and runs well. When I engage either the mower deck or the differential lock, the engine stalls. What can be the problem?


occupant switch on seat thinks there's no operator in seat with blades engaged , so safety ckt shuts engine off


seat switches go bad sometimes

Sep 14, 2016 | Husqvarna Garden

1 Answer

My Husqvarna LGT 2554 deck hung up on high spot mowing. Turned off deck & mower pushed by hand. Engaged deck,started to mow, wound to stop. Belts fine. Pull up on knob to engage, you get nothing.


The engine runs but the blades do not engage? Make sure the wire connecting the electric clutch is still plugged in. If all is connected and the belt is really fine, there is a problem with either the electric clutch or PTO switch.

May 21, 2015 | Husqvarna Garden

1 Answer

Husqvarna pto problem(?) disengaged blades to travel, would not engage after. Battery dead when checked after shutting off engine and wouldn't restart


Hi, first charge or replace the battery if necessary then check that the mower is charging the battery. The pto is probably fine but it needs battery voltage to engage. If the mower has stopped charging the battery may have had enough voltage to hold the pto in until you disengaged it but not enough to re engage it. Regards Phil.

Sep 06, 2012 | Garden

1 Answer

My 48 inch riding mower shuts off when I try to engage the blade. It runs until I try to engage


mine has a reverse cut out when blades are running....maybe the switch is bad and thinks mower is in reverse therefore shutting down the mower when the blades are engaged....

Aug 21, 2010 | Husqvarna Lawn Tractor 48" Deck, 23 Hp,...

2 Answers

Blades will not engage on Husqvarna riding mower.


Could be a broken belt, loose belt (stretched) or something is under the mower deck jamming the blades. (stick for an example)

Apr 14, 2010 | Husqvarna Lawn Tractor 48" Deck, 23 Hp,...

1 Answer

Husqvarna Mdl YTH2448 Riding Mower - Electric PTO Not Working


It sounds like your charge system is not working. If you jump the battery the engine will run with a weak battery but the pto clutch needs a strong battery to stay engaged.Try this to test it,after you jump it leav the jumper cables hooked up and try to engage the blade clutch,if it runs it is either a battery that wont take a charge or a charge system not working. If you put a volt meter on the battery while the engine is running and the voltage is 13 volts the charge system is working and the battery is bad.

Jul 31, 2009 | Husqvarna Garden

Not finding what you are looking for?
Husqvarna Lawn Tractor 48" Deck, 23 Hp, Model# Yth2348 Logo

236 people viewed this question

Ask a Question

Usually answered in minutes!

Top Husqvarna Garden Experts

Phil Walker
Phil Walker

Level 3 Expert

605 Answers

Doctor PC
Doctor PC

Level 3 Expert

7733 Answers

Roland W VanLue
Roland W VanLue

Level 3 Expert

486 Answers

Are you a Husqvarna Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...