Question about PowerBright Power Bright 2300 Watt Power Inverter - 12V DC to 110V AC

Open Question

The poles were reversed for a split second and a spark flew and all fuses blew. I replaced all the fuses but "no power output". HELP!

Posted by on

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

Frigidaire FEF365BGWC bake element went out when pulling out I forgot to unplug from wall. Sparks flew . Now nothing is working. It's getting power from wall.


Check all of your high limit safety switches. Possibility you may have fried the transformer on the main control board

Apr 17, 2015 | Frigidaire Ovens

1 Answer

Crossed solinoid and now have no electric at all sparks flew when i crossed poles


check fuse pannel for blown fuses,make sure getting power to solenoid,if not replace solenoid u may have fried it

Apr 21, 2011 | 1998 Ford Explorer

1 Answer

I changed the battery and negative treminal for my 1995 ford escort and as soon as I hooked up the battery it blew the 100 amp main fuse under the hood. I replaced the 100 amp fuse and hooked the battery...


At a guess, I'd say that you have got the new battery in back to front. This means that you are hooking the earth wires to the Positive side of the battery.

Mar 24, 2011 | 1995 Ford Escort

2 Answers

I mixed up connections of battery pole with ammplifier pole


check the fuse protection of your amplifier then replace it if blew up..but if still blow again some parts in you amplifier was damaged...like choke filter coil in DC section of your amplifier...look for elec..tech..to repair your amplifier.

May 25, 2010 | Fusion REAM45020 Two Channel Car Amplifier

1 Answer

Amp burned out


yes you shorted the output transistors and replacing them will fix your issue. inside the amp you will find three legged transistors that mount to the amps body/heat sink. replace all of them.

good luck man.

Jan 23, 2010 | MTX Thunder 4250D Car Audio Amplifier

1 Answer

Lexus es300 1994 Dome light issue!


yes there is a blown fuse. look under the left side of dash and also check the fuses under the hood.

Jun 13, 2009 | 1998 Lexus ES 300

1 Answer

Keep blowing fuse under hood when i put power wire in to amp


disconnect the negative battery terminal, replace the fuse with all the wires hooked up to the amp and reconnect the battery terminal, that way the initial surge of power goes through the negative terminal and not your inline fuse. That should solve your problem.

Mar 29, 2009 | Pioneer GM-5200T Car Audio Amplifier

1 Answer

Pioneer m-770 will not turn on


you probably have a short in the circuit some where. you need to replace the transistor and look at all the solder joints to make sure there not damaged or cracked. i have the same amplifier and i replaced the fuse several times and it blew every time up until the last time when the 4 of the power output transistors blew. what ever you do do not try and power it on till you do all the things i told you or you will have sparks and fire. my mistake cost me my amplifier. but might help you get yours repaired

Dec 24, 2007 | Audio Players & Recorders

Not finding what you are looking for?
PowerBright Power Bright 2300 Watt Power Inverter - 12V DC to 110V AC Logo

Related Topics:

31 people viewed this question

Ask a Question

Usually answered in minutes!

Top PowerBright Electronics - Others Experts

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

75817 Answers

Brad Brown

Level 3 Expert

15557 Answers

Are you a PowerBright Electronics - Other Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...