Question about Logitech Spin 75 Computer Speakers

Open Question

Speakers are not detected

Hi recently my speakers just stopped working for no reason, i have all the drivers realtek ac97

my pc specs:
2gb ram
windows sp 3 (speakers worked after i downloaded sp3)
3.2 ghz intel pentium
a8n-sli se (asus motherboard ) (on board sound card)
2x 6600 gt nvida cards

i have tried my speakers my dads and head phones still no luck

i hope you can help

Posted by on

  • Animal253 May 13, 2008

    sorry i forgot to mention my pc does not recognise, my speakers and says i have no mixers

×

5 Suggested Answers

Open SKy
  • 604 Answers

SOURCE: No sound out of woofer

Hello sparkie102
Happy Holidays
you have to check if all the cables are well connected, and in the right inputs. 2) check your software for sound that is enable, fine.
turn up the sub volume , if got it independent.
other that this, is a failure sub. if got warranty, use it! or RMS your sub.

Posted on Dec 28, 2007

fixyathing
  • 341 Answers

SOURCE: R-20 Sub stopped working.

might be a loose connection in the jack terminal. Sometimes pulling it in and out several times might free dirt or oxidation in the metal contacts. A contact cleaner is handy with this. Check also the wires for continuity. hope this helps..

Posted on Sep 08, 2008

danielizapat
  • 87 Answers

SOURCE: Logitech X-540 limited sound

why dont you have them all hooked up? I have the same speakers but I the model that only has 2 speakers. Try pluging your audio cable in the front where you would plug head phones in. Assuming that this is a desktop.

Posted on Jul 24, 2009

  • 4 Answers

SOURCE: Z5500 : No Vocals Coming in 5.1 Movies

The same thing happened to me and i just had to reset the system by turning it off and then holding input+settings for like 5 seconds until it shows what firmware version you've got it meqans it's reseted and that should solve your problem.

Posted on Aug 13, 2009

  • 19 Answers

SOURCE: No sound from X-540 speakers

are you getting power out of the speakers? tried them elsewhere? maybe the port burned out on the board and an audio card maybe needed. try an audio card and see if that works and return to best buy (if you have one near you) if thats not the problem. you can try to reset your motherboard to default values? if the computer shows your drivers working properly then maybe its the speakers. ive seen tht happen to good speakers. its a bummer deal!

Posted on Apr 27, 2010

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

3 Answers

I need sound software for my computer


if your computer came with a motherboard disk the sound drivers could be on it
control panel sounds and audio,volume,advanced,speakers select appropriate speakers or
audio you will find 3 drop down lists make the necessary adjustments there or
control panel,administrive tools,computer management,device manager,sound video and game controllers could be a yellow question mark? right click to re-install drivers

Dec 14, 2010 | Mercury P4VM800M7 Motherboard

1 Answer

I have no sound coming from my pc speakers


First of check you havent mutted anything in the sound icon in the control panel.

If not then its most likely your sound card itself is the problem, if the sound card is built onto the motherboard disable it in the bios, if it is a seperate expansion card then check its in the slot properly, in both cases it would probably be wise to invest in a new one.

Jan 20, 2010 | Biostar M7NCG-400 nForce2 Chipset ATA133...

1 Answer

No sound in Windows 7


Hi,

Uninstall all the audio drivers and restart the computer. Make sure the audio jack is in the Green audio port.

Let the operating system re-detect the audio and install the drivers for it itself. When its done see if you have any sound.

Post back if this does not work.



Good luck.

Nov 17, 2009 | Microsoft Computers & Internet

1 Answer

PC Speakers sound like chipmunks. Have webcam and also microphone connected. Sound card is Realtek AC97 audio and running windows xp.


try disconnecting the speakers and the other stuff like mic camera and only plug the speakers in if it doesn't work get new speakers

Oct 03, 2009 | Acer Aspire T135 PC Desktop

3 Answers

No audio on pc problem


Check the Sound and Audio settings to make sure that the proper output device has been selected. Go to your Control Panel then Sound and Audio Devices, then the Audio tab. In that tab make sure that Default Sound Playback is set your sound card.

Sep 25, 2009 | Computers & Internet

1 Answer

Cannot figure out how to hook up speakers external on my hp pc de


please check if you have drivers installed for your sound device and if your sound device is working fine. please try following steps, go to start--run--type devmgmt.msc--device manager window will open-- check if u see any yellow mark in front of sound devices

even if you dont see any yellow mark. please go on drivers and download page on hp website. please put your model number in there. If you need any help please let me know i can send you the link for this. download sound device drivers. most of the time HP use realtek ac97 or realtek high defination drivers. it could be different one too. if you are unable to get it from HP website you can download it from realtek.com too
last step : if other steps does't work :
go to start--run--type services.msc ---go to window audio -- if service is stopped for some reason please start it manually by pressing start

Good luck !!

Feb 22, 2009 | Compaq Presario 5000 PC Desktop

1 Answer

No Sound


try downloading realtek ac97


Jan 08, 2009 | Yamaha YST-MS201 Computer Speakers

1 Answer

REALTEK REMOVED MY WINDOWS SOUNDS!!


Solution:

best sol: go to start button ----->click RUN----->Type devmgmt.msc in Text Box -----> 

              Device Manager windows appears , click on Sound, video and game controllers(+), 
              if you see "Realtek AC97 drivers"(if they are visible...) then we can make sure that sound                     drivers are loaded in ur system, otherwise you have load it again.....


                                                          or

i) my best advice would be, dont mess up with installing, reinstalling, uninstalling sound drivers rather try   to format or reload your OS again(Windows XP) and then install drivers.

ii)  try to check volume on your speakers, volume in windows or system , volume in media players sometimes they may set to mute of no volume.......

iii) try to check all sound physcial connection that run from your computer to speakers, including power connections, cable connection ....or just remove and replace them(reseating...)

iv) try connecting a headset to your sound port, sometimes your subwoofers or speakers may fail.....



Thanking You

M. Sridhar

Dec 27, 2008 | Digital Audio OMX-LE (OP428LE) PC Desktop

1 Answer

No Sound on Gigabyte K8N Pro-SLI


Might be that the chip is bad, make sure that nothing is muted in your volume control also check that digital doesnt have a check on it. some times when digital has a check it wont let you hear anything.

Oct 19, 2008 | Gigabyte GA-K8N Pro-SLI Motherboard

Not finding what you are looking for?
Logitech Spin 75 Computer Speakers Logo

Related Topics:

438 people viewed this question

Ask a Question

Usually answered in minutes!

Top Logitech Audio Players & Recorders Experts

kakima

Level 3 Expert

101642 Answers

sonic boom...
sonic boom...

Level 3 Expert

1557 Answers

Paul

Level 2 Expert

223 Answers

Are you a Logitech Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...