Question about Electrolux Epic 6500 Vacuum

1 Answer

My vacuum is not working after cleaning a lot of dust. It starts w/o the hose but when i plug the hose it turns off on its own

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Electrolux Master
  • 43,501 Answers

Hi,

Take something and run it through the hose...your hose is clogged up...and yeah it has to be bigger then a wire... a wire will often push right through a clogg of dust...


Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...

Bissell Bagless Upright Vacuum not working

heatman101


Posted on Sep 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The vacuum has a lack of suction compared to when we bought it 6 months ago


Clean all filters and if there is a hose it could be partially plugged as well. Take hose off and shove something like a dry water hose through it.There is usually a filter back of the dirt bag as well. If it has been used to vac up drywall dust the dust bag will plug up before its filled as the dust is so fine it will plug up every thing on the vac. Really clean every thing and it will work better.

Apr 12, 2015 | Vacuums

1 Answer

Riccar 8995 no suction


If it's been over a year since you've replaced the belt that is the first place to start. Stretch belts lose elasticity and will still turn the brush roll but when the brush roll is lowered to the carpet it may not turn fast enough to pick up properly. If you have good suction at the end of the hose check to make sure there is not an obstruction in the tube where the hose goes into the bottom of the vacuum to the brush roll. Make sure your filters are replaced at least once per year and the bag is not full or has a lot of fine powder dust in it which can clog the bag.

Jun 13, 2014 | Riccar 8955 Upright Vacuum

1 Answer

Miele upright vacuum makes loud noise and dust comes out at bottom


It sounds to me like one of the hoses is plugged, probably the one that comes from the brushroll. That would make the dust and dirt come back out the front and would not let the vac pick up like normal. Clear the plug and you're machine should start cleaning better again.

Nov 09, 2013 | Miele Vacuums

1 Answer

LOST SUCTION what now ?


If it has suction at the tools and lots of it, you're not plugged. If there's low suction on the tools you're on the right track. Follow the airways back and you'll find the plug. Also check the base where the dirt goes 90 degrees that's almost always where a plug is going to start. A new belt might do it if the cloud you're talking about is rubber dust and rubber smell. Take the bottom plate off and look for plugs/a stretched belt there. It's really tough without seeing it to help. They can have bad motors from the factory as well which can make for smoke and burnt electrical smell.

Good luck!
The vac Dr

Jan 12, 2013 | Hoover Whole House Bagless Upright,...

2 Answers

On the back of my lg kompressor vacuum below the retractable cord is a suction plug that keeps sucking in when the vacuum is turned on it is supposed to stay out the increase suction. what is the solution...


Remove the hose fitting on the lower back of the vacuum and you will probably find a large amount of debris lodged in the hose. That hose leads to an opening right behind the main roller brush. If you remove the brush, it is easier to remove any clogs that are inside the hose. Once you have checked that there is no clogs in that hose reconnect the hose and the brush. You should then remove all three filters and wash only the two filters inside the canister. The third filter is a HEPA filter located in a compartment on the lower front side of the vacuum. Make sure you do not wash the HEPA filter.Clean it by tapping it inside a trash can outside the house since a lot of dust will come out of it. Once the other two filters are dry, put them back inside the canister and also jake sure that the canister is empty and clean.

Mar 15, 2011 | LG Kompressor Upright Vertical Cyclone...

1 Answer

I have a Bissell DigiPro canister vacuum and it has no suction. It is only 4 months old. What would the problem be?


Probably a clog in the hose. Disconnect the hose at both ends. Drop a coin in one end and allow it to fall through and out the other end. If it doesn't, the hose is blocked. Plug the end of the hose into the blower of the vacuum and turn it on. Make sure the other end of the hose is in a plastic bag. This should clear the clog.
Also, check the power nozzle behind the brush. Something may have gotten caught in the elbow near where the wand plugs in.
A full bag will also cause this, or if there's a lot of fine dust in your area, clogged pores in the bag will act the same as a full bag.

Jan 20, 2011 | Bissell 6900 DigiPro Bagged Canister...

1 Answer

Carpet setting: the brush drive does not work with the carpet setting. Is there a way to remove the bottom to determine if something is caught in the system?


To determine if you have a clog, first remove the attachment hose like you were going to put an attachment on. With the vacuum in the upright position, turn the vacuum on and place your hand over the hose. Do you feel a strong suction? If not remove the hose attachment by turning the locking ring at the end of the hose on the back of the vacuum counterclockwise, then remove the hose. Stretch the hose to it's fullest length several times. I would do this over some plastic or outside to keep the dust down.
Once you have done this replace the hose turning the locking ring clockwise to lock it in place, give the hose a little tug to make sure it's attached and locked.
Again, with the hose free from the agitator turn the vacuum on and fee for a good suction.
If you still don't have one then you likely have a plugged filter.
You will need to remove the dust bin.44d2af9.jpgOnce the dust bin is removed, over you trash can empty it by pressing the dustbin door release downwards. Now rotate the dustbin lid counterclockwise to remove the primary filter. With the lid removed grasp the filter and turn counterclockwise to remove the filter.
52c5f65.jpg
Pull the filter out over a trash can. Once out inspect it, if it's dirty you should wash the filter in warm water until the water is clear. When finish let the filter air dry for 24 hours before reinserting it.
Upon reinserting the filter, turn it clockwise to lock it in place, install the filter cover with a clockwise rotation to lock it in place and reinstall the dust bin.
Now plug the vacuum back in and again with the hose removed from the agitator or brush and ready to install an attachment then the vacuum on and you should have a solid suction.
These vacuums are really prone to poor suction if the filter get dirty. Because they have washable filters, you should take time about one a month to clean the filters.
Thanks Dorrian

Aug 13, 2010 | Kenmore Progressive Bagless Upright with...

2 Answers

IT DOES NOT WORK AT ALL


Try letting unit cool. If container was full it may have overheated. Also should clean filters while cooling down. If this does not work then its time for the shop. Most likely the cord.

Oct 09, 2009 | Panasonic Vacuums

1 Answer

Main vacuum suction won't turn off


try cleaning out hoses,if that dont work turn it on its side if the roller doesnt spin u need to change belt if it does take the bottom cover and try cleaning out the hole under roller

Nov 22, 2007 | Eureka Altima Upright Vacuum Model 2996AVS...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

47 people viewed this question

Ask a Question

Usually answered in minutes!

Top Electrolux Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18387 Answers

yadayada
yadayada

Level 3 Expert

74945 Answers

Mack Baxter

Level 3 Expert

381 Answers

Are you an Electrolux Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...