Question about Aquabot Pool Rover Above Ground Robotic Pool Cleaner

Open Question

My aquabot pool rover is not running. power is going in but not working

Posted by on

Ad

5 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad
  • 1 Answer

SOURCE: Aquabot is pushing out water but will not move to clean the pool

We've had this happen a few times because we use and abuse our poor bot. I sent it out for repair twice. Then I ordered parts. Self repair was tedious for a non-mechanical guy like me but I did it. Often it is the belts that need to be replaced. Next the rubber tracts. It's worth repairing. And worth repairing yourself if you can.

Posted on Jul 18, 2009

Ad
  • 15 Answers

SOURCE: won't go in shallow end to clean

If your floats have started to absorb water, the unit may become reluctant to climb the slope from the deep end to the shallow end, although it may still at least start to climb and clean the wall. There are 3 installed floats in the unit bottom plate: 1 "h" float and 2 pocket floats. Aqua Service Distributors in Sequin, TX had a good price on replacements. Good people, too. S. Christian dansker01@msn.com

Posted on Aug 22, 2009

  • 2 Answers

SOURCE: pool rover JR running slow

This has happened to me several times. Hair can get caught on the impeller. This causes the flap inside the jet to not close completely. Unplug the unit, remove two screws off the jet exhaust and gently remove the hair.

Posted on Aug 28, 2009

Geekman
  • 32281 Answers

SOURCE: aquabot is cleaning only one area of our pool and

The pool hose that is attached to the Aquabot gets set into a pattern so it moves to one part of the pool. Remove the pool hose and rotate it approx 100 degrees and re-attach it, then it will clean the pool. You may need to rotate the hose again to get the cleaner to clean the whole pool area.

Posted on Jun 03, 2011

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you clean the filter on aquabot


I have a small stream nozzle on my hose that puts out a good but of pressure. I turn the filter bag inside out and spray it til it's white. I then turn it back in and spray water from the inside out. The bag is also machine washable if it still isn't clean.

Jun 18, 2014 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

Pool rover has like patrolum jelly on it around bag


It is a type of algae. Wash it off and bleach it or tilex it.

Jun 01, 2014 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

Pool rover goes only one direction


they usually do unles its et the other way.. if its working leave it alone..

Jul 29, 2012 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

Rover only goes one way


I had this same problem. I took the Rover out of the pool, removed the filter, turned it right-side-up and shot a strong blast of hose water into the outlets where the water exits to propel the Rover. Do both sides over & over a few times. That should do it.

Jul 29, 2012 | Aquabot Pool Rover Above Ground Robotic...

2 Answers

Blows fuse when turned on


Mine is doing the same thing, but I have searched and not found any solutions...

Jul 06, 2012 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

My pool rover goes one way but wont turn around just keeps pushing against the wall


Hello Kathy,

I have the same problem. Do you already have a solution?

Regards,

Bob from belfium

Jun 10, 2012 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

The aquabot doesn"t go all


If you can wiggle the cord and make the pool cleaner work, it sounds like an electrical problem. If this is the case, you need to have it serviced by a professional. There are a few things you can check first, though. Make sure that the filter bag is clean and clear of debris. Make sure that all lint, cloth, or debris is removed from the impeller.

Sep 10, 2011 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

Online instruciton manual


Here is a page of articles from aquabot ,, lots of instructions you can view ..

http://www.123aquabot.com/Articles.htm

Please Vote !!

May 15, 2010 | Aquabot Pool Rover Above Ground Robotic...

1 Answer

Pool rover JR running slow


This has happened to me several times. Hair can get caught on the impeller. This causes the flap inside the jet to not close completely. Unplug the unit, remove two screws off the jet exhaust and gently remove the hair.

Mar 13, 2009 | Aquabot Pool Rover Above Ground Robotic...

Not finding what you are looking for?
Aquabot Pool Rover Above Ground Robotic Pool Cleaner Logo

Related Topics:

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Aquabot Pool & Spa Experts

Robco Water
Robco Water

Level 2 Expert

239 Answers

The Cover Guy
The Cover Guy

Level 2 Expert

64 Answers

David Spradling
David Spradling

Level 3 Expert

5045 Answers

Are you an Aquabot Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...