Question about Jl Audio 10W3v2 Car Subwoofer

1 Answer

JL Stealthbox 10w3 Subwoofer just shut off no sign of problems just quit working im not stressing it out by operating it above its limits its being powered by a JL HD900/5 AMP im concerned it might be broke but its not even 4 months old.....suggestions on what my problem is and if infact it sounds like it was broke.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 58 Answers

If this woofer is a dual voice coil woofer and if you are running your amp bridged or in mono would suggest try wiring your woofer in series.But before Idid anything I would unhook the woofer from the amp and pop it with a battery to make sure your woofer is still connected.

Posted on Sep 05, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Crank position sensor 2004 passat


reads off of flywheel on most cars, look around bell housing

Sep 02, 2013 | Jl Audio Volkswagon Passat Gray Subwoofer...

1 Answer

1994 gmc truck code 43


Code 43 is related to the knock sensor, this sensor informs the computer when the engine is knocking (pinging) and retards the timing.

Check to make sure the connectors to the sensors didn't fall off or that they are not loose.

zjlimited_421.gif


Many times the wrong knock sensor is installed.

1. There are two different knock sensors for this vehicle, depending on whether the engine has a knock module on the intake.
2. If it does not have the knock module, then the knock sensor should have about 3500-4000 ohms resistance.
3. If it does have the knock module, then the sensor should have about 100,000 ohms.

Hope this helps.

Jun 08, 2011 | Jl Audio Chevrolet And GMC Full-Size SUVs...

1 Answer

Some time dorse dose not open from key


Sub box is not likely to effect your door locks working.

Apr 22, 2011 | Jl Audio BMW 3 Series Gray Subwoofer...

1 Answer

I have a jl audio w3 that doesn't play or make any noise. I bought it brand new, never had been installed. Pressing the cone feels smooth and precise, so there is no signs of the coils being burnt out. The...


Id say take it back to where ever you bought it from and get an exchange. Have them test it there and see if it works. I have a JL W6 and have had JL's for a long time.To hear of something like this with a new JL is very rare. Just may be some kind of defect. Bring it back, get it tested and go from there.

Jun 01, 2010 | Jl Audio 10W3v2 Car Subwoofer

1 Answer

How to wire a JL audio 12W3v2-d2 subwoofer . there are two sets of terminals how are they connected two the amp


http://mobile.jlaudio.com/support_pages.php?page_id=161

THE ABOVE LINK WILL TAKE YOU TO THE CORRECT PAGE ON THE JL AUDIO WEBSITE THAT PROVIDES A NICE TUTORIAL ON CONNECTING YOUR SUBS. THIS IS FOR THE DUA VOICE COIL SUBS. LET ME KNOW IF YOU NEED FURTHER ASSISTANCE.....V

Jan 02, 2010 | Jl Audio 12W3v2-D2 Car Subwoofer

2 Answers

JL 12W2 Subwoofer


bad wires to the cone from the conectors

Oct 01, 2008 | Jl Audio 12W3 Car Subwoofer

2 Answers

Jl audio 250/1


ok what is the amp out put of your altanator and were did you hook the romte turn on wire two. It is usally blue.

Jul 20, 2008 | Jl Audio 250/1 Car Audio Amplifier

1 Answer

Sub does not operate


There could be many issues, from fuses in your amp, to power getting to your amps, to "low" impedance on your amp, and the circuit shutting down. Or it could even be your head unit, perhaps there is a setting on the HU that turns ON/OFF the subwoofer. BTW, you are running to low of an impedance on that amp. If my memory serves me correct, the lowest impedance that they JL Audio recommends is 1.5 Ohms.

Jun 25, 2008 | Orion H2 12.2 Car Subwoofer

Not finding what you are looking for?
Jl Audio 10W3v2 Car Subwoofer Logo

161 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...