Question about Freeplay Energy BayGen AM/FM/SW Radio

Open Question

My freeplay classic radio wind up unit making noise when running. What can I do about this? Thanks, John jdnastasijr@yahoo.com

Posted by on

4 Suggested Answers

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

  • 883 Answers

SOURCE: crank problem

the drive mechanism has failed. try this. ensure it is fully unwound. then open it. then look for some part of the drive gears or belt that has broken or has slipped off. caution, you MUST ensure it is fully unwound prior to opening it.

Posted on Jun 04, 2007

  • 2 Answers

SOURCE: Original Freeplay windup radio.

it sounds like your drive belt has worn out. Check ebay, there is a guy who sells the belts. it is a thin O ring type drive belt and is simple to fix. Search for "baygen belt".

Posted on Jul 29, 2008

SOURCE: summit freeplay "locked"

If you push the time set and alarm set buttons simultaneously this will lock/unlock the radio

Posted on Aug 26, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When turning the crank, the spring slips, and the crank flies back to original position. Spring will not wind up.


One day while cranking the freeplay PLUS Radio on a job site with no power, something inside snapped, and made a horrid grinding noise. All of my co - workers laughed. From then on I only used the radio with the AC plug in adapter.
After 8 years of keeping the freeplay plugged in to listen to it I finally decided to open it up and take a look.
Low, and behold I found some broken pieces that looked like a belt. HMMM?
After a little more investigating I found the 2 drive wheels that power the generator... with no belt on them. I looked in my junk drawer, and found a small blue rubber band amongst the others that I save from packaging items. It looked suitable to do the task. After stretching it around the generator drive wheels, I cranked it up, and IT WORKED!
I'm still waiting to see how long this fix works, but in a pinch... keep some rubber bands and a phillips head screwdriver around. This may be the same problem your having. I'm now getting the long lost last laugh.

Hope this helps! KMT

KMT



















Feb 19, 2011 | Freeplay Energy BayGen AM/FM/SW Radio

1 Answer

Cobra 29 ltd classic will not power up


Hi pig pen, my name is John. Welcome to FixYa. Check that the in line fuse is not blowed. Make sure that you are getting power to the unit, and that it is grounded good. Let me know if you need more help from this point,and I will post the solution here. Thanks for choosing FixYa...John

Dec 03, 2010 | Cobra 29 WX NW ST 40-Channels Base CB...

1 Answer

I have a cobra 29 ltd chrome and it making a lot of static noise while driving or idling. it transmits and recieves fine though


Hi, my name is John. Welcome to FixYa. Try running your power strait from the battery, that will bypass a lot of your noise. RED (+) ground (-) . Thanks for choosing FixYa....John

Nov 30, 2010 | Cobra 29 LTD CB Radio

1 Answer

I have had a Cobra 29 BT installed and my reception is nothing but loud static only when moving. It is a 2010 Freightliner and SWR is consistently high at about 3.0. Is this a coax or antenna problem?


Hi,my name is John. Welcome to FixYa. It could be both. Try running your unit direct from or to the battery, bi-passing all ignition noise. Make sure your antenna is getting a good ground, have your SWR checked at a near-by CB shack, or Radio Shack all for free. Thanks for choosing FixYa....John

Nov 16, 2010 | Cobra 29 LTD CB Radio

1 Answer

When the engine is running all i hear is engine noise how do i fix this


Hi, my name is John. Welcome to FixYa. Try running your red and black wires directly to the battery. Then if your radio has a Noise Blank switch or a noise limit switch, turn it to on. Good luck and thanks for choosing FixYa...John

Nov 05, 2010 | Radio Communications

2 Answers

I have an original freeplay clockwork radio which has died. Help!


Hi , you have probably expired the battery life out of the radio [ they have a recharge battery life ] but all you have to do is replace those recharge batteries with new recharge batteries and your as good as new

Jun 12, 2009 | Freeplay Energy BayGen AM/FM/SW Radio

2 Answers

Original Freeplay windup radio.


Tony,

Can't help you with the aerial. Mine made the same noise when winding down and I fixed that by pouring talcum powder around the windup section. Let it unwind and allow the talcum to go in,,,, and presto.......no more grinding noises.

Carlo

Jul 07, 2008 | Freeplay Energy BayGen AM/FM/SW Radio

4 Answers

Spring broken?


Solution #2 is correct. My Baygen Freeplay radio was running fast and mine had a broken belt. I could not find a belt on eBay. After hours of searching the internet, I fond a replacement belt at http://www.kenselectronics.com/lists/belts.htm I have the older large Baygen Freeplay radio without solar power and this is the belt that fit my radio... AV-SBS9.5 Replaces SBX9.5 & 1407-36 & SCX9.5 square 9.5 x .047" belt, Baygen Freeplay. Just search the website above... they also have a second size Baygen belt that might fit the newer Baygen Freeplay radios???

Feb 27, 2008 | Freeplay Energy BayGen AM/FM/SW Radio

2 Answers

Summit freeplay "locked"


If you push time set and alarm set buttons simultaneously you can lock/unlock the radio

Oct 12, 2007 | Freeplay Energy Summit AM/FM/SW Radio

2 Answers

Crank problem


the drive mechanism has failed. try this. ensure it is fully unwound. then open it. then look for some part of the drive gears or belt that has broken or has slipped off. caution, you MUST ensure it is fully unwound prior to opening it.

Jun 03, 2007 | Freeplay Energy Plus AM/FM/SW Radio

Not finding what you are looking for?
Freeplay Energy BayGen AM/FM/SW Radio Logo

Related Topics:

72 people viewed this question

Ask a Question

Usually answered in minutes!

Top Freeplay Energy Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you a Freeplay Energy Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...