Question about Vacuums

1 Answer

Belt gets hot turns the brush just not as it should what could this be please help

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 377 Answers

Sounds like the brush is binding around the rod that runs through the center of it. Remove the brush and lean all the debris off from it. Spray a little WD40 on the ends of the center rod and work by hand to loosen it up a bit. When you replace the belt, be sure it is put on correctly.

Posted on Sep 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Oreck brush only turns a tiny bit and belt pulley get hot belt not turning much either


If your brush is not turning properly then you need to check the bearing ends to see if there is any hair, string, or thread wound around the brush shaft. If there is and you can remove it, that might fix your problem otherwise I would suggest getting a new brush roller.

Jun 30, 2014 | Oreck XL Ultra Bagged Upright Vacuum

1 Answer

The brush bar will not spin. The belts melt when I turn it on and the belt drive is hot to touch with smoke coming out.


The belt is rubbing the foot plate.Check to see if the foot plate is damaged.Allso check the bearings in the brush bar are free and spin without the belt on.If you cant spin the brush bar by hand with the belt not attached then your bearings are seized.Get a new brush bar

Dec 30, 2010 | Bissell Vacuums

1 Answer

Motor gets real hot on little up right


hi,
f your motor got too hot there is a motorguard switch on there and it has to cool down before it will come back on.check under the vacuum and see if you can turn the brush roller by hand,unplug first.if it turns real freely then the belt is broke.if you can't turn it at all then the brush roller is either jammed or the bearings on the brush roller are froze up.and if thats the case, that will cause your motor to overheat and shut down.if the brush roller and belt are ok then the brushes on the motor might be going bad....
http://www.wikihow.com/Fix-a-Vacuum-Cleaner
.... hope this has helped you... thanks...

Sep 17, 2010 | Vacuums

1 Answer

Dirt Devil overheating Belt Okay


the belt is probably worn , so when the spool turns it heats up and looses friction with the belt.

Jul 05, 2009 | Dirt Devil Featherlite Bagless Vacuum...

1 Answer

The belt on my oreck xl keep breaking


the brush roller is siezing up on you.try to take the brush roller out and clean it real good .pull the ends off and clean them to things get caught up and wrapped around them and keep them from turning.before you put the new belt on clean the motor shaft .usually when a belt breaks it leaves burnt rubber on the shaft .if you don't clean it the new belt won't last long.please leave feedback.i hope i was some help to you...pete

Dec 26, 2008 | Oreck XL2200 Bagged Upright Vacuum

4 Answers

Hoover Steam Vav & Spin Scrub #F5899-100


Sorry it is not belt driven. There is a turbine that drives the brush. You have to remove the top cover to get to it. But if the motor smells hot, then you may have a problem with it also.

Apr 18, 2008 | Hoover F7431-900 SteamVac Vacuum

1 Answer

Hoover wind tunnel vac


If the belt is getting hot, then it is slipping instead of turning the brush roll. Check thge brush roll, make sure the ends are turning freely. Is the motor running ok? If it is then either the brush roll is bad, need a new belt, or something is catching the belt, not letting it move.

Mar 22, 2008 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Vacuum motor shaft too hot


Check the brush roll ends, will they turn easily or is one frozen. If so, you need to replace the brush roll. If the motor turns on, it and the belt are trying to turn the brush roll and can't. Also check the ends where the brush roll sits in and make sure it hasn't overheated and melted., If it did you will have to replave the base.

Mar 11, 2008 | Dirt Devil Featherlight Bagless Upright...

1 Answer

CHANGING THE BELT


Did you check the brush roll, the ends maybe aren't turning freely. May have to replace it, (Part # R98Z6064) I assume you put the correct belt on it (Part #S01Z6000). Are the sides ok where the brush roll sits in?

Mar 04, 2008 | Vacuums

2 Answers

Eureka 5197 self propelled bagless upright


Did you check the brush roll when you changed the belt? The smell of rubber would inducate a belt slipping. So if the brush roll (part #61308-2)isn't turning, the belt would get hot and would be slipping. If the motor sounds real loud, then you could have a bad motor(part #60775-4).

Feb 14, 2008 | Eureka 5197AT Upright Vacuum

Not finding what you are looking for?
Vacuums Logo

Related Topics:

13 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...