Question about Epson EMP S1 Multimedia Projector

1 Answer

Epson s1 Hi there. I have had the projector for 8 years and recently got a problem. The projector turns on fine adn works great for about 1 or 2 minutes and then a section of the picture fades to a light white and doesn't go away. Not sure why just the one section is affected. I have recently hooked up Direct TV with HDTV to the projector and thats when the problem started, but I am not convinced that is the reason. I have also tried a new bulb which did not solve teh problem. Please help if you can. Do I try a repair shop?

Posted by on

  • cadencesdad Jun 17, 2008

    I took the projector apart and cleaned it out with a blower and it fixed the problem

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,447 Answers

Hi-
before you send it to a repair shop pls try to remove all the devices that you attach to it and check if you are still going to get those light whites after awhile, or try using a different device in which it uses a different cable, did you attach a receiver as well from the tv to projector? try changing the cables as well. update me after you performed this steps, if it resolve it pls rate as fixya if not pls reply back. Thanks!!

Posted on May 10, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Epson EMP-S1 projector shows pink color with VGA input only, ok with video input and menu screen. What can be the problem?


With the VGA you have a bad cable or a bad input jack. I would bet on the cable first. You are missing the green or the blue on the screen and that is why the red/pink is more pronounced now.

Oct 04, 2012 | Epson EMP S1 Multimedia Projector

1 Answer

My epson EMP-S1 projector won't turn on. It worked fine two weeks ago but the power lights won't even come on now.


leave it plugged in for a few hours and see how it goes im talking like 4 hours... if still nothing then it could be the fuse on the main power board.... hope this is helpful :)

Feb 28, 2011 | Epson EMP S1 Multimedia Projector

1 Answer

Showing flourescent pink on display


Went to another site that offered commonly asked questions about product. Found the answer at a faster pace.

Jan 21, 2010 | Epson PowerLite S1 Plus Multimedia...

1 Answer

It stopped working. I assumed it was the bulb but it's not.


A hornet had built a nest in the cooling fan. this stopped the fan spinning. I removed the nest & re-assembled the projector. Now working fine. Also, as it wasn't the bulb, I now have a spare. Think I'll keep a cover over the unit when it's not in use so no more hornet nests appear.

Jan 11, 2010 | Epson EMP S1 Multimedia Projector

1 Answer

Projector lamp wil not turn on.


NEVER BEFORE OFFER ON DELL DLP PROJECTOR 2400MP
3000 Lumens Brightness, XGA Resolution, 2100:1 Contrast Ratio
Sony, Sharp, Hitachi, Toshiba, NEC, Benq, Acer, Epson All Are Above Rs 60000/-
Great Offer from Dell Pay Rs 42000/- And You Get
Two Years Warranty +
One Additional Lamp Worth Rs 15000/- +
One Projection Screen 6 by 8 with Tripod Stand worth Rs 7000/- Absolutely Free.

Limited Period Offer.


Please contact at
It gear. In
Shop no 14, Sakhai plaza,
Nr. Kothrud Tel. Exchange,
Kothrud, Pune, India. Land mark- Shree Shivaji Statue. Telephone -020-66021475, Hand Phone - 9850557001.
Contact person- Ketan
www.itgear.in

Jun 05, 2008 | Toshiba TLP 261 Multimedia Projector

1 Answer

Emp s1


Hi Sam

Have you tried replacing the lamp ? If you have and the problem still persists try swopping the Ballast ( Lamp's power supply ) It solves this kind of problem 99.9% of the time.

Mar 24, 2008 | Epson EMP S1 Multimedia Projector

1 Answer

Epson emp s1


hi,

Pls check the lamp condition.

Viren

Jan 18, 2008 | Epson EMP S1 Multimedia Projector

2 Answers

Lamp is on but not no signal from projector coming out !!!


i figured it out. open it up, and make sure the ribbon cables are securely plugged in.

May 01, 2007 | Epson PowerLite S1 Plus Multimedia...

Not finding what you are looking for?
Epson EMP S1 Multimedia Projector Logo

Related Topics:

261 people viewed this question

Ask a Question

Usually answered in minutes!

Top Epson Multimedia Projectors Experts

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

The Knight
The Knight

Level 3 Expert

68301 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5653 Answers

Are you an Epson Multimedia Projector Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...