Question about Coleman Powermate Premium Plus 6250W Portable Generator

1 Answer

I bought this generator it has been sitting for awhile and was low on oil on one side i added oil but still acant get it to start

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 97 Answers

Remove the spark plug and wile holding with a pair of pliers
ground the metal side of the plug against the top of the motor on a bare spot
set the run switch to run and crank the engine look for a spark if theirs a spark
re install the plug.
check the gas line at the carb by removing the
hose and turning on the gas valve under the tank.
if gas flows then replace the hose back.
if theirs no gas then you have a plugged fuel line or gas valve
their is also a screen in the tank attached to the valve remove it and install a in line filter
it will be easier to replace later if it happens again.
remove the air filter and crank engine with the choke closed
check for a gas smell in the carb hole by smell after cranking engine.
if wile checking for a smell of gas at the carb and their was none then you can have a stuck float or
gummed up carb remove and dissemble clean and at that point rebuild the kits are only around $20.00 and a float $6.00+.
if ok remove the spark plug again and set run switch to off
place a finger over the plug hole crank finger should be blow-en from the hole
and a wosh of air if ok. go to next step.
if the pressure did not blow your finger off you may have a stuck valve or a bent one
this will require removing the head for repairs.
take in for service.
if there is no spark with plug removed remove wires from the run switch and connect
together and remove wire from the low oil sensor crank. if spark replace the wire back
on low oil sensor crank if no spark replace the low oil sensor reassemble run.
if the is no spark with the wire on the sensor then replace the run switch.
re assemble run. if their is no spark with oil sensor disconnected and run switch wires
connected to each other remove the front air flow cover to expose the coil check wires for any
bare spots repair as needed. on the top on the flywheel theirs a coil their will be a spade plug
or a wire small that is a kill wire disconnect and crank check spark if spark then that wire is shorted
in the loop and you have to trace it it will go to a wire stud mounted to a plate under
the carb with a plastic mount this can be cracked and shorting bypass and try again still
no spark use a match book cover and lower the coil to the flywheel with the match book cover
in be tween and disconnect the small wire crank if no spark the coil unit is the issue replace
some people will say sand clean the tops of the magnets built in to the flywheel this is a myth
it don't matter but feel free to clean anyways it don't hurt.
this seams allot but it is a complete diagnoses the fuel,spark and air system if all this is ok and still don't run you have a serious internal issue the engine will either need
major work or replacement. i hope this all helps you.

Posted on Sep 02, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

It will start for a minet then shut off and wont start till it sits for a half hour


Check to see if the fuel filter is clean or change it. If the screen in the bottom of the gas tank is clogged, that will do it too. If those solutions do not work, check the oil level and condition of oil, if it is low or dirty the low level switch will shut it down.

Jan 21, 2013 | Coleman Powermate Powermate 5000W...

2 Answers

White smoke coming form exhaust


if you added oil before storing it then it's the oil burning off

Oct 03, 2012 | Kipor IG3000 Inverter Generator

1 Answer

Honda 5000 generator with remote starter running rough.. tis like ******* or something.. oil was almost empty so i stopped generator and added oil and restarted.. can u give some advice as to how to remedy...


Those generators are set up with a low oil saftey but your gonna want to check compression anyways just to verify it is where it needs to be. Im gonna guess its to be between 120-160 psi, check your manual for the service limits. after that check your air filter, valve lash, fuel filter etc etc.

Mar 29, 2012 | Honda Mmd 5000 Watt Electric Start...

1 Answer

Unit just shuts off after about 15 minutes of operation


Hi and welcome to FixYa, I am Kelly
This may very well be as simple as having to make sure the generator is sitting level and the OIL level is fully serviced. The generator has a low oil level sensor. The Subaru / Fuji Heavy Industires EH and EY series engines seem to be very sensitive to oil level. I can tell you from owning one myself and from my 40 years of experience. I replaced my oil level sensor and in a few weeks was experiencing the same problem all over again. I finally disconnected one of the wires from the low oil level sensor and resigned myself to checking the oil and servicing the oil to full each time I added fuel. (It works for me)
There are other things that can cause this symptom. Without your exact model number I can not look it up and make other recomendations at this time. If you still have the problem first try disconnecting ONE wire from the low oil level sensor after making sure the unit is fully serviced with oil. Then see how long it is before it shuts off. (If at all!) Once you disconnect the low oil level sensor you MUST check and service the oil if necessary each time you add fuel.
Should the problem persist respond here with a COMPLETE model number and I will help you.

Thanks for choosing FixYa,
Kelly

Aug 31, 2011 | Coleman Powermate Subaru 5000W Portable...

1 Answer

Runs for awhile shuts down and will restart but will run awhile and shut down


Check your oil, you have a low oil sensor on your unit and if the low oil sensor will shut the engine down,

Aug 28, 2011 | Dewalt DG6000 Heavy Duty 6000 Watt Gas...

1 Answer

I have a centurion 3250 watt portable generator it was working fine 2 days ago but it will not start. Will not being on a level and flat surface cause it to not run ?


Hi and welcome to FixYa, I am Kelly.

Your question:
"Will not being on a level and flat surface cause it to not run?

In short YES!

Generators have low oil level sensors that are quite fussy about their orientation. If there are any inclinds a generator is sitting on you can get FALSE low oil level shut downs.
You must make sure the generator is full of oil and I do mean FULL. Additionally do what you have to so that the generator sits level horizontally.

A quick way to find out if the low oil level sensor has been activated is to simply check spark.
If you have no spark:
FILL WITH OIL
Re-orient generator to a level position (15 to 30 second wait)
(Check spark again) If you now have spark your low oil level sensor had gounded the ignition because it sensed a low oil level either from an actual low oil level condition or the unit was on an incline causing a false low oil level senor activation and a subsequent engine shut down.

Thanks for choosing FixYa,
Kelly

Aug 28, 2011 | Electrical Supplies

3 Answers

2002 FATBOY, AFTER SITTING A WEEK, CHANGED OIL AND FILTER,VERY LITTLE OIL CAME OUT, ASSUMED ENG. OIL LEVEL WAS LOW, BUT NO OIL LEAKS DETECTED. ADDED 3 QTS , ROAD BIKE ABOUT 20 MILES. NOW ENG. IS LEAKING...


The Oil Capacity is 3.5 qts. (3.3 L) are you sure you pulled the right drain plug, and drained the ENGINE oil? The engine oil drain hex bolt is located on the right side of the motorcycle and is removed/installed horizontally.
Transmission oil drain hex bolt is located on the left side of the motorcycle and is removed/installed vertically.

Jul 25, 2011 | 2002 Harley Davidson FXST Softail Standard

1 Answer

I tried to start my new coleman powermate 6250/5000,


Do check the oil after it has tried to start. Low oil cutoff would certainly cause the problem. Look for the "lost" fuel shutoff valve... there usually is one.

Apr 24, 2010 | Coleman Powermate Premium Plus 6250W...

1 Answer

Laptop has been sitting for awhile. I bought a


Should run just off adapter. Have you hooked an external screen to it to see if its the display.

Dec 14, 2009 | Toshiba Satellite M35X-S161 Notebook

1 Answer

Generator


I had same problem, oil sensor was reading low oil and it was full.Have sensor changed

Oct 03, 2008 | Coleman Powermate Premium Plus 6250W...

Not finding what you are looking for?
Coleman Powermate Premium Plus 6250W Portable Generator Logo

271 people viewed this question

Ask a Question

Usually answered in minutes!

Top Coleman Electrical Supplies Experts

John Trevino

Level 3 Expert

1383 Answers

Shawn DuRee

Level 3 Expert

355 Answers

Phil Walker
Phil Walker

Level 3 Expert

605 Answers

Are you a Coleman Electrical Supply Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...