Question about Televison & Video

1 Answer

This was posted last year. my hitachi 57f500a picture went out and sound. When you power up you can hear the clicks and the red light in front comes on solid. Out of the five leds on the power board four of them are on when powered on. the green d928 led is out, its marked as 115v switch d928 led. Any help would be greatly appreciated. PS. I bought this mans tv and I am trying to fix it. However, I don't know how to locate this Pico fuse that was suggested in the "fix" Help. thanks Jeff

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,284 Answers

On the board I believe the fuses are marked PS*** . They look like resistors that are sort of tan in color. In most cases if the 115 volt fuse has opened the horizontal output transistor is possibly shorted. I think that was Q7700 and will have a fairly large heat sink attached to it. Check it with an ohm meter in circuit to verify its good or bad.

Posted on Sep 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

57F500A, powered light on with no sound/picture, ticking noise


Over the years of servicing these sets and others for Convergence issues, I have on several times gotten defective Convergence ICs. In your case where a Resistor is now open, (Probably a 1.5 ohm 1/2 watt), I would suspect you had gotten a hold of a defective IC. I would replace them both again. Make sure to use Heat Sink Compound between the ICs and Heat Sink.(Just a thin coating on the metal area) You can get the heat sink compound from Radio Shack. They should also have the Resistor you need.
Good luck,
Skyassoc

Jul 23, 2009 | Hitachi 57F500 57" Rear Projection...

1 Answer

My hitachi 57f500a picture went out and sound. When you power up you can hear the clicks and the red light in front comes on solid. Out of the five leds on the power board four of them are on when...


There should be a solder in pico fuse(yellow) close to that LED labled E...something. It is most likely open. If so, check to see if there is a blue high voltage capacitor(2kv) in front of the H.output transistor. If yes, replace them both...if no try just replacing the pico fuse.

Jul 07, 2009 | Televison & Video

1 Answer

Power but no picture


I doubt it is the picture tube...there are three of them.. a red. a green, and a blue. Would suspect something on the power/deflection board

Jul 05, 2009 | Hitachi 57F500 57" Rear Projection...

1 Answer

Hitachi 53uwx10ba turns on & off when off red flashing light/clic


Same problem. Replaced both convergence ICs about 5 months ago. Worked fince since then and just recently no sound, no video, blinking red on front panel and clicking sound. I suspect that the ICs went bad again and blew a resistor or two. I used cheap Chinese ICs instead of the Sanyo ones and thing this is why. I'll be looking at it again and post solution.

Jan 21, 2009 | Hitachi 50SBX78B 50" Rear Projection...

1 Answer

Hitachi model 51f59j no picture no sound


YOU HAVE POWER BORAD PROB CALL PTS AND BAY THERE BORAD COMPLETE 8128249331

Dec 29, 2008 | Hitachi 51F59 51" HDTV Projection...

1 Answer

Hitachi 43F300 43 in. Rear... Problem:


units in shut down to protect further damage,poss. power supply or deflection fault

Jul 21, 2008 | Hitachi 43F300 43" Rear Projection...

1 Answer

HITACHI TV MODEL 57F500A


My hitachi 57f500a wont turn on i pulled the back off and there are only one green light on and the relay keeps clicking when the relay clicks another green light flickers and the red one come on and goes off.

May 04, 2008 | Hitachi 57F500 57" Rear Projection...

1 Answer

Have 46ux12b hitachi


2 Questions?

1., Does the unit have sound?
2., Can you hear a click?

Jan 12, 2008 | Hitachi 43FDX01B TV

Not finding what you are looking for?
Televison & Video Logo

Related Topics:

85 people viewed this question

Ask a Question

Usually answered in minutes!

Top Televison & Video Experts

The Knight
The Knight

Level 3 Expert

74136 Answers

Cindy Wells

Level 3 Expert

5102 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Televison and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...